I have no clue how to config my buttons

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie I have no clue how to config my buttons

This topic contains 5 replies, has 2 voices, and was last updated by Profile photo of herbfargus herbfargus 2 years, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #96336
    Profile photo of depress
    depress
    Participant

    Hi all, I’m pretty noob to Linux, RetroPie, and basically all things encompassing an arcade machine made from a Raspberry Pi so I hope that you will bare this in mind when responding (please don’t take steps or information for granted.)

    I have a board setup with two PS3 controllers worth of buttons (16 in total for each.) They’re both individually recognized in Emulation Station and work just great, I can get in and out of any menu’s and games as needed.

    The problem I have is that when I enter any emulator / game, the only controls that are recognized are the attached keyboard. I have no idea how to enter any menu’s to config anything, I don’t seem to be able to exit and games via keyboard either and I’m just really not sure what’s going on. I’d just love to find a “Configure Controller” page but I just cannot find one for the life of me or find anything that helps me.

    Thanks for any and all help!

    #96342
    Profile photo of herbfargus
    herbfargus
    Member

    https://github.com/retropie/RetroPie-Setup/wiki/RetroArch-Configuration

    If you are using retropie 3.0 there is an option to configure your controller in the retropie menu. If not you’ll have to configure it through the terminal.

    all the controller configurations options in RetroPie/EmulationStation

    Plug n play controller.

    #96344
    Profile photo of depress
    depress
    Participant

    I was able to get into the setup pages, but the RetroArch controller registration thing doesn’t recognize my button presses. All of the buttons work just fine and I can confirm that via jstest and they work perfectly in EmulationStation, but when I actually open an emulator it’s like they aren’t even connected, I can’t even get incorrect inputs from them.

    I tried to edit the cfg file for the device (XinMo Encoder) and just punch in like input_b_btn = “2” but that didn’t seem to work for me either.

    #96347
    Profile photo of herbfargus
    herbfargus
    Member

    Was the .cfg file you edited this file?:/opt/retropie/configs/all/retroarch.cfg when you say you have 2 ps3 controllers worth of buttons are you saying you have two ps3 controllers? Or do you have an arcade stick setup or, is it something you put together yourself?

    #96348
    Profile photo of depress
    depress
    Participant

    It’s an arcade stick setup that I put together myself. Sorry, I should have been more clear on that.

    I… technically fixed it. Very very technically. I plugged in a USB SNES Controller, and pressing ‘Y’ on that brought up RetroArch’s menu in a game… I just, have no idea. Anyways, inside here I was able to bind everything to my setup correctly and it works fine except for one thing.

    RetroArch seems to auto-bind certain things and it’s pretty inconvenient. I can disable auto-config but the damage has been done. I can’t figure out how to unbind my controller’s “R2” from opening the RetroArch menu, and I can’t figure out how to unbind keys in this menu. Any help on that?

    #96359
    Profile photo of herbfargus
    herbfargus
    Member

    The binding for R2 is a hotkey for RGUI see this video.

    As far as i understand it, In the retroarch.cfg file it will be a line called input_menu_toggle_btn it is also automatically added to the autoconfig file created when you run retroarch-joyconfig

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar