How to use mame4all

This topic contains 20 replies, has 8 voices, and was last updated by Profile photo of redlag redlag 2 years, 8 months ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #9445

    Kevin

    I finally finished installing mame4all by the retropies-setup, the one that takes 16-22 hours. Then I changed the mame section in es_systems.cfg with

    DESCNAME=MAME
    NAME=mame
    PATH=/home/pi/RetroPie/emulators/mame4all-pi/roms
    EXTENSION=.zip .ZIP
    COMMAND=/home/pi/RetroPie/emulators/mame4all-pi/mame %BASENAME%
    PLATFORMID=23
    

    I don’t think mame4all is being used because background has just blue background with the Mame logo and I’m not sure but isn’t it suppose to say Mame4all. Also when I try to load a ROM some of the roms say missing files or it bust has a black screen and then boots back to emulationstation.

    #9446
    Profile photo of Mutex
    Mutex
    Participant

    The MAME page in EmulationStation is not related to the emulator you are using. It’s just a theme for EmulationStation, so nothing will change here by using mame4all.

    Your problem with the ROMs sounds like you’re trying to use a wrong romset version. mame4all uses the MAME 0.37b5 romset. Roms from newer sets will probably not work. Google should show you how you can get that specific romset.

    #9450

    Kevin

    ahh okay thanks for that. I’ll go look for that romset.

    #9520

    Kevin

    No clue what is going wrong, but every ROM I try is simply not working. They are of ROM set 037b5, I’ve tried about 20 different ROMs and transferred it to the SD about 1-3 of each different ROM I tried. Each time I got missing files message. I also noticed when I load up cavestory it just goes back to emulation station and shows cavestory again.

    #9696
    Profile photo of twoleftbees
    twoleftbees
    Participant

    I have been experiencing this same problem. I’ve been through another post:

    …so many times I practically have the posts memorized.

    – I’ve edited my es_systems.cfg
    – I’ve checked my roms using clrMAMEpro AND RomVault – they are definitely 0.37b5
    – I have the roms in the correct directory
    – I’ve tried starting the games from the command line (bypassing emulationstation)
    – I’ve tried the complete install twice.

    But no matter what I do, every rom I try says that all the files are missing. I check the zip files directly and they’re all there.

    What are we doing wrong?

    Just in case it matters, I’ve been transferring my roms to the Pi using FileZilla and I’m a complete linux noob.

    If there is anyone out there that has solved this issue and can shed some light on this issue, please help. My inner arcade-playing child will be eternally grateful.

    #10646
    Profile photo of nemo93
    nemo93
    Participant

    hello Guys,

    this is weird. It should work almost out-of-the-box… Sorry to insist on that but did you ensure that paths are correct under the Mame section in es_systems.cfg? Do you have only one COMMAND line commented out (without the #)? Also did you try with the newest Retropie release (2.0)?

    After triple checking paths and COMMAND line then just let focus on one rom for instance “karateblz” (and your roms have to be zipped). This one works for sure and requires no special bios as far as I know. If you have issue with it then it’s very likely you are not using the correct romset for this mame version.

    hope this helps.

    #10650
    Profile photo of ademcc
    ademcc
    Participant

    Nemo93, sorry to jump in here but hopefully we can work out what’s happening here.

    My romset is 0.37b11 and worked absolutely fine in v1.10.1 with default setting (mame4all). Same roms haven’t worked in either v2 or v2.1 (SD image). The relevant section from es_systems.cfg is as follows:

    <fullname>MAME</fullname>
    <name>mame</name>
    <path>~/RetroPie/roms/mame</path>
    <extension>.zip .ZIP</extension>
    <command>/opt/retropie/supplementary/runcommand/runcommand.sh 4 “/opt/retropie/emulators/mame4all-pi/mame %BASENAME%”</command>
    <!– alternatively: <command>/opt/retropie/emulators/RetroArch/installdir/bin/retroarch -L /opt/retropie/emulatorcores/imame4all-libretro/libretro.so –config /opt/retropie/configs/all/retroarch.cfg –appendconfig /opt/retropie/configs/mame/retroarch.cfg %ROM% </command> –>
    <platform>arcade</platform>
    <theme>mame</theme>

    …and seems to suggest that mame4all is being initiated so all a bit weird to me.

    #11667
    Profile photo of nemo93
    nemo93
    Participant

    Hi ademcc,

    your es_systems.cfg looks definitely fine and I’ve switched also to Retropie 2.1 so for sure mame4all is working fine. I have not so many troubles with my romset to be honest. Some roms lack sound or doesn’t launch but only a handful of them.

    You talked about 0.37b11 romset, which is not supported. You have to stick to 0.37b5 romset (Google is your friend :)). Even if there shouldn’t be many differences between the two romsets it’s best to follow the specification! If mame4all tells you that files are missing, it’s sure 100% that it’s not the good rom for this version of mame. Did you try also the various “sets” (set 1, set 2, world, bootleg) for a given rom?

    All in all you have to be sure you’re using the proper 0.37b5 romset.

    hope this helps again 🙂

    #11713
    Profile photo of dem1980
    dem1980
    Participant

    Same problem for me with the version v2.1
    I have a lot of roms that work with version 1.10.1 with MAME using MAME4All.
    I’m using the same roms/MAME directory, and MAME4All list a lot of missing roms.
    For example, i use a neogeo.zip bios which is ok but MAME4All doesn’t recognize it in the v2.1 bbut works with 1.10.1
    :-/
    is it possible that MAME4All doesn’t seen the rom diretory or something like that ??
    In the es_system.cfg in the Mame section, the command is :
    <command>/opt/retropie/supplementary/runcommand/runcommand.sh 2 “/opt/retropie/emulators/mame4all-pi/mame %BASENAME%”</command>
    it may be :
    <command>/opt/retropie/supplementary/runcommand/runcommand.sh 2 “/opt/retropie/emulators/mame4all-pi/mame %ROM%”</command>

    #11718
    Profile photo of nbonaparte
    nbonaparte
    Participant

    Yes, it by default looks inside the emulator directory instead.
    You have to edit mame.cfg (found inside emulator folder) to look in wherever you have your roms at (usually ~/RetroPie/roms/mame).
    Just change “rompath” to the rom location (so if you have it in the same spot, “rompath=/home/pi/RetroPie/roms/mame”).

    #11788
    Profile photo of dem1980
    dem1980
    Participant

    Editing /opt/retropie/emulators/mame4all-pi/mame.cfg and replacing the line
    rompath=/opt/retropie/roms/mame
    by
    rompath=/home/pi/RetroPie/roms/mame

    now MAME4All works ! thx

    #11792

    Francesco

    i’ve also same problem with kevin…i’ve last version (2.1) of retropie and my es_systems.cfg for mame is

    <fullname>MAME</fullname>
    <name>mame</name>
    <path>~/RetroPie/roms/mame</path>
    <extension>.zip .ZIP</extension>
    <command>/opt/retropie/supplementary/runcommand/runcommand.sh 4 “/opt/retropie/emulators/mame4all-pi/mame %BASENAME%”</command>
    <!– alternatively: <command>/opt/retropie/emulators/RetroArch/installdir/bin/retroarch -L /opt/retropie/emulatorcores/imame4all-libretro/libretro.so –config /opt/retropie/configs/all/retroarch.cfg –appendconfig /opt/retropie/configs/mame/retroarch.cfg %ROM% </command> –>
    <platform>arcade</platform>
    <theme>mame</theme> 

    now every game that i open give me an error missing files and it return to emulationstation. how can i fix that?

    #11795
    Profile photo of Mutex
    Mutex
    Participant

    i’ve also same problem with kevin…i’ve last version (2.1) of retropie and my es_systems.cfg for mame is

    <fullname>MAME</fullname>
    <name>mame</name>
    <path>~/RetroPie/roms/mame</path>
    <extension>.zip .ZIP</extension>
    <command>/opt/retropie/supplementary/runcommand/runcommand.sh 4 “/opt/retropie/emulators/mame4all-pi/mame %BASENAME%”</command>
    <!– alternatively: <command>/opt/retropie/emulators/RetroArch/installdir/bin/retroarch -L /opt/retropie/emulatorcores/imame4all-libretro/libretro.so –config /opt/retropie/configs/all/retroarch.cfg –appendconfig /opt/retropie/configs/mame/retroarch.cfg %ROM% </command> –>
    <platform>arcade</platform>
    <theme>mame</theme> 

    now every game that i open give me an error missing files and it return to emulationstation. how can i fix that?

    Check the post right above yours and do the same thing.

    Editing /opt/retropie/emulators/mame4all-pi/mame.cfg and replacing the line
    rompath=/opt/retropie/roms/mame
    by
    rompath=/home/pi/RetroPie/roms/mame

    now MAME4All works ! thx

    #11802

    Francesco

    yeah now it works…i’ve another question…i’ve set my controller on retroarch.cfg but it doesnt work on mame games and fba games, where is configuration files for these?

    #11803
    Profile photo of Mutex
    Mutex
    Participant

    For mame4all press [Tab] wenn you are ingame. There you can configure the controls for mame4all and the different roms. It may be possible that saving won’t work since mame wants to write the config files to /opt/retropie/emulators/mame4all-pi/cfgs which needs root privileges. If that’s the case you have to run mame manually with sudo and configure the controls.

    pifba has it’s config file in /opt/retropie/emulators/pifba and it’s called pifba2x.cfg I think. You have to configure your controls manually in the file.

    #11810

    Francesco

    thanks for everything!!!now it works fine everything!!!

    #11867
    Profile photo of ademcc
    ademcc
    Participant

    Thank you all – updating mame.cfg as above solved all my issues (still using 0.37b11 romset)

    #12070
    Profile photo of octubrq
    octubrq
    Participant

    thanks for solving the problem, the games now work. but I have a problem, when I press TAB to configure the buttons on MAME4ALL, it works in the game, but if I put another game is not recorded my settings. one could change this?

    #12230
    Profile photo of nemo93
    nemo93
    Participant

    hi octubrq,

    have a look at this post about the permissions issue: http://blog.petrockblock.com/forums/topic/no-writing-permission-for-retroarch-cfg/#post-12219

    hope this helps.
    cheers,

    #34608

    Marty

    I had the same issue
    i somehow installed with root
    theres a mame cfg file in emulators mame4all
    rom location was pointing to root
    change to home/pi/
    and all sweet now

    #81974
    Profile photo of redlag
    redlag
    Participant

    hi,

    i stock my roms in a usb disk. /storage/MEMUP/consoles/MAME for roms MAME.
    what i have to change to works? because when i try to launch a game i have a black screen and go back in retropie…

Viewing 21 posts - 1 through 21 (of 21 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar