how to uninstall xbox controller driver, install ps3 driver [solved]

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project how to uninstall xbox controller driver, install ps3 driver [solved]

This topic contains 2 replies, has 3 voices, and was last updated by Profile photo of cortex cortex 2 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #92578
    Profile photo of patrickm

    Hi all, I’m close to the final stage of getting everything set up but I’m still having difficulty getting my ps3 controller working. I accidentally installed the xbox drivers by mistake and now emulationstation won’t detect my controller except as an xbox controller. How do I remove the xbox controller driver so that the ps3 controller is detected as a ps3 controller by ES? Or is it even necessary to remove the xbox drivers?

    I found usr/bin/xboxdrv and usr/bin/xboxdrvctl. Is the driver just these two files, or are there more somewhere? I really suck at Linux.

    I also see at shutdown “sixad not working” in the terminal. Is this related to this problem?

    I’d really appreciate any help on this.

    Edit: never mind! Solved controller issues by removing the two files listed above and doing a hard reboot.

    Profile photo of vinceabs

    Maybe you can help me. I kinda have a similar problem. I got a generic controller to work first then tried to get a 360 controller working. The 360 works in Emulation Station, but not the emulators themselves. When I load the emulators, it looks like they are seeing the generic controller as port 0 and the xbox controller as port 1 and therefore not responding to the xbox controller.

    Any idea how to remove the generic controller?

    Profile photo of cortex

    If you want to do it the easy way and just for retroarch-emulators, just try
    sudo ./Retropie-Setup/
    and choose “Register retroarch controller”.

    after you configured it, this should be your first gamepad for retroarch-emulators.

    If you want to do this for more than one Controller, you’ll have to set the gamepadindexes in the retroarch.cfg:
    sudo nano /opt/retropie/configs/all/retroarch.cfg
    and then watch out for the lines like

    so you could Change this to the corresponding Controller (I think they’re numbered by the USB-ports they’re plugged in at boot, so left upper is 0, left downer is 1, right upper 2 and right downer 3).

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar