How to setup a controller in 2.2 ???

Home Forums RetroPie Project Controller Configuration in RetroPie How to setup a controller in 2.2 ???

This topic contains 37 replies, has 9 voices, and was last updated by Profile photo of davinel davinel 2 years, 2 months ago.

Viewing 35 posts - 1 through 35 (of 38 total)
  • Author
    Posts
  • #12312

    Parasomnia

    I have downloaded the newest image (2.2), put it on my card and put some roms in the folder via startx ( copy from my usb stick).
    Teh games working in Emulationstation but my joypad don’t.

    I can just setup the controls for up,down,left,right,A,B,Start,Select,Page up &down…

    In the last image before(1.9 and 1.10),there was this nice option where I could change the buttons from the Emulationstation menu.They worked perfect then in the Genesis,SNES etc Emulators.

    Where is it now – or is it gone in this Version? That would be awful…
    How can I setup my joypad now ( It is a SNES Clone btw.)

    Thanks people

    #12316
    Profile photo of zsprawl
    zsprawl
    Participant
    sudo chown pi /opt/retropie/configs/all/retroarch.cfg
    cd /opt/retropie/emulators/RetroArch/installdir/bin
    sudo ./retroarch-joyconfig -j 1 >> /opt/retropie/configs/all/retroarch.cfg
    #12319

    Parasomnia

    Ok Thanks zSprawl
    But is this the only way? I mean type in this huge command? There was this good and easy option before, why is it gone. I dont get it…

    #12324
    Profile photo of zsprawl
    zsprawl
    Participant

    I’m not certain, unfortunately. It seems that GUI option was removed. However, once it is setup, you shouldn’t need to mess with it again.

    #12329

    Parasomnia

    Good I will do it that way. Thanks again for your help.
    Maybe someone will find the old option – I can’t still believe that they forgot it to put it in. ^^
    It was so easy and perfect…

    #12375
    Profile photo of zsprawl
    zsprawl
    Participant

    Press F1 when in-game. 🙂

    #12467

    Parasomnia

    Strange.
    When I Enter this last command :

    sudo ./retroarch-joyconfig -j 1 >> /opt/retropie/configs/all/retroarch.cfg

    It Says couldnt open Joystick 1.

    And when I press F1 in any Emulator nothing happends either…

    #12498
    Profile photo of zsprawl
    zsprawl
    Participant

    Try other values for -j. Like 0 or 2.

    sudo ./retroarch-joyconfig -j 0 >> /opt/retropie/configs/all/retroarch.cfg

    or

    sudo ./retroarch-joyconfig -j 2 >> /opt/retropie/configs/all/retroarch.cfg

    #12922

    daisyjennings

    i have been trying to set up my controller for a few hours now and to no prevail, i was using a guide on the internet that i can only assume used an older version of retrobut apart from the many problems i have had while trying to set up my pi ican’t find any of the files mentioned such as /configs/all..i created one and put an apt file in but they weren’t there before, i can set up my controller to controll emulationstation menus but no further, meaning all the roms are installed and my pi all ready i just can’t play :'( HELP?

    #12923

    daisyjennings

    ok, my bad this might now be working

    #12924

    daisyjennings

    ok this did work but i have set the buttons up wrong, take 3 or maybe 4, yes im a tit

    #12925

    ryan

    When I run the command above, everything is great, but it is asking me to configure more buttons than my controller has. I am using an SNES style controller, but the button values look like something for an n64 controller or similar. Am I ok to just pick any old button to get through the buttons I don’t have on the controller, or is this an indication that controller isn’t being recognized properly?

    #12930
    Profile photo of zsprawl
    zsprawl
    Participant

    When I run the command above, everything is great, but it is asking me to configure more buttons than my controller has. I am using an SNES style controller, but the button values look like something for an n64 controller or similar. Am I ok to just pick any old button to get through the buttons I don’t have on the controller, or is this an indication that controller isn’t being recognized properly?

    I have the same issue. I just pick a button like left paddle for all of these buttons/controls that I do not have.

    Then open up the file, and delete those lines.

    sudo nano /opt/retropie/configs/all/retroarch.cfg

    #12936

    ryan

    well… I’m not familiar with how to edit the file. The bottom two lines (with what look like they would be the help commands are cut off the tv. Is there a way to edit it from with the gui?

    #12937
    Profile photo of zsprawl
    zsprawl
    Participant

    I SSH into the box and edit the file, but if you haven’t used linux, I’m not sure how to help.

    Maybe get an X-box controller that has all the controls? /shrug

    Or download putty and SSH into the box. 🙂

    #12943
    Profile photo of smatticus
    smatticus
    Participant

    cyberduck or wincsp are your friends on windows, both offer a simple winowed interface that allows navigation of the files via mouse/keyboard. you could also use startx to do the same from the pi itself. or you press f4 to get to the command prompt and type sudo nano /opt/retropie/configs/all/retroarch.cfg and then arrow down to the end where it should say “input_player1_l2_btn = “4” ” and so on , just delete everything from there down and then press control+x to save, then press Y and then ENTER. type sudo reboot and you’re good to go

    #13105
    Profile photo of borlandoflorida
    borlandoflorida
    Participant

    Strange.
    When I Enter this last command :

    sudo ./retroarch-joyconfig -j 1 >> /opt/retropie/configs/all/retroarch.cfg

    It Says couldnt open Joystick 1.

    And when I press F1 in any Emulator nothing happends either…

    I have the same issue. Any help would be appreciated!

    #13218
    Profile photo of borlandoflorida
    borlandoflorida
    Participant

    I managed to fix this by changing the hot key button to F2 on the keyboard the having the menu button assigned to F1. I hold F2 down then press F1 and hey presto. I could then edit the input settings etc and save it as a new .cfg file. I would need to SSH into the directory and rename it retroarch.cfg to get it working though.

    #13657

    Matias

    how can you exit an emulator in from the controller in retropie 2.2??? No one seems to be able to answer that 🙁

    #13708
    Profile photo of atimmins
    atimmins
    Participant

    Exiting the emulator with the controller has been discussed many times. It works the same in 2.2 as in older versions.

    You have to set up a hot key so that you press select + start. Try adding the following lines to the config file.

    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”

    #14187

    keven the tank

    ok so I’ve followed your instructions to the letter i get couldn’t open joystick #0. also i cant seem to get it to find the roms there installed and ready.

    #17831

    Al

    I am using 2.2 as well and have followed all the steps above. When I press F2 (changed it from F1) nothing happens in game. I may have missed something with this one.

    I have tried to configure controller 2 followed this (sudo chown pi /opt/retropie/configs/all/retroarch.cfg
    cd /opt/retropie/emulators/RetroArch/installdir/bin
    sudo ./retroarch-joyconfig -j 1 >> /opt/retropie/configs/all/retroarch.cfg) it takes the commands of controller 2 but does not work in game. I have changed -j 1 to 0 and to 2 (which controller 2 seems to be seen on -j 0 and controller 1 is -j 1).

    Not sure what I maybe doing wrong.

    #18376

    Ken Walton

    G’day,

    what i found was that its not saving the config file because i permisions?

    i just started an emulator (e.g. SNES) pressed F1 to bring up the menu, went through the process of mapping the USB Gamepad, change the directory in with the config file got saved (e.g. to the Desktop) and hit save.
    Then i exited Emulationstation (F4) booted into LXDE (startx) found the directory that retroarch.cfg was saved into (opt/retropie/emulators/all/) ? thats only a guess, im at work atm, so i cant remember the exact adrress , deleted it, and moved the saved config file from where i saved it (in this case the desktop) to where the old retroarch.cfg file was, and then renamed it to “retroarch.cfg” as it was something like “retroarch-07212014.cfg”

    and that was it, rebooted back into Emulation station and all the controller config was saved and still working.

    Thats how it worked for me anyways 🙂

    Cheers
    – Ken

    #19704

    A

    Hey there Ken and thanks for getting back with me. My other problem is within a game pressing F1 does nothing for me (forgot how I did it but changed it to F2 and still does nothing for me.) Any idea what commands I need to use to apply F1 to work on my keyboard within a game?

    Thanks.

    #19705

    A

    Forgot to mention that F4 does work for me. Just F1 does nothing what so ever.

    #20573

    Al

    I just got the 2.3 image. Having the same problem that controller two does not work in games (even though this command the controller will program, just not function. sudo chown pi /opt/retropie/configs/all/retroarch.cfg
    cd /opt/retropie/emulators/RetroArch/installdir/bin
    sudo ./retroarch-joyconfig -j 1 >> /opt/retropie/configs/all/retroarch.cfg)

    F1 not working in games either. For some reason it only shows up if I launch and exit the doom port but F1 is never pressed, just shows up when exited out of the game and configuration does not save.

    When I open the menu inside of emulationstation, there are some glitches with the menu. If I go to scrapper all the text inside of that are square looking letter instead of readable letters.

    Also installed Quake 3 from the setup menu but when launching the game it says failed to launch and cannot find ioquake3.arm.

    #21507
    Profile photo of imgpoz
    imgpoz
    Participant

    I have the newest image (2.3) and in both 2.2 and this I have not been able to get my joystick/controller to work. The keyboard works fine in ES, but not in an of the Emulators and when I try from the command line to configure the joystick I get the error message “Couldn’t open joystick #0″. I’ve tried changing the joystick code to 1, 2, etc. but no luck.

    Has anyone been able to configure their joysticks? Am I missing a driver or perhaps since I’ve got my Arcade joystick plugged into a Keyboard encoder (along with a real keyboard in the pass through) and then into my Pi, is there a conflict?

    I can’t wait to really try RetroPie/Emulation Station but this is driving me crazy.

    Any help would be appreciated. Thanks!

    #26774
    Profile photo of merlin2049er
    merlin2049er@gmail.com

    Thanks, found this really helpful. Up and running in 1/2hr.

    #34370

    Edri Espinoza

    Gracias. Toda esta información me fue útil. Pude configurar mi Joystick MaxFire Blaze3 correctamente, también la configuración de video. Y lo uso con un televisor. RCA obviamente. (Thanks, all the information here were really useful, i could correctly configure my MaxFire Blaze3 Gamepad, and the video settings too, and i’m using it with an RCA TV.

    #36080

    Elliot

    I am having issues setting my 2 wireless xbox controllers configured within RetroArch.

    I followed the directions in the wiki, both are recognized/tested with jstest and work in Emulation Station. (Running v 2.2)

    Now, I am trying to get the controllers set up with RetroArch. When I run the retroarch-joystick command ./retroarch-joyconfig -o p1.cfg -p 1 -j 0 to output to a config file, the utility stops on

    `
    Configuring binds for player #1 on joypad #0

    B button (down)
    `

    and just sits there. I also tried configuring these from the retropie_setup script. From there, it gets to goes past that step but every button gives a timed out message.

    Any help would be great, thanks!

    #37664

    Michael

    Hello,
    everything works great. Thank you so far. But there is still one problem left:
    On my wireless Xbox 360 controller is everything functional except the “START” Button. Everytime I use “START” the game ends (via console) and the emulations´menu is popping up. I´m also using an Alienware Gamepad which is working 100% fine. I used the configuration – with both of them – via sudo ./RetroPie-Setup/retropie_setup.sh since the manual change didnt want to work.
    Also every driver has been updated… It would be nice if the 360 Controller config could be fixed because “START” is still quite important 😀
    Thank you so far

    #46086
    Profile photo of epicrean
    Daniel

    I have been trying for a bit now and I have no directory named anything close to retroarch

    #63700
    Profile photo of dover19
    Ben

    What do you need that folder for? Are you trying to manually edit a file?

    #65289

    RedX

    Elliot my Xbox controllers are doing exactly the same thing did you find a fix?

    #81983
    Profile photo of tsimcox
    tsimcox
    Participant

    There’s a GUI. Hit F1 during emulation, then use the keys you set in emulationstation to navigate to settings, then input options, and configure your keys

Viewing 35 posts - 1 through 35 (of 38 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar