How to install Mame4All with Emulation Station

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project How to install Mame4All with Emulation Station

This topic contains 24 replies, has 9 voices, and was last updated by Profile photo of Roo Roo 2 years, 3 months ago.

Viewing 25 posts - 1 through 25 (of 25 total)
  • Author
    Posts
  • #92289
    Profile photo of mulliganx
    mulliganx
    Participant

    hello. I am having issues playing ROMs on the default Mame that came with retropie.

    How do I install Mame4All ?

    I have the zip file for Mame 4 All and unsure of how to install it in order to play Mame ROMs.

    I have Retropie Set up and have been using Emulation station to play games.

    I have not been able to find instructions on google on how to do this. Any help much appreciated !

    #92294
    Profile photo of Roo
    Roo
    Participant

    Assuming you’re on a current RetroPie image, the default MAME emulator in RetroPie IS mame4all…

    I think you might be going about this the wrong way. If you’re not running the RetroPie v2.6 SD card image, start with that. If you are running the current image, what errors are you getting trying to load games?

    A common problem is you have the wrong MAME ROMs for RetroPie. If you are getting “missing files” errors check this tutorial

    https://github.com/retropie/RetroPie-Setup/wiki/Managing-ROMs

    #92300
    Profile photo of mulliganx
    mulliganx
    Participant

    Thanks for replying. So let me start from the original issue. I started attempting to use Mame4All because I am unable to play games with Mame on retropie.

    I have a zipped game that I moved into the Mame folder. When I start the Emulation Station it displays Mame, and even shows the name of the game. “Super Puzzle Fighter 2 Turbo”

    When I try to play the game nothing happens. This is what led me to start trying to download Mame4all.

    Since I already have Mame4all what would be the recommended fix for this?

    #92308
    Profile photo of dudleydes
    dudleydes
    Participant

    Mame4all uses the v0.37b5 romset. The link below is a list of supported games:

    MAME4ALL Game List (2270 romsets)

    So Super Puzzle Fighter 2 Turbo isn’t supported by mame4all.

    #92309
    Profile photo of Floob
    Floob
    Member

    This guide should help:
    http://dai.ly/x2hunh4

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #92374
    Profile photo of mulliganx
    mulliganx
    Participant

    So basically there is no way for me to play super puzzle fighter turbo on retropie?

    #92376
    Profile photo of Mutex
    Mutex
    Participant

    You coud try running it in final burn alpha (pifba on your pi) since its a cps2 game.

    #92441
    Profile photo of caseyjames
    caseyjames
    Participant

    Your guess is as good as mine.I have all the mame roms(the correct number)and still won’t play most of the games I loaded.I have 2000 games loaded in the fba and about 5 of them work.The people who made these emulators lied on the compatibly sheet that are included in the system.Street fighter 3.Fba,advance mame and mame all say they run this game.I even download loaded the number attached to the game and still nothing.Im gonna put snes nes sega and atari on it and give it to some lucky kid.I have 10 real computers that don’t have these kind of problems.I hate the pi it has really stole about 3 months of life and I want it back.It would have been nice to have all my games on a dedicated machine but I’m done wasting my time for not.Oh yea not one reply from this website in all that time.

    #92444
    Profile photo of scaryevilguy
    scaryevilguy
    Participant

    FB Alpha v0.2.97.08 sets work with FBA on the pi, if that helps.

    I assume Caseyjames is just trolling but if not, then try to find that romset because most games in it work (not all, but quite a lot). There a few different ones available (Neo geo, cps1/2/3 etc)

    #92455
    Profile photo of Mutex
    Mutex
    Participant

    Just because you have 2000 games doesn’t mean you have the right version of those games. Mame is different from pretty much every other emulator in that you have to make certain that every file needed by the emulator is within the zip file for that game. You don’t just have one binary file with the rom dump like other systems, but you actually have lots of different files that are need to run the game.

    That’s the reason you need a specific romset version to run with a certain emulator, i.e. pimame4all uses the romset version 0.37b5. That is a relatively old version of MAME so the compatibility with modern roms is lacklustre. If you download a MAME-rom somewhere that version is most likely for a newer Mame version and you need to use programs like clrmame to transform the game into the right version for your emulator.

    If you try the games from the right romset version you will see that noone lied about the emulator running those games.

    #92468
    Profile photo of Roo
    Roo
    Participant

    If you look up, I posted a detailed tutorial on how to verify your MAME4ALL and PiFBA ROM sets….

    https://github.com/retropie/RetroPie-Setup/wiki/Managing-ROMs

    #92484
    Profile photo of herbfargus
    herbfargus
    Member

    @caseyjames

    Plenty of people have responded to your requests.

    This is a project for anybody who just wants the chance to be able to play their childhood games that are no longer currently available on modern hardware.

    Its an open source project in constant development so it is going to require patience and a little bit of tinkering to meet everyone’s needs.

    But there are plenty of fantastic people here willing to help out with the process, just be patient with yourself and the people trying to help you- because there is nothing more empowering than having an problem and learning how to solve it ๐Ÿ™‚

    But hey maybe you should hand it off to that lucky kid cause he would probably appreciate it more

    #92587
    Profile photo of Roo
    Roo
    Participant

    @herbfargus

    Ha I didn’t even see how negative the thread had become. I normally just don’t post. But anyways, the real reason for my reply, thanks for adding to my wiki article on CMP- nice video! ๐Ÿ™‚

    #92606
    Profile photo of danielfsc
    danielfsc
    Participant

    Hi Guys,
    I have a problem with mame4all, my romset is the 0.37b5 (100% sure because I used in a old version of retropie. All roms works fine in mame-libretro but none of them work on Mame4all-pi. I always get a “file not found” error.
    Any idea?
    Thanx

    #92608
    Profile photo of Roo
    Roo
    Participant

    I know you say you’re 100% sure but file not found means you’re missing something… do you have the BIOS ROMs present too? Is it a full set or are you just putting in select ROMs?

    #92611
    Profile photo of danielfsc
    danielfsc
    Participant

    I have about 1000 roms and I never care about the bios. In my old installation (Retropie 2.4 on rasp B) all of them works fine. I just copy all roms to my new installation (2.6 on rasp 2). Furthermore, all of them runs ok on mame-libretro, I dont think it’s a problem with the roms.

    #92636
    Profile photo of herbfargus
    herbfargus
    Member

    @Roo

    glad you liked the video. Your tutorial was the best I found as clrmamepro can be confusing to beginners. I made sure to place your page on the wiki homepage as well as link it to the relevant posts because it is incredibly useful.

    #92638
    Profile photo of Roo
    Roo
    Participant

    @danielfsc

    You’re going to have to work with me if you really want to fix this… ๐Ÿ™‚ Your assumption that one MAME binary uses the same ROMs as a different MAME binary is faulty.

    I know mame4all uses 0.37b5 ROMs. I was under the impressions the libretro mame core uses the same set, but I haven’t tested that myself.

    This part you already seem to know: RetroPie comes with 3 versions of MAME.
    * /opt/retropie/emulators/advmame/bin/advmame is used if you put your ROMs in ~/RetroPie/roms/mame-advmame
    * /opt/retropie/emulators/mame4all/mame is used if you put your ROMs in ~/RetroPie/roms/mame
    * /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/mamelibretro/libretro.so is used if you put your ROMs in ~/RetroPie/roms/mame-libretro

    Are you putting your ROMs in the correct folder?

    Try launching the different versions from the command line so you can see the errors without EmulationStation hiding them from you.

    libretro-mame:
    /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/mamelibretro/libretro.so --config /opt/retropie/configs/all/retroarch.cfg --appendconfig /opt/retropie/configs/mame/retroarch.cfg /home/pi/RetroPie/roms/mame-libretro/dkong.zip

    mame4all:
    create a new directory roms under /opt/retropie/emulators/mame4all
    copy your rom(s) there (only necessary for launching from the command line)
    /opt/retropie/emulators/mame4all/mame dkong

    with mame4all you can also verify the your ROMs with the command
    /opt/retropie/emulators/mame4all/mame -verifysets dkong

    #92639
    Profile photo of Roo
    Roo
    Participant

    @herbfargus

    Aww thanks! I made that when I first found RetroPie, I see so many people confused about that issue I thought I could help out since I’ve been at this MAME thing for a long time now (oh geez, thinking about it now… has it really been a decade???)

    #92691
    Profile photo of danielfsc
    danielfsc
    Participant

    Hi Roo,
    I create the roms file on mame4all folder and put dkong.zip in roms folder.
    Well. when I run:

    pi@retropie /opt/retropie/emulators/mame4all $ ./mame -verifysets dkong
    romset dkong is good
    1 romsets found, 1 were OK.

    And when I try:

    pi@retropie /opt/retropie/emulators/mame4all $ ./mame dkong

    I got a list of all files inside the dkong.zip and “Error: required files are missing, the game cannot be run”.
    Thank you for helping.

    #92694
    Profile photo of Roo
    Roo
    Participant

    That is very strange. If mame can verify the set is complete, why can’t it run it?

    Can you please post the exact, full error message you get when running ./mame dkong ?

    Have you made any changes to the mame4all config file?

    #92705
    Profile photo of danielfsc
    danielfsc
    Participant

    I don’t change the mame config file.

    I will try a fresh install of the retropie, I already remove the …/emulators/mame4all folder and don’t works.
    That’s the error i got when I try to run a rom.

    dk.3f NOT FOUND
    dk.3h NOT FOUND
    dk.3n NOT FOUND
    dk.3p NOT FOUND
    dk.5a NOT FOUND
    dk.5b NOT FOUND
    dk.5c NOT FOUND
    dk.5e NOT FOUND
    dk.7c NOT FOUND
    dk.7d NOT FOUND
    dk.7e NOT FOUND
    dk.7f NOT FOUND
    dkong.2j NOT FOUND
    dkong.2k NOT FOUND
    dkong.5f NOT FOUND
    ERROR: required files are missing, the game cannot be run.

    #92707
    Profile photo of Roo
    Roo
    Participant

    You tried ./mame dkong immediately after running ./mame -verifysets dkong correct? You didn’t remove the ROM from /opt/retropie/emulators/mame4all/roms in between running the two commands?

    can you try this and post the results? (just making sure the file is there with the right roms inside)

    cd /opt/retropie/emulators/mame4all/roms
    unzip -l dkong.zip

    That’s all I got… Yeah – if you didn’t remove the ROM, I would agree with a fresh RetroPie install

    #92782
    Profile photo of danielfsc
    danielfsc
    Participant

    Well, I install RetroPie 3.0 and now everything works fine. Thank you for your helping Roo.

    #92804
    Profile photo of Roo
    Roo
    Participant

    good to hear ๐Ÿ™‚

Viewing 25 posts - 1 through 25 (of 25 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar