How to disable auto-restart of ES in cmdline?

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project How to disable auto-restart of ES in cmdline?

This topic contains 6 replies, has 3 voices, and was last updated by Profile photo of jymihan jymihan 2 years ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #100703
    Profile photo of jymihan
    jymihan
    Participant

    Hey RetroPie Community!

    Does anyone know how to disable the auto-restart of Emulationstation once you exit to command line? I’ve been looking through all the forums and in RetroPie scripts but to no avail. I have tons of roms on my sd and it takes quite awhile to load and exit out of es. A lot of the times, the “press any key to exit in 5 seconds” does not work for me due to the long exiting of es. Has anyone found how to disable this? Thank you!

    Raspberry Pie 2 Model B
    RetroPie v3.0 Beta 4
    Logitech F310 GamePad

    #100723
    Profile photo of Floob
    Floob
    Member

    As a quick aside – when exiting ES, press a key then anyway, and I’m pretty sure it will remember that once it has exited ES fully. Does for me anyway!

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #100727
    Profile photo of jymihan
    jymihan
    Participant

    It works 50/50. Sometimes it does other times it doesn’t. Anyways, thanks for the reply Floob. Love your videos! Helped me so much with setting up Retropie!
    You’re doing God’s work =)

    Raspberry Pie 2 Model B
    RetroPie v3.0 Beta 4
    Logitech F310 GamePad

    #100728
    Profile photo of Floob
    Floob
    Member

    Thanks 🙂
    I’ll fish out the setting you want in a min.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #100730
    Profile photo of Floob
    Floob
    Member

    It looks like its this part

    while [[ -z "\$key" ]]; do
        \$es_bin "\$@"
        echo "EmulationStation will restart in 5 seconds. Press a key to exit back to console."
        IFS= read -s -t 5 -N 1 key </dev/tty

    which is in
    /home/pi/RetroPie-Setup/scriptmodules/supplementary/emulationstation.sh

    Its the $es_bin that restarts ES, so I guess you could just take that out.
    I really need to improve my scripting to understand it better though 🙂

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #100732
    Profile photo of herbfargus
    herbfargus
    Member

    You could also change the 5 to 10 or 20 If you want it to take longer or as floob said you can take out $es_bin

    #100734
    Profile photo of jymihan
    jymihan
    Participant

    Thank you Floob for finding the right script! Looking forward to your future videos. Thank you herbfargus, it looks like I can play around with the timing.

    Raspberry Pie 2 Model B
    RetroPie v3.0 Beta 4
    Logitech F310 GamePad

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar