How to add theme menu back sound, and others

Welcome Page Forums RetroPie Project Emulation Station Themes How to add theme menu back sound, and others

This topic contains 8 replies, has 3 voices, and was last updated by  labelwhore 1 year, 9 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #106906

    proaudiosoft
    Participant

    Hello all. I have easily added scroll sound to the default simple theme using <scrollSound>./art/select.wav</scrollSound> to the xml. (and its working using that method). but originally I couldn’t seem to get it working using the code already in the xml for editing. I want to actually get a few of the other sounds working. I have some .wav files I have created. I read somewhere to remove the <!– and –> in the xml, and i have included the path. What am i doing wrong? Could someone show an example? Thanks so much

    <!– Sounds
    <sound name=”systemscroll”>
    <path>./art/systemscroll.wav</path>
    </sound>

    <sound name=”systemselect”>
    <path>./art/systemscroll.wav</path>
    </sound>

    <sound name=”listscroll”>
    <path>./art/listscroll.wav</path>
    </sound>

    <sound name=”back”>
    <path>./art/back.wav</path>
    </sound>

    <sound name=”launch”>
    <path>./art/launch.wav</path>
    </sound>

    <sound name=”menuopen”>
    <path>./art/menu.wav</path>
    </sound>
    –>

    #106915

    herbfargus
    Member

    This is an example of the sound in one of the themes I worked on:

    https://github.com/HerbFargus/es-theme-carbon/blob/master/carbon.xml#L67

    #106916

    proaudiosoft
    Participant

    But this is just the scroll sound correct? I have already added this. But how do you add other menu sounds, such as back, or system select? btw, i love that theme(Carbon), using it now. Me being a person that has migrated from using PC’s in my arcade machine builds, to the RPI, just looking for a way to kick the front end up a notch by adding some menu sounds i am use to.

    #106932

    herbfargus
    Member

    I think you put the respective sounds under their respective tags, so for the system select you’d put it under the system tag:

    https://github.com/HerbFargus/es-theme-carbon/blob/master/carbon.xml#L12

    back and other stuff might just be in the gamelist tag (right after your system scroll like my example in the last post) I haven’t actually tested it but I’m pretty sure thats how it works.

    This is the page for the official documentation: https://github.com/Aloshi/EmulationStation/blob/master/THEMES.md

    If you have a chance- I’d be interested in checking out some of the sounds you’re using.

    #106939

    proaudiosoft
    Participant

    Hey thanks for the quick response. I actually tried to set it up like the scroll in the gamelist tag with no success earlier today. I must be doing something wrong. I will definitely check out the documentation in the link you posted when i get back home this eve, I really appreciate it. I will let you know of my results. Absolutely, I would be more than happy to share any sounds I have laying around. I have a studio here in my house and am big time into music production, so if you need anything special I can probably make it too lol.

    Edit: Yeah, i actually read that documentation yesterday while doing some searching on the subject. The only sound I see in the documentation being referred to is the scrollsound. I am starting to wonder if the other sounds have ever really been implemented? I haven’t really seen a theme with any others working really. But if you look at the default “simple” theme’s XML there is definitely references to other menu sounds.

    #106950

    herbfargus
    Member

    Yeah there is also reference to a grid pattern gamelist which I’ve never seen implemented either. (You are making sure to put your sounds in the art folder yes? Also that they are .wav files?) You may be correct in that it may have never been implemented in the code quite yet- I’ll look into it a bit more when I’ve got time and see if I can get it sorted.

    But yeah if you have some good sounds I’d be interested in including them as options in the theme if we can get them working.

    #106952

    herbfargus
    Member

    Actually on further perusal it looks like you may be right in that they were never integrated:

    https://github.com/Aloshi/EmulationStation/issues/215

    I tried a bunch of different code snippets in the xml and the sound would never play.

    seems development halted before sounds were included for the carousel and systemselect unfortunately.

    I may bug you in the future though for some sound effects for some boot videos I’m contimplating making for retropie ha ha

    #106958

    proaudiosoft
    Participant

    Thank you for confirming what I already suspected lol. I am sure future updates will have menu sounds fully up and runnin’. I would be glad to help you out with any sound fx you need in the future. Just get a hold of me 🙂

    #116037

    labelwhore
    Participant

    Actually on further perusal it looks like you may be right in that they were never integrated:

    https://github.com/Aloshi/EmulationStation/issues/215

    I tried a bunch of different code snippets in the xml and the sound would never play.

    seems development halted before sounds were included for the carousel and systemselect unfortunately.

    I may bug you in the future though for some sound effects for some boot videos I’m contimplating making for retropie ha ha

    I know this is a little bit old, if you still need sound effects, I might be able to help on that also.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/