How do I re-bind the Config key (Tab) for AdvanceMAME? [RetroPie 3.0]

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie How do I re-bind the Config key (Tab) for AdvanceMAME? [RetroPie 3.0]

Tagged: ,

This topic contains 3 replies, has 3 voices, and was last updated by  blazefyah 1 year, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #104124


    I did something really dumb while trying to re-bind my MAME emulator’s config key. It used to be Tab, and while I was trying to re-bind it to one of my gamepad buttons I un-bound the key, and now I have no way of accessing the config settings.

    I found this section of the mamedev wiki, which suggests editing the default.cfg file. But I tried to access that file and it appears to be blank when I try to edit it via Putty using:

    nano default.cfg

    default.cfg also isn’t in the mame-advmame directory. apparently its location changed with Retropie 3.0:

    I must be doing something wrong. Out of all of the keys to accidentally un-bind, I do it to the most important one! How do I fix my very dumb mistake? And where do I even find the default.cfg file that I’m supposed to edit/delete? I’m even willing to completely re-install AdvanceMAME to reset my bindings.

    Pi Model: Raspberry Pi 2 Model B
    RetroPie Version Used: 3.0



    I don’t know of any config files for mame. You can try reinstalling the binary for it from the setup script: here’s a video if there is any confusion:



    That was actually one of the first things that I tried. But it didn’t reinstall the AdvanceMame emulator- it seems to have just updated it. I’m still having the config bindkey issue. And since RetroPie 3.0 is so new, there aren’t any resources online that point to a solution, yet! I found a mame.cfg file in opt/retropie/emulators/, but it doesn’t contain any keybindings for the MAME config menu that’d normally be accessed using the Tab key.



    Use Putty with WINSCP and go to /opt/retropie/configs/mame-mame4all/cfg/default.cfg.
    Delete default.cfg and re-install Mame4all from binary setup.
    Worked for me! Tab should work again.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss