How do I Overclock?

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of Floob Floob 2 years, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #83856
    Profile photo of clockwise
    clockwise
    Participant

    So…I’ve been looking around for hours now and I have no idea why my overclocking is not working. I use a Raspberry Pi Model B+.

    I’ve been looking at this: https://github.com/retropie/RetroPie-Setup/wiki/Advanced-Configuration

    And changing the config.txt in /boot/ does nothing. I went from 700 to 1050 on arm_freq and did the stresstest specified in the link and my temp is not affected. My current config.txt file is as follows:

    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720
    
    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    #uncomment to overclock the arm. 700 MHz is the default.
    arm_freq=1000
    
    # for more options see http://elinux.org/RPi_config.txt
    core_freq=500
    sdram_freq=500
    over_voltage=4
    avoid_safe_mode=1
    gpu_mem=384
    force_turbo=0

    I also tried changing doing this: sudo raspi-config and changing overclock settings to turbo, but no temperature change or anything. I don’t even have extra cooling, so it feels like my settings are not being used.

    Any ideas?

    #83865
    Profile photo of Floob
    Floob
    Member

    This should help:

    http://elinux.org/RPiconfig#Overclocking

    Particularly this bit:
    The latest kernel has a cpufreq kernel driver with the "ondemand" governor enabled by default. It has no effect if you have no overclock settings. But when you do, the arm frequency will vary with processor load. Non default values are only used when needed according to the used governor. You can adjust the minimum values with the *_min config options or disable dynamic clocking with force_turbo=1

    This is worth a read as well:
    http://megakemp.com/2013/02/26/adventures-in-overclocking-a-raspberry-pi/

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar