Hotkeys not working on joystick

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Hotkeys not working on joystick

This topic contains 8 replies, has 2 voices, and was last updated by  spjonez 2 years, 8 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #97194


    Hi, I’m using original SNES + USB adapters on a Raspberry Pi Model B with version 3.0 of the RetroPie script. With the default install the resting position of the controller is off so I had to use the steps posted on here to recompile the kernel.

    The d-pad and all the buttons on both controllers work as expected in Emulationstation and in all the emulators I’ve installed but I cannot get the hotkeys to work. Holding select and pressing start or any of the other triggers doesn’t do anything.

    Here’s my controller config in /opt/retropie/emulators/retroarch/configs:

    input_device = "USB,2-axis 8-button gamepad  "
    input_driver = "udev"
    input_b_btn = "1"
    input_y_btn = "3"
    input_select_btn = "6"
    input_start_btn = "7"
    input_up_axis = "-1"
    input_down_axis = "+1"
    input_left_axis = "-0"
    input_right_axis = "+0"
    input_a_btn = "0"
    input_x_btn = "2"
    input_l_btn = "4"
    input_r_btn = "5"
    input_enable_hotkey_btn = "6"
    input_exit_emulator_btn = "7"
    input_shader_next_btn = "5"
    input_shader_prev_btn = "4"
    # Saves state.
    input_save_state_btn = "3"
    # Loads state.
    input_load_state_btn = "1"
    input_reset_btn = "2"

    In /opt/retropie/configs/all/retroarch.cfg I’ve tried these two settings for this line as noted in another thread;

    # input_enable_hotkey_btn =
    input_enable_hotkey_btn = tab

    Hotkeys work from a keyboard but when I only have two SNES controllers plugged in they don’t work from controller 1.

    Any ideas what I’m doing wrong? Thanks!



    Does this value exist in your file?


    I’d remove this line from it (the /opt/retropie/configs/all/retroarch.cfg) , as it exists in your controller file:
    input_enable_hotkey_btn = tab

    Also, this video may help give an overview (about 27:30 in)

    RetroPie help guides -->
    Please read this before asking for help -->



    Thanks for the quick reply! I previously watched that video and selected option 1. At the very end of my config file is this line:

    input_enable_hotkey = nul

    Based on what he said I removed that line from the bottom of the file and changed this section to:

    # Alternatively, all hotkeys for keyboard could be disabled by the user.
    input_enable_hotkey = alt

    Rebooted and unfortunately they still aren’t working.



    Can you post your /opt/retropie/configs/all/retroarch.cfg as an attachment or up on

    If you do it as an attachment you will need to rename it to a .txt file.

    I’m presuming when you start a game that uses a retroarch/libretro core the yellow text appears on the bottom of the screen and confirms your controller filename?

    RetroPie help guides -->
    Please read this before asking for help -->



    Sure here’s my /opt/retropie/configs/all/retroarch.cfg. And my /opt/retropie/emulators/retroarch/configs/USB_2-axis_8-button_gamepad.cfg.

    Yes when I start a game very briefly yellow text flashes at the bottom of the screen showing each controller.

    I was able to get hotkeys working in PISNES by changing the key bindings in /opt/retropie/emulators/pisnes/snes9x.cfg but they still don’t work in any of the other emulators. All the others I’m using are part of libretro.

    In the videos it doesn’t say to but am I supposed to change anything in /opt/retropie/emulators/retroarch/retroarch.cfg?

    So confused!



    Can you confirm the name of the file that is shown in yellow when you start a game?

    Also, does this jstest show that your start button is 7 and select is 6?

    And no, you dont need this:

    RetroPie help guides -->
    Please read this before asking for help -->



    Yes jstest shows select as 6 and 7 as start. When I start a game this is the text I see in yellow:

    Joypad port #0 (SFC/USB Pad) configured

    When I ran the joystick setup from the setup script it said it wrote USB_2-axis_8-button_gamepad.cfg, but I’ve also tried changing USB_Gamepad.cfg and it doesn’t seem to fix it either.

    Correcting the keys in /opt/retropie/emulators/pisnes/snes9x.cfg did fix that emulator so I’m assuming it’s a misconfig but I can’t tell what file it’s loading from the text it prints.

    Could it be a problem with auto-config? I can’t seem to find a similar config to snes9x.cfg for all the libretro ones.



    Backup this directory:

    Then you could try this to confirm what file is getting written:

    USB SNES Controller – D-Pad not working in games

    RetroPie help guides -->
    Please read this before asking for help -->



    Fixed it! In /opt/retropie/emulators/retroarch/configs there was a file named tempconfig.cfg that had input_device = “SFC/USB Pad” which matches the yellow text. Updating that file made them start working.

    Thanks both of you for your help!

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss