Hotkey for exiting to main menu

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Hotkey for exiting to main menu

This topic contains 16 replies, has 2 voices, and was last updated by Profile photo of herbfargus herbfargus 1 year, 6 months ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #111938
    Profile photo of ravilla
    ravilla
    Participant

    So im new to this and seem to got it mostly working, but I cant figure out how to input the hotkey for start-select to exit the emulator. I have searched and searched and tried all kinds of different ways. Very frustrating. I was able to go into retroarch and save the set up for the controller. I am using a usb SNES controller, but everytime i try to enter the file, it says the command doesnt exist.
    cd /opt/retropie/emulators/retroarch/config­s
    doesnt work
    I am using retropie 3.2.1

    Any help would be great. There are some other inputs i have tried and its like the retroarch config file doesnt exist.

    #111942
    Profile photo of herbfargus
    herbfargus
    Member
    #111945
    Profile photo of ravilla
    ravilla
    Participant

    yeah ive gone through that set up and the command ” /opt/retropie/configs/all/retroarch-joypads ” doesnt work. Just says no such command

    #111946
    Profile photo of herbfargus
    herbfargus
    Member

    It automatically configured hotkeys when you configure your controllers through emulationstation

    Are your hotkeys not working?

    #111947
    Profile photo of ravilla
    ravilla
    Participant

    ive tried the start then select to exit hotkey and it doesn’t work. So ive been trying to get into the config file to set it up myself, but every command i have found doesn’t seem to work.
    I watch this video https://www.youtube.com/watch?v=Z0FT4i2CQVI and was able to config the retroarch file with the controller, even though i did that already through emulationstation and when he gets to opening the file to see the hotkeys that are already in place. i get this command does not exist.

    #111949
    Profile photo of herbfargus
    herbfargus
    Member

    You may want to brush up on your Linux terminal command knowledge:

    https://github.com/RetroPie/RetroPie-Setup/wiki/ssh

    The hotkey is select so its select+start not start+select.

    What is the output of

    ls -lah /opt/retropie/configs/all/retroarch-joypads

    Also BTW that video is outdated. (I need to make a new one) the official wiki is the only thing kept consistently up to date.

    #111954
    Profile photo of ravilla
    ravilla
    Participant

    What is the output of

    ls -lah /opt/retropie/configs/all/retroarch-joypads

    total 12K
    drwxr-xr-x 2 pi pi 4.0K Jul 20 17:57 .
    drwxr-xr-x 3 pi pi 4.0K Oct 20 2015 ..
    -rw-r–r– 1 pi pi 546 Jul 20 17:57 usbgamepad.cfg
    -rw-r–r– 1 pi pi 0 Jul 20 17:29 usbgamepad.cfg.bak

    yeah i figured the video was out of date, but that it would still have the right commands for what I needed. Pressing select+start doesnt seem to do anything either.

    #111956
    Profile photo of herbfargus
    herbfargus
    Member

    And what are the contents of usbgamepad.cfg?

    sudo nano usbgamepad.cfg

    #111962
    Profile photo of ravilla
    ravilla
    Participant

    it was blank, so I guess i messed something up. Been trying to connect it to the internet, but cant keep the damn thing to connect with the ethernet cord.

    #111963
    Profile photo of herbfargus
    herbfargus
    Member

    That definitely would explain it.

    You made sure you were in the retroarch-joypads folder first correct?

    The absolute path to edit would be

    sudo nano /opt/retropie/configs/all/retroarch-joypads/usbgamepad.cfg

    #111964
    Profile photo of ravilla
    ravilla
    Participant

    this came up this time. So it looks like the hotkey is enabled but not working for some reason.

    Attachments:
    #111966
    Profile photo of herbfargus
    herbfargus
    Member

    Which emulators have you tested it on?

    #112003
    Profile photo of ravilla
    ravilla
    Participant

    Just the SNES one, guess ill try some of the others

    #112004
    Profile photo of ravilla
    ravilla
    Participant

    well i got it to work finally. Thanks for the help. Now i just have to figure why the game boy ROMs arent loading. Thanks again.

    #112014
    Profile photo of herbfargus
    herbfargus
    Member

    Please post your solution so that others with a similar issue can learn from your experience.

    #112016
    Profile photo of ravilla
    ravilla
    Participant

    lol i feel an idiot, but i guess i needed to hold down the select button and press start. I was just clicking one then the other.

    #112017
    Profile photo of herbfargus
    herbfargus
    Member

    It’s always the little things 😉 glad you got it sorted.

    I’ve clarified the wiki:

    https://github.com/RetroPie/RetroPie-Setup/wiki/First-Installation#default-hotkeys

Viewing 17 posts - 1 through 17 (of 17 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar