hotkey button "stuck" in RetroArch

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project hotkey button "stuck" in RetroArch

This topic contains 16 replies, has 5 voices, and was last updated by Profile photo of rev138 rev138 2 years, 6 months ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #83490
    Profile photo of rev138
    rev138
    Participant

    I have one of these controllers (http://www.amazon.com/gp/product/B00G6CLXRK), and it seems to work fine, except for the hotkey functions.

    I have the hotkey button mapped to the “select” button (8, in this case), and everything behaves in emulationstation, but once I launch a game, it acts as if I’m holding down “select” when I am not (i.e. I hit “start”, and it quits because I have “select+start” mapped as the exit key). I tried mapping to another button (12) and it still acts as if I have the hotkey pressed. I even tried a second one of these controllers in case that one was a dud, and it has the same issue. I’m thinking this must be a bug and/or a config issue.

    Has anyone run into this?

    PS- I have an iBuffalo SNES controller and the hotkey function works perfectly

    #83507
    Profile photo of Floob
    Floob
    Member

    Can you post your config file so we can see?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #83510
    Profile photo of gizmo98
    gizmo98
    Participant

    If you configure “select” as a input_enable_hotkey_btn you also need an input_enable_hotkey for your keyboard. Strange but true…

    #83514
    Profile photo of Floob
    Floob
    Member

    Maybe its the defaults in here:

    sudo ./retropie_setup.sh

    Option 3 – Setup
    Option 310 – Hotkey behaivour

    As per this post, I think you would want option 2

    Default configuration for RetroArch hotkey button

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #83521
    Profile photo of geeks
    geeks
    Participant

    gizmo, could you elaborate on this?

    > If you configure “select” as a input_enable_hotkey_btn you also need an input_enable_hotkey for your keyboard. Strange but true…

    #83522
    Profile photo of rev138
    rev138
    Participant

    Well, it looks like my problem was that I had followed this blog post: http://weekendengineer.wordpress.com/2014/09/02/auto-detecting-controllers-in-emulationstation-2-0

    I had to deviate slightly from the instructions because the controller detection option in retroarch-config doesn’t seem to work (no output), so I ran joyconfig manually and copied the output to a file in /opt/retropie/emulators/RetroArch/configs. This apparently does not work properly.

    I appended the contents of my custom config file to the main retroarch.cfg, and now the controller behaves properly (though it doesn’t switch mappings when I plug in a different controller, as was implied by that how-to.

    #83569
    Profile photo of rev138
    rev138
    Participant

    Upon further testing, it seems the auto-detection IS working. When I launch a game, I see a message in yellow flash on the bottom identifying the controller. However, when I do this, pressing “start” exits the game as if I had been holding down “select”. If I move the exact same settings directly into my retroarch.cfg, it works properly. Very weird.

    #83570
    Profile photo of Floob
    Floob
    Member

    It might be to do with the position of the lines – can you post your auto config joypad file?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #83751
    Profile photo of rev138
    rev138
    Participant
    input_device = "Performance Designed Products Rock Candy Wireless Gamepad for PS"
    input_driver = "udev"
    
    input_b_btn = "1"
    input_y_btn = "0"
    input_select_btn = "8"
    input_start_btn = "9"
    input_up_btn = "h0up"
    input_down_btn = "h0down"
    input_left_btn = "h0left"
    input_right_btn = "h0right"
    input_a_btn = "2"
    input_x_btn = "3"
    input_l_btn = "4"
    input_r_btn = "5"
    input_l2_btn = "6"
    input_r2_btn = "7"
    input_l_x_plus_axis = "+0"
    input_l_x_minus_axis = "-0"
    input_l_y_plus_axis = "+1"
    input_l_y_minus_axis = "-1"
    input_r_x_plus_axis = "+2"
    input_r_x_minus_axis = "-2"
    input_r_y_plus_axis = "+3"
    input_r_y_minus_axis = "-3"
    
    input_enable_hotkey_btn = "8"
    input_exit_emulator_btn = "6"
    input_save_state_btn = "4"
    input_load_state_btn = "5"
    
    #83757
    Profile photo of Floob
    Floob
    Member

    Long shot, but try removing that blank line.

    Also, how does your retroarch.cfg compare to my working (with auto config file) one here?

    Working controller config files attached

    Also, in your example you dont have Start set to exit the emulator? You have l2 set too do that?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #83760
    Profile photo of thex
    thex
    Participant

    I had this exact issue.
    Try removing the quotes around the numbers for the hotkey and exit buttons, like below;

    input_enable_hotkey_btn = 8
    input_exit_emulator_btn = 6

    #83762
    Profile photo of rev138
    rev138
    Participant

    @thex: I tried that. No dice. Are you using those same gamepads?

    @floob: I don’t have start mapped to exit right now because I need to be able to use the start button. It doesn’t matter what button I use though, it exits without holding down the hotkey.

    #83765
    Profile photo of Floob
    Floob
    Member

    You could try pasting your auto config into the main retroarch.cfg file and see if it works there.
    Did you try removing that blank line?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #83951
    Profile photo of rev138
    rev138
    Participant

    After finding a couple more posts on this exact issue (which different people seem to have different working solutions to), I was finally able to make this work by moving these options out of the controller-specific config and into the main retroarch.cfg

    input_enable_hotkey = "tab"
    input_enable_hotkey_btn = 8
    input_exit_emulator_btn = 9
    input_save_state_btn = 4
    input_load_state_btn = 5

    Now it only exits on select+start, as it should. However, this is not ideal because if I use a different controller, those will map to different buttons 🙁

    Progress.

    #83953
    Profile photo of Floob
    Floob
    Member

    Perhaps when you use the auto file, it is importing it before the
    input_enable_hotkey = “tab” line in your main retroarch.cfg file ?

    Therefore it gets overwritten by the keyboard tab setting later in that file?

    You could check this by putting it back how it was then run it and press tab and then a hotkey button on your joypad.

    For reference, this structure works fine for me (uses hotkey in auto file no problem).
    http://blog.petrockblock.com/wp-content/uploads/2014/12/retroarch.txt

    You can compare yours here:

    https://www.diffchecker.com/

    As a side note, I really need to work out if it cares about the button codes being in quotes or not. “”.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #83955
    Profile photo of Floob
    Floob
    Member

    Actually thinking about it, it shouldnt matter as one is keyboard hotkey and one is joypad hotkey.

    It would still be interesting if you compare your retroarch.cfg to mine – anything drastically different?

    Also, does it make any difference if you take that blank line out of your auto file?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #83970
    Profile photo of rev138
    rev138
    Participant

    Thanks for the comparison file. I tried mimicking your config somewhat in that I put

    input_hotkey_enable = escape

    in the main retroarch.cfg, and moved all the actual hotkey bindings to my controller-specific config file. This seems to work!

    Thanks again!

Viewing 17 posts - 1 through 17 (of 17 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar