Hi all, Newbie here with a few questions, can you help?

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! Hi all, Newbie here with a few questions, can you help?

This topic contains 14 replies, has 5 voices, and was last updated by  mikegold 2 years, 5 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #103017


    Hi guys, newbie here setting up a raspberry pi 2 board up with retropie and in need of assistance;

    My questions and troubles are;

    1. I am currently running retropie/emulationstation 3.0/Rc1 and i am trying to get a video splashscreen to load during the boot up of the system. the problem is i followed a guide on youtube by Herb Fergus as it was the most popular and recommended. I was able to follow most of the guide until i reached a file called asplashscreen in the supplumentary folder, this is when i then noticed it was not there and that this was for v2.6. I was then able to find the file in the etc/Init.d/ folder. I made my alterations and continued with the guide only to find my splashscreen did not boot. It does its initial boot then continues to the emulation station loading screen. My file is Mp4 and the file name matches the folder it is placed in, OMX player is downloaded and installed… have i missed something, if so is there a guide for 3.0 as i have searched the forums and cannot find anything?

    2. I am trying to set this up and make the most of the emulators included although when i add all my roms to all the emulators i find that my system has a white screen crash.. i believe that is something to do with the amount of emulators showing at one time and how many menu bars are showing, is this a memory issue or is there a simple fix for this or is there a restriction as to how many emulators can be shown on the menu at one time?

    Thanks for reading and thanks in advance.





    have not tried the video splashscreen, can’t help you there.

    As for 2:
    Yes it is a problem with having quite a lot of roms. In my case it helped to let it idle there for a bit and have its cogs spin. Took a bit more than an hour in my case as I have my complete PSX collection as ISO on the HD.

    Might help you there, not sure though.




    I think I can help you with the video asplashscreen. I apologise, I need to update the video as some of the paths have changed and I’ve figured a few things out since i first posted it as well that makes setting it up a little easier. I’ve been working with death259 on his PiAssist script and we’re hoping to integrate it that way as its a little easier than manually editing things, but we’re still working on that.

    but until then if you’d like to edit it manually, here’s what you do. Ignore the whole old version of omxplayer- I found a workaround to make the new version work without dbus errors.

    you need to edit the script here:
    and replace all the asplashscreens with splashscreen like the following

    #!/usr/bin/env bash
    # This file is part of RetroPie.
    # (c) Copyright 2012-2015  Florian Müller (contact@petrockblock.com)
    # See the LICENSE.md file at the top-level directory of this distribution and 
    # at https://raw.githubusercontent.com/RetroPie/RetroPie-Setup/master/LICENSE.md
    rp_module_desc="Configure Splashscreen"
    function depends_splashscreen() {
        getDepends fbi omxplayer
    function enable_splashscreen()
        printHeading "Enabling custom splashscreen on boot."
        cp "$scriptdir/scriptmodules/$md_type/$md_id/splashscreen" "/etc/init.d/"
        chmod +x "/etc/init.d/splashscreen"
        find $scriptdir/supplementary/splashscreens/retropie2015-blue/ -type f > /etc/splashscreen.list
        # This command installs the init.d script so it automatically starts on boot
        update-rc.d splashscreen defaults
        # not-so-elegant hack for later re-enabling the splashscreen
        update-rc.d splashscreen enable
    function disable_splashscreen()
        printHeading "Disabling custom splashscreen on boot."
        update-rc.d splashscreen disable
    function choose_splashscreen() {
        printHeading "Configuring splashscreen"
        local options
        local ctr
        pushd $scriptdir/supplementary/splashscreens/ > /dev/null
        for splashdir in $(find . -type d | sort) ; do
            if [[ $splashdir != "." ]]; then
                options+=($ctr "${splashdir:2}")
        popd > /dev/null
        cmd=(dialog --backtitle "$__backtitle" --menu "Choose splashscreen." 22 76 16)
        choices=$("${cmd[@]}" "${options[@]}" 2>&1 >/dev/tty)
        if [[ -n "$choices" ]]; then
            rm /etc/splashscreen.list
            find $scriptdir/supplementary/splashscreens/$splashdir/ -type f | sort | while read line; do
                echo $line >> /etc/splashscreen.list
            printMsgs "dialog" "Splashscreen set to '$splashdir'."
    function configure_splashscreen() {
        cmd=(dialog --backtitle "$__backtitle" --menu "Choose the desired boot behaviour." 22 86 16)
            1 "Enable custom splashscreen on boot"
            2 "Disable custom splashscreen on boot"
            3 "Choose splashscreen"
        choices=$("${cmd[@]}" "${options[@]}" 2>&1 >/dev/tty)
        if [[ -n "$choices" ]]; then
            case $choices in
                    printMsgs "dialog" "Enabled custom splashscreen on boot."
                    printMsgs "dialog" "Disabled custom splashscreen on boot."

    And then you’ll want to change this file:
    and change the filename to splashcreen like the following
    and replace the contents with these:

    #! /bin/sh
    # Provides:          splashscreen
    # Required-Start:
    # Required-Stop:
    # Default-Start:     S
    # Default-Stop:
    # Short-Description: Show custom splashscreen
    # Description:       Show custom splashscreen
    do_start () {
        while read splashline; do
            echo Playing splash video or image $splashline
            isMovie=$(echo $splashline | grep -o ".avi\|.mov\|.mp4\|.mkv\|.3gp\|.mpg")
            if [ -z "$isMovie" ]; then
                /usr/bin/fbi -T 2 -once -t 10 -noverbose -a $splashline
                sleep 12
                omxplayer $splashline
        done </etc/splashscreen.list
        exit 0
    case "$1" in
        echo "Error: argument '$1' not supported" >&2
        exit 3
        # No-op
        exit 0
        echo "Usage: asplashscreen [start|stop]" >&2
        exit 3

    Remove the old asplashscreen with sudo rm /etc/init.d/asplashscreen

    Then move your video into a folder like on the youtube video and then open up the setup script-

    -choose option 3 setup

    -Configure splashscreens

    -enable splashcreen

    -and then choose your new splashscreen (the folder with your video in it.)

    sudo reboot



    Thank you guys for your speedy responses unfortunately i work two jobs so i wont be able to do this again until saturday evening but until then thanks again. I will let you know how i get on and, Herbfargus your videos are great and very helpful thank you again!


    Edit, Managed to follow your steps there quickly using winscp, when i finished everything and rebooted all i got was “waiting for dbus to appear” maybe i did something wrong as i was doing it fast.



    Hi there anton,

    Thanks for your reply. Is this problem something to do with the SD card, if i transferred everything off on to a usb drive and booted from there could i store all the games on there? if not what is the capacity limit of roms before it begins to freeze if you know.

    Thanks in advance




    The problem isn’t a matter of SD card capacity rather its a matter of how emulation station is coded/ the raspberry pi lacking sufficient CPU. There’s not a whole lot you can do about the issue other than thinning your ROM collection down. I’m not sure how accessing ROMs externally affects it (either USB or NAS).



    I agree with herb there. Just checked and I have around 95.000 files for my RetroPie to process. This takes it around 2 minutes to fully start up.
    But this is connected through USB.

    I side with herb and recommend what I recommended to a friend of mine who wanted to make his one as portable as he could:
    1. Take the games you like to play most
    2. Search YouTube for ‘Hidden Gems’ or ‘Most Popular’ games, you’ll be surprised what you discover (MetalJesusRocks, Gamster81, GameSack to name a few)
    3. The IGN Top 10, 20, 100 or so are also a great way to discover

    With all that retrogaming goodness you’ll be busy for quite a while.



    Hi again guys, i have followed your guide herb about three times now and still no luck. It seems to be a problem finding the OMXplayer as when i go to configure splashscreen, the first line of text is “Could not find correct packages; OMXplayer, trying to install now? i have tried the guide about three times now and no luck, i have installed omxplayer at the start of the guide and it says that it is installed and up to date. is there something i am doing wrong?

    thanks in advance




    Try removing omxplayerin this file


    I added it as a dependency but if you’ve installed it manually that file doesn’t need it.



    For point 2.
    It’s a memory issue with emulation station. It’s not the number of roms you have, its the number of systems. This came up a while ago and the ES skin author reduced the size of the background images from 1080p to 720p to free up a little more memory but it’s still an issue if you have a lot of systems emulated.

    Raspberry Pi 2 + Retropie3.2.1 + 2 x PS3 Wireless + Logitech K400



    I have followed Your guide and it worked. Kind of…
    1. I have turned off all text on device start all according to your other video.
    2. Now when I start my Pi it shows on the bottom that it wasn’t able to load the video (gives the whole path) and after a few seconds the video starts.
    3. After video is finished I can see for a while linux info with last login time etc.
    So is there any way to switch off all this nasty text?

    Thanks in advance ;].



    Yeah I really need to find a better scripted option than all these manual edits… I’m still working on that. Its weird its giving you an error but still loading the video, and outside of the boot text I talked about in my video I don’t know how to hide the rest of the text.



    I did everything just as in your post on top of this thread. I literally did copy-paste.

    I think it might be the picture viewer trying to start the *.mp4 file and after it fails, video player kicks in.

    Is there any possible way for the video to run while emulation station is loading?
    It would be nice to go from video straight to the list of emulators…

    Also I’ve noticed that no matter how long is the movie, after that I’m getting this black screen with last login in linux etc. text and then EmulationStation loading splash, yet I’ve seen on YT some people having video that links seamlessly with ES splash.



    yeah that may be why- its definitely not the most ideal yet.

    yeah change this line here: do_start to do_start &

    The only caveat is when emulationstation loads, it loads, so it will cut off your video whenever it loads up.



    After adding & to do_start my video is cut after first few seconds and Emulation Station starts loading. I thought that I will show You the error I’m getting, because that bothers me way more than this Linux text right after movie.

    If You know how could I get rid of it, please let me know.

    PS. Congratulations on Your 1000 post ;].

Viewing 15 posts - 1 through 15 (of 15 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss