Help with SD Card Issue

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! Help with SD Card Issue

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of herbfargus herbfargus 1 year, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #111076
    Profile photo of fatalxception
    fatalxception
    Participant

    I have a RPi2B that I tried to set up for RetroPie. I flashed the image to the card, then I booted the Pi. I didn’t et display, so I SSH’ed into it and ran raspi-config. the only change I made was to have the disk expanded so I could use the full capacity, then I rebooted via commandline. The display came up with the console booting and the four RPi logos at the top, then went to a RetroPie splash screen and stopped loading. I noticed the network cable lights were off, so I checked my DHCP server to see if it had grabbed an IP address- Not only had it not gotten an address, but the DHCP entry for the IP address it had prior to boot was missing (We have an 8-day lease set up for IP addresses, so it should have been listed even if it were not connected). I let it sit for an hour before power cycling the Pi, and no display, no network. Worst of all, the micro sd card will not read with 2 different readers on two different computers under three OS’s. I thought I had a bad card, so I used my other card following the same steps- and got the same result! These are Kingston Class 10 32GB microSD cards. One of them had been previously flashed, but only once- both were brand new cards. I want to use RetroPie, but I am scared to sacrifice any more cards to this project- Is the problem the card, perhaps the capacity or something? I haven’t seen anyone else with this problem. Please let me know what I can do- I’ve been trying to recover the cards, but in Linux, when I scan for the reader or try anything while the card is plugged in, the card reader tries, fails, and shuts off. My other reader tries, fails and stays on. Inserting the card to any reader on a windows machine crashes the user mode driver. The first reader is a USB3 and the second is a USB2 reader. Please let me know how I can recover- the only utility that has even come close to working was TestDisk and this was very limited. Thanks- I appreciate your help.

    #111085
    Profile photo of herbfargus
    herbfargus
    Member

    The only thing I can think of is to check your power supply to make sure there are no faulty connections and also to check the source of the SD cards (eBay can be sketchy).I get sandisk cards off amazon typically and haven’t had issues.

    But it sounds like there is something going on that’s causing corruption either hardware related or the process in which you flash your cards.

    I had one SD card corrupt and I was never able to salvage it and just had to bite the bullet (I attempted many times with a live cd of the parted magic distro) since then I’ve bought SD cards with smaller memory in sets of 5 so its not so bad when the SD card fails.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar