help with n64 emulation?

Tagged: ,

This topic contains 5 replies, has 5 voices, and was last updated by Profile photo of cortex cortex 2 years, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #94147
    Profile photo of lorenrose1013
    lorenrose1013
    Participant

    Hello!
    I’m new to retropie but I have a raspberry pi 2 that I set up with version 2.6 from the sd card image.

    I’ve been trying to play Paper Mario and Legend of Zelda OOT. They both run, a lil glitchy on the n64. Paper Mario has messed up menus and text boxes, and a lot of things are like double or triple vision which makes them hard to read. Zelda crashes if you save, or even go to that menu.

    I decided to try n64-mupen64plus because I’d read it would be better, but both roms crashed before I could even make a save file. Zelda crashed at the black mupen64 terminal screen and paper mario crashed when I pressed start on the start screen. In both cases, the entire pie became unresponsive, and I had to pull the power and reboot.
    Then I switched to the rice plugin. Zelda I can now get to pick a name, but the buttons map wrong and it wont display the letters I input, nor will it let me continue past that point. And Mario freezes at the same place, but this time the audio keeps going and I can exit, so the entire pie is Not frozen. It’s an improvement, but neither game is playable this way.

    Can anyone help me get these working, maybe post their configurations if it’s a video thing or help me understand whats going on?

    Thanks a bunch 🙂

    EdIT: if it helps at all I’m using a gamecube controller.

    #94214
    Profile photo of geoldr
    geoldr
    Participant

    I am also playing around with the N64 emulators, basically it seems like a pain.

    You should check out the RetroPie 3 Beta 2 image, as there is supposedly some improvement for N64.

    Also – Check out this video: https://www.youtube.com/watch?v=lh0n5PWN2lI (towards the end)
    The guy posts his config, and it seems to work well for him.

    One more thing – there is a forum member on here ‘Floob’ he is very good with configuring the RetroPie image. Maybe see if you can reach out to him and have him visit this page and help us out.

    #94255
    Profile photo of alextaldren
    alextaldren
    Participant

    Honestly, I’ve been wading through the mess of N64 info for RetroPie for a few weeks because I recently got a Pi2 and was excited at the prospect of playing the N64 games, and it isn’t worth it.

    Both N64 emulators are more or less trash–certain games only work semi-decently on one or the other, setting up the controllers is a giant, giant pain, and then switching between the right gfx plugins (which work differently for each game) is just another fun step.

    Unless you’re pursuing N64 emulation as a kind of work project, save yourself the frustration and just wait until someone gets that shit figured out. The last thing I want to do is have some friends over and try loading up something like Mario Kart 64, only to have them wait while I hotkey+F1 into the retroarch menu, swap out some video plugins, and pray the damn thing will work without issue.

    #94257
    Profile photo of herbfargus
    herbfargus
    Member

    I have to agree with alex, unless you like tinkering with settings and stuff incessantly then you’re probably better off using project 64 on a pc- that’s what I’ve resorted to. Though I was able to get Mario kart working pretty well with the rice plugin.

    #94260
    Profile photo of lorenrose1013
    lorenrose1013
    Participant

    Thank you guys so much for responding !! 🙂

    That video was really helpful! I used that config and get my controller set up and now both games are running really well. There’s occasionally issues, like not being able to see fire in zelda or some textures just being black in mario, but its so minor it doesn’t bother me.

    Thanks!

    #94288
    Profile photo of cortex
    cortex
    Participant

    you really should check out the 3.0 beta2 Image though.
    If you install the testing-modules for mupen64plus, the fire bug in Zelda OoT is gone (just select the testing-Rice-video-plugin when hitting x while starting a rom). It Looks really great and runs almost fullspeed.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar