Help with mame button configuration.

Home Forums RetroPie Project Everything else related to the RetroPie Project Help with mame button configuration.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of 3ootsy 3ootsy 2 years, 5 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #84329
    Profile photo of 3ootsy
    3ootsy
    Participant

    Hi,

    I am a newbie here, however I have spent 10+ hours reading the forums trying to solve my problems.

    I recently put together my retro arcade with retropie. At this stage I have only downloaded mame roms. I have configured controls through retro arch.

    I have two problems that I cannot fix. 1. Inside a game I cannot get it to recognise buttons 16 and 17 – these are my select (player 2) and start (player 2) buttons.

    2. I cannot get an “exit emulator” shortcut to work. I have tried changing the retro arch config with a “select” button hot key but it has had no effect.

    I have read that retro arch has nothing to do with the mame emulator, so am not sure if I am even coming close to fixing it.

    I am using joysticks and buttons that I purchased online and running them through this interface http://www.jammaboards.com/store/pc-mame-ps3-to-arcade-controller-usb-interface-pcb-kit-pc2jamma-usb.html

    Any help/ideas would be greatly appreciated.

    #84338
    Profile photo of Floob
    Floob
    Member

    Thats right, MAME emulation does not use RetroArch in RetroPie 2.3

    You can see how to set an exit button combination here:

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #84378
    Profile photo of 3ootsy
    3ootsy
    Participant

    Thank you, that was a very easy fix for the exit emulator problem.

    I’m still having the same problems with buttons numbered over 15?

    I have now started trying other emulators and I have a new problem. SNES is not recognising player 2 buttons or joystick. I have tried adding info into retro arch config but it still is not working. I know it is all connected ok because mame is working and all buttons are working with Jetset?

    I have watched your YouTube vids on setting up controllers, they are awesome, however I wasn’t able to fix my problem.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar