Help with controls

This topic contains 4 replies, has 0 voices, and was last updated by  histo 2 years, 9 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #51444

    histo

    I’m really struggling to understand why this isn’t working…
    I have an ipac2 running a control panel I’ve built plugged in to my raspberry pi. I have all the buttons mapped in my /opt/emulators/retropie/configs/all/retroarch.cfg . My buttons work perfectly in emulation station as well as mame; control panels default bindings are the default mame keys.

    I can not get my keys to work in any other emulator selected; nes, snes, turbografix etc… they all appear to be using retroarch to launch so they should be obeying my key config.

    Any insight would be usefull I’ve been at this for two days.

    #51546

    histo

    I’m really lost now. I’ve tried just about everything but retroarch.cfg button settings are not used anywhere. Here is my config

    I’m trying to use keyboard controls for player 1 and 2. No gamepads anywhere to be seen.

    #51548

    histo

    Well wouldn’t let me post a link here is my relevant config section
    input_player1_a = shift
    input_player1_b = z
    input_player1_y = alt
    input_player1_x = ctrl
    input_player1_start = 1
    input_player1_select = 5
    input_player1_l = space
    input_player1_r = x
    input_player1_left = left
    input_player1_right = right
    input_player1_up = up
    input_player1_down = down
    # input_player1_l2 =
    # input_player1_r2 =
    # input_player1_l3 =
    # input_player1_r3 =
    input_player2_a = w
    input_player2_b = i
    input_player2_y = s
    input_player2_x = a
    input_player2_start = 2
    input_player2_select = 6
    input_player2_l = q
    input_player2_r = k
    input_player2_left = d
    input_player2_right = g
    input_player2_up = r
    input_player2_down = f

    #51675

    histo

    It appears that it’s sending the key presses to the terminal in the background. Luckily atleast the esc key works so I can exit the game. When I do so I can see some of the presses in the tty prior to emulationstation coming back up.

    Has anyone else been sucessfull in getting a keyboard working with RetroPie 2.3 sdcard image?

    #51735

    histo

    Okay problem was in my config lines. You can’t use 1,2,3,4,5…. in retroarch.cfg they are num1,num2,num3,etc…. or keypad1,keypad2,keypad3….

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar