Help starting basic setup

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! Help starting basic setup

Tagged: ,

This topic contains 6 replies, has 2 voices, and was last updated by  jakehoms 2 years, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #105045


    Hello all,

    My issue is both controller & new-setup related, but since I haven’t really gotten anything to work, I decided we’ll post in this forum.

    My setup:
    RPI Model B
    2 player home built arcade hooked up to a MiniPac (pre-2015)

    I am successful setting up the SD card, and it boots up into emulation station’s main ‘No gamepad detected’ screen. So far so good. I only intend to use the MiniPac, so I hold down on a button (it recognizes the keyboard input) to do the configuring part. This is where I get stuck. Most times, I can map a few buttons, but it’ll eventually freeze and not allow any input from the keyboard and I have to fully reboot the RPi. I have even tried connecting just a basic usb keyboard and it happen as well. I truly just want to get past this configuring section but so far I’ve been stuck here for days trying to figure it out. Here’s what I’ve tried so far (all to no avail):

    – USB keyboard into a USB hub, which runs into the RPi (in case it was a power issue.)
    – Swapping for another RPi (I have two Model B’s)
    – Changing USB keyboards.
    – Re-installing on a new SD card.
    – Changing power adapters for the RPi.

    Right now, I am stuck. I’m confident this can be fixed, either with modifying the script or the resulting config file, but I wasn’t sure what location to modify (I found something in /opt/retropie/all/retroarch.cfg, somewhere like that) but it was more than I wanted to adjust. Also, I don’t think it’s the MiniPac because even when I connect it via just a keyboard, I have an issue.

    Any help I can get would be appreciated. I have this nice arcade all built, but am stuck at this final silly part.




    retropie 3 ?

    Please detail your power set up (you mention a hub, but don’t mention if it is powered).

    check the output from dmesg etc from terminal (you can paste it via if you want me to have a look).

    sounds like power issues to me though, or a hardware problem/fault.



    Hi buzz, sorry for the delay and thank you for replying! I have made some progress, but I will answer your questions first.

    Yes, Retropie v3.0 and you are correct, it’s a powered hub, so not using the power via the RPi.

    I went through my cable drawer and found an another power supply, actually a sanctioned RPi one, and used it, plus another, very basic, USB powered keyboard. Together, this seems to allow me to get through the ‘configuring keyboard’ section! However…… I’m now stuck at an even more basic issue… I can get through each configuring section but whether I assign it a button or not, I can not his the OK button. Hitting Enter, Return, Space bar, etc. Nothing allows me to save the setup. I’ve gone through nearly all keys on the keyboard, and nothing allows it to hit ‘OK’. I can even arrow-up to move around, so I know it’s not frozen, but nothing accepts the ‘OK’ button. Crazy! I’ll do some more tests but that’s where I’m stuck at now. If you or anyone else has any input, please let me know. I can add the dmesg output too if that’ll help.




    so it was a psu issue then. Usually is.

    as for the “ok” press the key you defined as “a”



    Ha! That was it. I apologize for such a dumb question, I thought I hit that already but must have not.

    So, where is this input file written, so I can adjust going forward? As I mentioned earlier, my only intention is to set this up for MAME games, so I will need to adjust the file(s) for all the buttons I have for that.

    Thank you again!



    not sure what you mean by adjust going forward, but the input configuration for ES is in ~/.emulationstation and for retroarch it is stored in /opt/retropie/configs/all/retroarch.cfg for keyboard and /all/retroarch-joypads for controllers.

    I recommend reading through the wiki as a lot of information is there (plus this forum)



    I just meant that, since my button config is more than what I just configured, I’d need to go edit the config for all the buttons.

    Thanks again for your help. I will now mark this as resolved!

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss