Help needed with vintage SNES controllers in emulators

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Help needed with vintage SNES controllers in emulators

This topic contains 0 replies, has 1 voice, and was last updated by  tijn 3 years, 2 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #46511

    tijn
    Participant

    I have stripped a SNES case and kept the controller ports. The original connector ports have been connected, without the GPIO adapter, to the GPIO ports of the Raspberry Pi:

    VCC (SNES 1) to P1
    Clock (Snes 2) to P19
    Latch (Snes 3) to P23
    Data 1 (Snes 4) to P7
    Data 2 (Snes 4 on the other side) to P5
    Ground (Snes 7) to P6

    Exactly as described in http://blog.petrockblock.com/2012/10/21/the-retropie-gpio-adapter/ , but without the GPIO adapter.

    Controller 1 can be configured and used in Emulator Station and works great!
    Controller 2 is not seen, so I have some work there. Could it be Data 2 has to be connected to another GPIO pin?

    If I try to use controller 1 in an emulator it doesn’t work, obviously. I activated SNESDev with polling pads & buttons, but I can’t control the game.

    After that I tried to use the Gamecon driver, but to no avail, the controller can not be used.

    So I figured out that if I have not configured the controllers yet, I also can’t use them (do you know those times when you want to smack your head on the desk because you tried everything but overlooked the obvious? I do now…)

    When I try to configure the controllers from RetroPieSetup, I get timeouts. When I run the same program from command line, it doesn’t recognise that buttons are pressed.

    What can I do to configure the controllers?

Viewing 1 post (of 1 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/