HELP NEEDED. First person to solve my problem will receive an arduino uno.

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project HELP NEEDED. First person to solve my problem will receive an arduino uno.

This topic contains 7 replies, has 4 voices, and was last updated by Profile photo of malacai malacai 2 years, 10 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #5786
    Profile photo of toddforester
    toddforester
    Participant

    First, off thank you all for your hard work, and im sure you are tired of solving joypad issues but i searched the entire forum and have seen no problems like mine. (if i missed it put the link in the comments).

    Second, i will send whoever helps me to solve my issue an arduino uno.

    Third, i would send you a beer but im not sure that would be completely legal.

    OK so The Problem,
    i have a raspberry pi model b rev.2 running this image http://blog.petrockblock.com/download/retropie-project-sd-card-image-torrent/
    i have wired two nes controller ports according to this image.

    The problem is controller 1 (data1/pin7) is recognizedas js1 and controller 2 (data2/pin5) is not responsive(recognized???) at all.

    I know SNESDev is running properly because i also have a button wired to pin11 and when i press it i get “r” in the console and if i press 5 times the pi shuts down.

    when i do,
    ls /dev/input/
    i get this output in the console,

    ---------------------------------------------------------------------------
    pi@raspberrypi ~ $ ls /dev/input/
    by-id  by-path  event0  event1  event2  event3 event4 js0  js1  mice  mouse0
    ---------------------------------------------------------------------------

    if i do,
    jstest /dev/input/js0

    i get no response from either controller.
    from what i have read controller 1 should be js0 correct?

    if i do,
    jstest /dev/input/js1
    and press buttons on controller 1 i can see the button states changing from off to on and the axes move.

    i have gotten emulationstation and emulators to recognize controller 1.
    i had to edit /RetroPie/configs/all/retroarch.cfg to have,
    input_player1_joypad_index = 1
    instead of,
    input_player1_joypad_index = 0
    in order to have player 1 controller able to be used in emulators.
    in doing so i also changed player2_joypad index to 0.
    i am super desperate for a solution right now i have been at this for 3 days now and (i can feel my hair turning grey) have had no resolution to my problem. i need this thing ready for two players (on original nes controller hardware) by this sunday (3/30/14) so my son and i can play nes while i get to see him.

    sorry if this post is super long i, trying to give all the info i have.
    i plan on posting pictures on here of what i have done after it is finished.

    for now you can catch a peek in this video https://www.youtube.com/watch?v=CvQFhAj6Puk

    thanks in advance and if you help me first youll get one of these bad boys right here. http://arduino.cc/en/uploads/Main/ArduinoUno_r2_front.jpg

    if you need more info or think you know whats up let me know
    thanks.

    #5788
    Profile photo of toddforester
    toddforester
    Participant

    so i poked around with my oscilloscope on the data lines of both controllers and it seems like player1’s voltages are higher than player2’s i can see when i press buttons on both 1 and 2 … also with a multimeter i checked the data lines of both. player ones normal voltage on data is == 3.25 . player twos normal voltage is == 1.71 . i am confused??? im powering both controllers from gpio pin1 3v. any ideas? im thinking maybe ill try 5v but i dont want to burn the pi.

    #5789
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Since only js0 and js1 exist in the input directory, I assume that only SNESDev is running and not interfering with, say, the gamecondriver (which can also be installed via the RetroPie-Setup Script – DON’T DO THAT!).

    Also, one pad is working, which means that all connections except one data pin are properly connected and SNESDev is running correctly.

    Now, I would try and check or even reconnect the data lines on the breadboard. Just a wild guess, though.

    I keep my fingers crossed that you can solve the problem until sunday!

    #5790
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Another thing – swap data 1 and data 2. Does this lead to swapped gamepads on the console as well?

    #5792
    Profile photo of karloss
    karloss
    Participant

    I had loads of issues using the latest image and gamepads, build your own from source using raspbian and the retropie script, I had no issues with js0/1 since then..

    Sent from my Nexus 5 using Tapatalk

    #5799
    Profile photo of toddforester
    toddforester
    Participant

    thank you all for the replies. I ended up connecting vcc for both controllers to gpio pin2 (5v) and crossed my fingers that my pi didn’t explode when powered. to my surprise IT WORKED!!! I now have both controllers working perfectly. I have read that there is supposed to be some protection (diode+resistor?) on the data pins could you tell me how that is supposed to work?

    #5800
    Profile photo of toddforester
    toddforester
    Participant

    also I think the data lines are backwards in the diagram above or (software?) because player 1 is js1 and player 2 is js0.

    #40030
    Profile photo of malacai
    malacai
    Participant

    toddforester: Big thx for this, u sure solved my problems

    cheers mate!

    /mallorz

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar