Help Exiting Genesis/MegaDrive Games and Screen Resolution for PSX

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Help Exiting Genesis/MegaDrive Games and Screen Resolution for PSX

This topic contains 4 replies, has 2 voices, and was last updated by  jamesandjome-com 2 years, 11 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #85466



    I am currentally running version 2.3 on a B+ and everything is almost perfect.

    The only remaining issue I have is that I can not exit Genesis/MegaDrive games with the select+start buttons like I can in NES and SNES. From looking around I have gathered that the RetoArch.cfg button layouts do not apply to this emulator because it uses DGEN which is seperate. However I am unsure as to how I go about either editing just the DGEN controls or getting DGEN to recognise the RetroArch.cfg button mapping.

    Can anyone point me in the right direction to solve this? I am using the SNES Buffalo USB Controllers if this helps.

    The other issue I have is when I load up Playstation games my screen resolution changes and the picture goes out of bounds.

    I would appreciate any advice you can give me.



    Can anyone help with the above? It seems sometimes I can exit but once I do exit Genisis/MegaDrive the system freezes. This never happens with SNES or NES.

    I’m at a loss of what to do.



    If you put the roms in the megadrive rom folder it will use the picodrive retroarch core. The megeadrive-dgen folder uses dgen emulator.

    Although thats on RetroPie 2.4.x the 2.3 version only has the picodrive/retroarch option.

    Do you have any extra settings in your megadrive retroarch config file?

    I cover some hotkey settings here:

    RetroPie help guides -->
    Please read this before asking for help -->



    Hello Floob,

    Thank you for providing this. I dont know how I missed it, I thought I had seen all your videos.

    I will check everything again whist watching the video and update this post, hopefully with a “Yay this worked”.



    I tried the above video and I was stuck with the same issue. I have since moved to Version 2.4.2 and am not encountering the problem anymore. I would guess that I messed something up along the way in my 2.3 install and have had a better (more experianced) install on 2.4.2.

    Thank you Floob.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss