Help configuring NES Controllers using 4nes4snes USB adapter

Home Forums RetroPie Project Everything else related to the RetroPie Project Help configuring NES Controllers using 4nes4snes USB adapter

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of floeggu87 floeggu87 2 years, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #87359
    Profile photo of trk55449
    trk55449
    Participant

    Hello all,

    I’m building a NES emulator using a Raspberry Pi and am having a problem getting two controllers to register in Emulationstation. I’ve wired the original controller ports to this device: http://www.raphnet-tech.com/products/4nes4snes/index.php and even though I have two controllers plugged in, it only registers one. Also, it will detect one controller at a time in each controller port and it works fine, so I know both are working properly. Can anybody give some advice on getting this configured to use two controllers?

    #89080
    Profile photo of floeggu87
    floeggu87
    Participant

    Hi trk55449

    I used this 4nes4snes circuit as well. Since version 2.5 / 2.6 the controller only recognizes 2 axis instead of 8. (before the circuit was recognized as a joystick with 8 axis and 32 buttons).

    This seems to be a Problem with the newest generic joystick-driver.
    Sadly i havn’t figured out yet how to downgrade the driver or how to get it to recognize 8 axis again.

    for the working configuration you can have a look at my post: http://blog.petrockblock.com/forums/topic/has-anyone-used-the-raphnet-4x-snesnes-usb-adapter-circuit/#post-87027

    Please let me know if you figure out how to solve the problem 😉

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar