Help! – can't get controller to work with emulator

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Help! – can't get controller to work with emulator

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of trimmtrabb trimmtrabb 2 years, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #82917
    Profile photo of johnnybravo
    johnnybravo
    Participant

    Background
    Hardware
    Raspberry Pi B+
    microSD Card – 16GB
    USB keyboard
    USB RetroPad adapter for NES
    Original NES controller

    RetroPie Version – 2.3

    Software Steps completed
    sudo rpi-update
    sudo raspi-config
    – Expand Filesystem
    sudo reboot
    sudo apt-get update
    sudo apt-get upgrade
    sudo rpi-update
    sudo reboot
    cd RetroPie-Setup
    sudo ./retropie_setup.sh
    update the scripts
    update binaries
    sudo reboot
    sudo apt-get install joystick

    Ran
    jstest /dev/input/js0
    verified – B=0, A=1, select=2, start=3, D-Pad Up=-1,Down=1,Left=-0,Right=0

    cd RetroPie-Setup
    sudo ./retropie_setup.sh
    Setup-Samba ROM Shares
    Setup-Register RetroArch controller
    ran through controller registration and it completed and stated ‘RetroUSB.comRetroPad.cfg will be used by RetroArch from now on…’

    dropped a single ROM file into roms/nes
    sudo reboot
    controller works in EmulatorStation, select ROM, it loads and no controller buttons work or d-pad

    /opt/retropie/emulators/RetroArch/configs/RetroUSB.comRetroPad.cfg
    input_device = “RetroUSB.com RetroPad”
    input_driver = “udev”
    input_b_btn = “0”
    input_select_btn = “2”
    input_start_btn = “3”
    input_up_axis = “-1”
    input_down_axis = “+1”
    input_left_axis = “-0”
    input_right_axis = “+0”
    input_a_btn = “1”

    Attached – retroarch.cfg from /opt/retropie/configs/all

    I’ve also tried the below on a previous build. But, this build I did not run this:
    cd /opt/retropie/emulators/RetroArch/installdir/bin
    sudo ./retroarch-joyconfig -j 1 >> /opt/retropie/configs/all/retroarch.cfg

    Please help, I’m at my wits end. What am I doing wrong?

    #82920
    Profile photo of johnnybravo
    johnnybravo
    Participant

    Hello Again,

    Does anyone have any ideas for me?

    Thanks.

    #82927
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    The file you need to edit is retroarch.cfg in /opt/retropie/configs/all

    Here is mine for example, use it as a template. More config options here:
    https://github.com/libretro/RetroArch/blob/master/retroarch.cfg

    Note ‘joypad_index’, this is the number your gamepad is assigned. Looking at your post above 0 should be right

    input_player1_joypad_index = “0” input_player1_b_btn = “1” input_player1_y_btn = “3” input_player1_select_btn = “8” input_player1_start_btn = “9” input_player1_up_axis = “-5” input_player1_down_axis = “+5” input_player1_left_axis = “-4” input_player1_right_axis = “+4” input_player1_a_btn = “0” input_player1_x_btn = “2” input_player1_l_btn = “4” input_player1_r_btn = “5” input_player1_l2_btn = “6” input_player1_r2_btn = “7” input_player1_l3_btn = “11” input_player1_r3_btn = “12” input_player1_l_x_plus_axis = “+0” input_player1_l_x_minus_axis = “-0” input_player1_l_y_plus_axis = “+1” input_player1_l_y_minus_axis = “-1” input_player1_r_x_plus_axis = “+2” input_player1_r_x_minus_axis = “-2” input_player1_r_y_plus_axis = “+3” input_player1_r_y_minus_axis = “-3” input_enable_hotkey_btn = “8” input_exit_emulator_btn = “9” input_enable_hotkey_btn = “8” input_save_state_btn = “5” input_enable_hotkey_btn = “8” input_load_state_btn = “4” input_enable_hotkey_btn = “8” input_state_slot_increase_btn = “7” input_enable_hotkey_btn = “8” input_state_slot_decrease_btn =”6″ input_enable_hotkey_btn = “8” input_menu_toggle_btn = “3”

    If you have found the solution to your problem please mark the topic as resolved.

    #82928
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    You don’t have to assign all of those buttons by the way just remove the ones you don’t need although the hotkeys are useful

    If you have found the solution to your problem please mark the topic as resolved.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar