HELP! All emulators DONT work anymore?!

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project HELP! All emulators DONT work anymore?!

This topic contains 16 replies, has 4 voices, and was last updated by Profile photo of strunze strunze 1 year, 12 months ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #100997
    Profile photo of dragonjarvis
    dragonjarvis
    Participant

    Hello Forum!
    I have a massive problem!
    I was playing an PSX game on my Raspberry Pi 2 B and everything worked fine.
    Today after I reloaded a savestate in the PSX emulator suddenly no buttons worked anymore.
    I updated the script and hit the Binary update thing just in case.
    After that all the games wich worked before, dont work anymore.
    No PSX game, GBA,Megadrive and SNES.

    I dont know what to do and didn’t find any helpful tips so far.
    I am afraid to lose my progress in my Games.

    Please help!

    I am pretty frustrated, I bought my raspberry pi 2B almost a week ago and e I had to reinstall retropie daily. =/ I am using Retropie V3.0 Beta 4

    EDIT:
    These are the both errors i got:
    RetroArch [ERROR] :: parse_input :: –menu was used, but content file was passed as well.
    RetroArch [ERROR] :: rarch_main_init :: Fatal error received in: “parse_input()”

    #101049
    Profile photo of strunze
    strunze
    Participant

    Hi All,
    The same problem as above for me. I am using Retropie V3.0 Beta 4 with a 32 GB micro sd. Did a binary update and script update. Same errors as DragonJarvis. Mame Emulators work fine. Also Ports work fine. All other emulators do not work. Roms are in the list but when I select one it brings me back to the list. Also rom names appear to be grayed, not in boldface like they previously were. Any help on this would be massively appreciated. Thanks in advance.

    #101056
    Profile photo of tgilly
    tgilly
    Participant

    Same issue here.. I hope this gets fixed without a re-install

    #101060
    Profile photo of petrockblog
    petrockblog
    Keymaster

    I recently rebuilt all binaries I’ll check if retroarch is broken again or something.

    #101061
    Profile photo of petrockblog
    petrockblog
    Keymaster

    can confirm – ill debug and put up a new binary.

    #101062
    Profile photo of petrockblog
    petrockblog
    Keymaster
    #101064
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Fixed – it was an upstream retroarch issue with commandline parsing. If you re-install retroarch from menu 5 in retropie-setup it should sort it.

    #101071
    Profile photo of dragonjarvis
    dragonjarvis
    Participant

    Hello buzz.
    Thank you very much for your help!

    I did the following:

    1. Accses Retropie via puTTY
    2. typed in cd RetroPie-Setup
    3. typed in sudo ./retropie_setup.sh
    4. then under No. 5 i picked the retroarch-RETROARCH
    5. Picked binary.
    6. performed a reboot.

    After that my controller didnt work in the game at all!
    I couldn’t use a single button ingame. Emulationstation worked fine though.
    I pluged in my keyboard but it did not work either so i had to pull the plug.
    After that I reconfigured my gamepad but it still did not work in game and I had to pull the plug again.

    Do I need to do the binary and script update again?
    If I did something wrong please tell me because i am very new to linux and often not sure what to do and how.

    #101072
    Profile photo of petrockblog
    petrockblog
    Keymaster

    try doing a full binary install then – in case you had an older retroarch / emulationstation script that used the old controller location or something (which it shouldn’t since you updated recently).

    I cant help without more details / logs etc – does retroarch show your controller when you unplug / plug it in during emulation ?

    #101073
    Profile photo of tgilly
    tgilly
    Participant

    I didn’t have controller issues before so my case not entirely similar but since I updated retroarch, emulator are working again. Thanks for the responses

    #101074
    Profile photo of petrockblog
    petrockblog
    Keymaster

    the controller issue is something else I think – the OP shoudl also try another controller out – strange it suddenly stopped working, so maybe something unrelated to retropie.

    #101078
    Profile photo of dragonjarvis
    dragonjarvis
    Participant

    So I did full binary and script just in case.

    My controller did not work at first, however during emulation it showed me when I unplug/plug it and then it kinda worked for a couple of seconds.
    I tried to reload my savestat BUT the savestate hotkey is now just the select button instead of select+right trigger.
    So I accidently overwirte my savestate and then the controller stopped working again.
    And loading the savestate is on select+left trigger, so I cannot test this out…

    Unfortunatly I dont have another controller to use now.

    What details do you need excactly?

    Pi Model: 2B
    RetroPie Version Used: 3.0 BETA 4
    Built From: SD Image, then run binary
    USB Devices connected: /
    Controller used: Speedlink XEOX sl-6556-BK
    Error messages received: if that means the runcommand log, its empty
    Guide used: Tutorial German
    File: how do i figure that out?
    Attachment of config files: I dont know or found a solution on which i need to show you
    How to replicate the problem: Play playstation game, savestate and loadstate often in a short time, because you kept dying.

    Yes, I did read Suggestion Support thread, however after even searching the internet for a couple of hours i couldn’t find proper solutions on how to show you the files and logs you may need.

    #101081
    Profile photo of petrockblog
    petrockblog
    Keymaster

    please post the contents of the file(s) in in /opt/retropie/configs/all/retroarch-joypads (this folder is accesssible over samba/windows file sharing)

    Then remove them, and go to retropie-setup in emulationstation and go to supplementary menu, and run the retroarch input configuration option. Configure your joypad there, and then test if the controller works in emulation. Please also post me a copy of that controller config – which should be in the same location as above.

    please use a pastebin site for posting the configs.

    #101087
    Profile photo of dragonjarvis
    dragonjarvis
    Participant

    There are 4 files. Two cfg files and two bak files. I hope you dont need the bak files. Maybe I should’ve mentioned that I am working with linux mint.

    Is there i specific syntax i should highlight?

    Microsoft_X-Box_360_pad.cfg
    MicrosoftX-Box360pad.cfg

    After I deleted everything in that folder as you said I went into Setup /Configuration and from there I picked 318 “Configure Input devices for RetroArch”

    So I can tell you that this didn’t worked out to well, because for the first time i could not configure my thumbsticks there. Pressing them down worked fine but it timed out on any direction i pressed with the left and right thumbstick.
    I did this 3 times but it refuses to work.
    This is what I got:

    MicrosoftX-Box360pad.cfg

    Please bear with me. I know it takes a long time for me to do this stuff.

    #101088
    Profile photo of petrockblog
    petrockblog
    Keymaster

    you could try editing this manually – removing

    
    input_l2_axis = "+2"
    input_r2_axis = "+5"
    input_r_x_plus_axis = "-4"
    input_r_x_minus_axis = "-4"
    input_r_y_plus_axis = "-4"
    input_r_y_minus_axis = "-4"
    

    and see if that helps – or cut it down even more with just directions and ab xy –

    also please post /opt/retropie/configs/all/retroarch.cfg

    #101093
    Profile photo of dragonjarvis
    dragonjarvis
    Participant

    So after searching over an hour to find out how to use samba I created a new topic and asked around, because I thought I gave you the config datas you needed =/.

    However, I looked at some setup options and decided to download the xbox360 driver. After that it detected 2 controlers altough only one is plugged in, then I deleted all raspian files wich are not needed and after that i started a game.. controller works now but when i hit the hotkeys to open retroarch, it is completly bugged out! xD at first the option to select the savestates were gone but I tried to savestate anyway and after that i couldnt move the dpad in retroarch anymore and the font was craped out…

    So what I decide to do now is to save the savegame file of my game, completly format the SDcard yet again, then download the image for the 3rd time, just in case and then carefully watch a tutorial on how to install retropie again. I am kinda tired of this for now.

    I am afraid though that i might corrupt my sd card because I had to format it daily since retropie just refuses to work for me.

    I really, really apreciate your help though!!

    #101123
    Profile photo of strunze
    strunze
    Participant

    Thanks Buzz,
    Works perfectly now. Thank you to yourself and to all involved. Big Up 🙂

Viewing 17 posts - 1 through 17 (of 17 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar