Having controller issues (xbox and snes)

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Having controller issues (xbox and snes)

This topic contains 4 replies, has 2 voices, and was last updated by  kdesilva 3 years, 9 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #82586

    kdesilva
    Participant

    Hey there, I’ve got my Raspberry Pi B+ setup with a fresh install of RetroPie 2.3 using the binary source code installation (only took around 20 hours). I had it setup with the image downloaded from the site earlier but the controllers weren’t working on that either…

    I’m trying to get an xbox360 wired controller working and a cheap amazon bought snes usb controller.

    I installed the 360 drivers, and I registered my controller with retroarch (although no menu came up to take me through setup)

    I’ve also setup the controllers through emulation station and mapped the controls to the commands ..

    So emulationstation works (although after the second installation there’s no background, just white with black text), and both controllers can navigate around in it .. but neither of my controllers work IN GAME.

    I’ve only tried one ROM (super mario world) on the NES and neither of them are recognized. Help please!

    #82587

    krux02
    Participant

    the controller you configure in the frontend is only for the frontend. You have to configure your controller as a retro-arch controller in the setup. Then it works also ingame, but you won’t be able to exit the game with the controller. There is documentation about it, but I just want to mention you are not alone with having this problem.

    #82588

    kdesilva
    Participant

    Yeah see I did this:

    cd RetroPie-Setup
    sudo ./retropie_setup.sh

    I then selected “Register controller for RetroArch emulator” and I thought it would prompt me for my controller, but it didn’t.

    It ran some command line codes for a brief half a second then went back to the menu

    #82589

    kdesilva
    Participant

    I just ran

    jstest /dev/input/js0

    and it recognizes the input ..

    I tried

    sudo chown pi /opt/retropie/configs/all/retroarch.cfg
    cd /opt/retropie/emulators/RetroArch/installdir/bin
    sudo ./retroarch-joyconfig -j 0 >> /opt/retropie/configs/all/retroarch.cfg

    and it says joyconfig command not found..

    #82660

    kdesilva
    Participant

    Got it working!

    Did all of the above – this time I ran it as the ROOT user … had to setup a password for it first, then switch to root in the command prompt

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

We use Cookies and similar technology to collect and analyse information about the users of this website. We use this information to enhance the content, advertising and other services available on the site. Please click ‘Accept cookies’ to consent to the use of this technology by petrockblock. You can manage your preferences at any time by visiting our Cookies Policy page.