Hat Input on Classic XBOX controller – Mame4all

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Hat Input on Classic XBOX controller – Mame4all

This topic contains 0 replies, has 1 voice, and was last updated by  thatilguy 3 years, 6 months ago.

Viewing 1 post (of 1 total)
  • Author
  • #15628


    I’ve recently switched from PiPlay to tryout RetroPie. It’s pretty awesome.

    Anyway, I have a classic XBOX Pelican Real Arcade stick (Kind of like this which I’ve hacked for USB. When I first plugged it in, ES recognized it and I was able to set it up for navigation. It also worked just fine with RetroArch config and in the NES emulator.

    When I got to MAME (Which I believe is now Mame4All), I could not get the stick to register. The buttons work just fine. What I recalled about my configuration for Mame4all in PiPlay was that the inputs came across as being from Hat 0. I had also used xboxdrv to get it to work. So, I installed the xboxdrv from the config menu. The next reboot, ES showed that I had 2 controllers installed. I held the button on the deck of the stick and configured it in ES. The joystick inputs showed up as being from the Hat. I went into mame4all and is still not recognizing the hat input (the buttons still work).

    So, it seems to me that I have 2 drivers running simultaneously, and mame4all is confused about what to use.

    Anyone have any thoughts about this? I haven’t tried manually editing the mame4all config file to look for the hats, but I suspect that it just won’t see them. When I did this before, I could configure it using the tab menu.


Viewing 1 post (of 1 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss