Graphic filter in FBA? I want to blur the pixels.

Welcome Page Forums RetroPie Project Video Output on RetroPie Graphic filter in FBA? I want to blur the pixels.

This topic contains 23 replies, has 4 voices, and was last updated by Profile photo of Floob Floob 2 years, 1 month ago.

Viewing 24 posts - 1 through 24 (of 24 total)
  • Author
    Posts
  • #98268
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Hello,

    I am running Street Fighter 3 in FBA using lr-fba, but the graphics are not blurred, how do I enable this?

    I hit x on when I run the game but can’t see an option to chnage the graphics.

    Thanks

    #98274
    Profile photo of Floob
    Floob
    Member

    As it uses libretro (lr) you could apply shaders, or overlays etc..

    Here is a basic overview on shaders

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98278
    Profile photo of patrickm
    patrickm
    Participant

    If you just want simple bilinear filtering, this is enabled in the RGUI under settings -> video settings -> scroll to where it says point filtering and change it to bilinear

    You could also check out the blur shaders in the shaders/blur directory, but you will have to set render resolution no higher than 960×720 which will cause scaling issues on a non-720p native display. (See: “how to get perfect scaling and list of recommended resolutions”) You might not notice this, however, if using a blur shader.

    #98283
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Thanks guys, I’m trying to change the filters in the game (like in the video) using my keyboard but nothing works, I tried to edit the /opt/retropie/configs/fba/fba2x.cfg file like below, but nothing works. How do you configure the controls for the keyboard and what does yours look like?

    Then I can try the the filter settings

    [Keyboard]
    # Get codes from /usr/include/SDL/SDL_keysym.h
    A_1=a
    B_1=b
    X_1=z
    Y_1=x
    L_1=c
    R_1=v
    START_1=q
    SELECT_1=w
    LEFT_1=276
    RIGHT_1=275
    UP_1=273
    DOWN_1=274
    QUIT=27
    #player 2 keyboard controls, disabled by default
    A_2=999
    B_2=999
    X_2=999
    Y_2=999
    L_2=999
    R_2=999
    START_2=999
    SELECT_2=999
    LEFT_2=999
    RIGHT_2=999
    UP_2=999
    DOWN_2=999

    #98284
    Profile photo of patl
    patl
    Participant

    You can set the option in RGUI:
    Settings – Video Settings – Use Bilinear filtering

    “Point filtering
    to
    “Bilinear filtering”

    But you have to save the config and restart the emulator.
    Or in the config.cfg you can set: video_smooth = true

    In Combination with a scanline overlayimage it looks much better than a blur shader in higher resolutions.
    And there are no performance issues.

    #98285
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Hmm I can’t find this, I’m on the retropie menu and I can’t see the settings option?

    #98286
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Guys I can’t locate this RGUI

    You can set the option in RGUI:
    Seetings – Video Settings – Use Bilinear filtering

    please help

    #98287
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    In the file:

    /opt/retropie/emulators/retroarch/retroarch.cfg I have this, ingamer no controls work but the retropie menu works:

    # Keyboard input, Joypad and Joyaxis will all obey the “nul” bind, which disables the bind completely,
    # rather than relying on a default.
    # input_player1_a = x
    # input_player1_b = z
    # input_player1_y = a
    # input_player1_x = s
    # input_player1_start = enter
    # input_player1_select = rshift
    # input_player1_l = q
    # input_player1_r = w
    # input_player1_left = left
    # input_player1_right = right
    # input_player1_up = up
    # input_player1_down = down
    # input_player1_l2 =
    # input_player1_r2 =
    # input_player1_l3 =
    # input_player1_r3 =

    #98290
    Profile photo of Floob
    Floob
    Member

    Guys I can’t locate this RGUI

    You can set the option in RGUI:
    Seetings – Video Settings – Use Bilinear filtering

    please help

    In your first post you say you are running lr-fba, but then further down you refer to a config file from pifba.
    Check this post for the config file locations depending on the emulator you are using (you set the emulator when pressing x when the game starts):

    MAME versions and romsets on RetroPie

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98294
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    I thought that was the file for ir-fba, so what are the 2 locations one for ir-fba and pifba?

    Once they keyboard is set do I then hit x as the game boots up to set the bilinear filter as I have yet to find rgui – settings –

    Thanks

    #98297
    Profile photo of Floob
    Floob
    Member

    The link in the previous post shows the locations for the config files.

    Then if you use lr-fba you can access the RGUI when the game is running.
    Press your hotkey and F1 to bring it up. Or just F1 if no hotkey is set.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98359
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Thanks for the link.

    Main goals are to get the keyboard to work in fba pifba and if-fba and then use hot key + f1 to try the filters.

    So I try and configure a game using FBA (pifba) which according to the link uses /opt/retropie/configs/fba/fba2x.cfg

    under the keyboard section I have these controls, and none of them work and I don’t even see a link to the hot key:

    [Keyboard]
    # Get codes from /usr/include/SDL/SDL_keysym.h
    A_1=a
    B_1=b
    X_1=z
    Y_1=x
    L_1=c
    R_1=v
    START_1=q
    SELECT_1=w
    LEFT_1=276
    RIGHT_1=275
    UP_1=273
    DOWN_1=274
    QUIT=27

    I start a game and keyboard doesn’t work, just the tab key to insert a coin.

    I then try a game in If-fba which uses /opt/retropie/configs/fba/retroarch.cfg

    in the file it just shows:

    #include “/opt/retropie/configs/all/retroarch.cfg”
    # All settings made here will override the global settings for the current emulator core
    input_remapping_directory = /opt/retropie/configs/fba/

    So I think it uses the global settings in /opt/retropie/configs/all/retroarch.cfg

    So I head there:

    # Keyboard input, Joypad and Joyaxis will all obey the “nul” bind, which disables the bind completely,
    # rather than relying on a default.
    input_player1_a = x
    input_player1_b = z
    input_player1_y = a
    input_player1_x = s
    input_player1_start = enter
    input_player1_select = lshift
    input_player1_l = q
    input_player1_r = w
    input_player1_left = left
    input_player1_right = right
    input_player1_up = up
    input_player1_down = down
    # input_player1_l2 =
    # input_player1_r2 =
    # input_player1_l3 =
    # input_player1_r3 =

    I then try a game and not one key works.

    What am I doing wrong??

    #98362
    Profile photo of Floob
    Floob
    Member

    One thing you need to be clear on is the following (for RetroPie 3):

    pifba has nothing to do with RetroArch, so anything referred to in retroarch.cfg wont have any affect at all, whatsoever.
    http://sourceforge.net/projects/pifba/

    lr-fba (fba libretro)
    This does use the retroarch.cfg
    https://github.com/libretro/fba-libretro

    Here is how they are started via the emulators.cfg file

    pifba="/opt/retropie/emulators/pifba/fba2x %ROM%"
    default="pifba"
    lr-fba="/opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-fba/fb_alpha_libretro.so --config /opt/retropie/configs/fba/retroarch.cfg %ROM%"

    You can choose between the 2 emulators by pressing x as you start the game.

    However, they both use roms from /home/pi/RetroPie/roms/fba and they both need different romsets (as per link above). So you really need to choose which one you want. Using both would require some tweaking to various files.

    So first step would be to choose which one you prefer. If you have a Pi2 I would be tempted to go with lr-fba as this uses a newer romset.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98363
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Right I can see pifba which uses /opt/retropie/configs/fba/fba2x.cfg has to use codes from /usr/include/SDL/SDL_keysym.h

    So that is better now, what is the hot key?

    Still not luck with if-fba’s keybord controls though

    #98365
    Profile photo of Floob
    Floob
    Member

    There are no hotkeys in pifba – that is for lr-fba only.

    In pifba here are the graphic options:
    [Graphics]
    DisplaySmoothStretch=1
    # Display Effect: 0 none, 1 scanlines
    DisplayEffect=0
    DisplayBorder=0
    MaintainAspectRatio=1

    The readme file is here:
    http://sourceforge.net/projects/pifba/files/

    DisplaySmoothStretch - Disable anti-aliasing smoothing.
    DisplayEffect - Postprocessing scanline filter.  For the scanlines filter it is recommended you switch off "DisplaySmoothStretch".
    DisplayAutoRotate - For vertical games auto rotate the display.
    MaintainAspectRatio - Keep the original game display ratio or fill the screen.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98366
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Thanks, I’m getting further now.

    2 things left. In ir-fba I can’t quit a game, I dont see the line to edit?

    # Keyboard input, Joypad and Joyaxis will all obey the “nul” bind, which disables the bind completely,
    # rather than relying on a default.
    input_player1_a = z
    input_player1_b = x
    input_player1_y = a
    input_player1_x = s
    input_player1_start = w
    input_player1_select = q
    input_player1_l = c
    input_player1_r = v
    input_player1_left = left
    input_player1_right = right
    input_player1_up = up
    input_player1_down = down
    # input_player1_l2 =
    # input_player1_r2 =
    # input_player1_l3 =
    # input_player1_r3 =

    And you mention I need to I need to use a hotkey to add a filter to my graphics like bilinear, how do I do this as I don’t have a hotkey?

    #98367
    Profile photo of Floob
    Floob
    Member

    lr-fba uses hotkeys in the same way as all the other retroarch based libretro cores.

    Please see this video on how to use hotkeys.
    (I wouldnt recommend editing the main retroarch.cfg at all to be honest)

    And for the new paths in RetroPie 3

    If you watch those 2 videos, you’ll know just as much as me on the subject (which isnt that much! 🙂 )

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98370
    Profile photo of Floob
    Floob
    Member

    Although to be honest, you could probably do this easily with these steps.

    1 – Write a clean RetroPie 3 beta 2 image to a SD card
    2 – Expand card (raspi-config)
    3 – Copy the romsets for lr-fba to your Pi (These are different to the romsets for pifba)

    MAME versions and romsets on RetroPie

    https://github.com/retropie/RetroPie-Setup/wiki/Managing-ROMs

    4 – Choose lr-fba as the default FBA emulator by pressing x when you start a game (you only have to do that once)

    Your hotkey should already be set on the controller (select). Hold select and tap “x” on the joypad (or F1 on the keyboard) to bring up RGUI.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98389
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Might be worth a go if you think it should all work straight from the word go using the defaults.

    I do have a backup of the retropie configs, maybe I could just copy over the current files with the originals? If so which ones?

    #98391
    Profile photo of Floob
    Floob
    Member

    Yes, it should work with the defaults.

    Do you have a spare SD card? That would be easiest.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98400
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    No but I could back the current one up and format it.

    At what point do I use the F1 + x keys to set the graphics options up for all the games?

    #98419
    Profile photo of Floob
    Floob
    Member

    When you are running the game (any point when the game is running) in lr-fba, hold select and press “x” on the joypad (or “F1″ on the keyboard”.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98426
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Thanks, but where is this:

    If you just want simple bilinear filtering, this is enabled in the RGUI under settings -> video settings -> scroll to where it says point filtering and change it to bilinear

    #98430
    Profile photo of Floob
    Floob
    Member

    Have you opened RGUI up?
    RGUI will NOT work with pifba, only with lr-fba.

    To open it, when in a game, hold your hotkey (usually select) and press”x” on joypad, or “F1” on keyboard.

    It’ll look a bit like this:
    RGUI

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 24 posts - 1 through 24 (of 24 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar