gPSP – no sound

This topic contains 3 replies, has 1 voice, and was last updated by Profile photo of techlibrarian techlibrarian 2 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #85426
    Profile photo of techlibrarian
    techlibrarian
    Participant

    I installed RetroPie from source last week and I have Genesis, Master System, PSX, SNES, NES, GB, GBC, PC Engine, and Sega CD all working great. They are fast, have sound and the controllers are working great.

    GBA is running smoothly and works great with the controller, but there is no sound at all. I tried different sound frequencies in the settings (by pressing F10 in-game).

    I have a Raspberry Pi B+ and have it going through HDMI.

    Any thoughts?

    #85479
    Profile photo of techlibrarian
    techlibrarian
    Participant

    Shameless bump!

    Anyone else experience anything like this or know where I should at least start looking/researching?

    #85725
    Profile photo of techlibrarian
    techlibrarian
    Participant

    I may have resolved this issue.

    I increase my swap file size from 128MB to 512MB and now several games that I tried this morning worked with full sound.

    I will mark as resolved for now and will update if the issue persists.

    #85774
    Profile photo of techlibrarian
    techlibrarian
    Participant

    Update for those who may run into the same issue:

    I started up the Pi again this morning and lo and behold: GBA has no sound for all games.

    I tried starting up a Sega Genesis game first and then all GBA roms have sound again. I shut down and restarted and tried GBA. No sound. Started an NES rom next and then came back to GBA again. Sound works for all roms again.

    I shut down and power off the Pi every night. My best guess is that gPSP fails to start some sound-related process that every other emulator does start.

    At least there is a work around.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar