Gpsp GBA refuses to save config

This topic contains 7 replies, has 4 voices, and was last updated by  Jemall 2 years, 11 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #12515
    Profile photo of capeman
    Tony

    So to edit the settings on gpsp, you have to leave emulation station and open gpsp via command line. Gpsp loads in fine, I open the config and set video filtering off, then set controls. To test, I load and run a rom. Rom runs with no filtering and correct controls. Ok, check. Use the emulator menu to exit.

    This should save the settings, but when I load emulation station or gpsp again, all settings have reverted back to default.

    I read somewhere that there should be a gpsp.cfg file somewhere but it’s not in the emulators folder when I remote into the pi from my computer.

    Any help would be appreciated, it’s hard to play with blurry graphics and the B/A buttons reversed haha. Thanks!

    #12516
    Profile photo of capeman
    Tony

    Should mention that I am using the version 2.1 of retropie from July 4th I think. New emulation station is pretty great.

    #12524
    Profile photo of zsprawl
    zsprawl
    Participant

    Move to version 2.2 and run:

    sudo chown pi -R /opt/retropie/configs/

    #12536
    Profile photo of capeman
    capeman
    Participant

    Question though, are the cfg files for gpsp saved in the folder you had me set permissions for above? there is no gba folder in the /opt/retropie/configs/ folder…

    There appear to be some config files in the /opt/retropie/emulators/gpsp/raspberrypi folder… but when i make changes to the files, they don’t affect the emulator when it runs on the pi.

    I just want to make sure theres a way i can change this out without having to flash my drive and reinstall 2.2, did a lot of work making my 2.1 install good, don’t want to have to redo everything (unless there is a way to upgrade without losing all my settings).

    Thanks for your help.

    #12541
    Profile photo of smatticus
    smatticus
    Participant

    You can edit config in gsps by hitting “select” and “r” in a game and then change setting there. F10 on a keyboard does the same. Not sure about the saving of the settings

    #12542
    Profile photo of capeman
    capeman
    Participant

    zsprawl:
    Nevermind. Your fix works, but you have to take out the configs folder and run the ownership change command on the entire retropie folder, since the config files for gpsp are not saved in the configs folder.

    This is definitely related to the bug in ownership that popped up in 2.1.

    smatticus:
    Already knew about the select/R menu option, problem was it wasn’t saving the config files on emulator exit, all settings would default when gpsp was closed and loaded again.

    #12800
    Profile photo of dem1980
    dem1980
    Participant

    In my case, i had to do :
    sudo chmod 777 /opt/retropie/emulators/gpsp/raspberrypi/gpsp.cfg
    or
    sudo chmod -R 777 /opt/retropie/emulators/gpsp/raspberrypi/
    gpsp config file is in this directory in 2.2 for me.

    #18191

    Jemall

    THX TO zsprawl

    You helped me alot :)))

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar