Getting WiFi working with RetroPie?

Home Forums RetroPie Project Everything else related to the RetroPie Project Getting WiFi working with RetroPie?

This topic contains 13 replies, has 3 voices, and was last updated by Profile photo of sinfulangle sinfulangle 3 years, 1 month ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #6287
    Profile photo of sinfulangle
    sinfulangle
    Participant

    How would I go about with getting WiFi working with the RetroPie?

    I currently have the ‘Edimax EW-7811UN 150Mbps Wireless Nano USB Adapter’ and the ‘lusb’ command tells me that the Pi detects the USB.

    I have done a bit of googling and research but no tutorials or assistance results with getting WiFI working with the Pi & RetroPie installed.

    Thanks guys.

    #6288
    Profile photo of RazorX2014
    RazorX2014
    Participant

    load up wpa_gui from the start menu click scan then double click your network then in the “PSK” field, enter your wireless password and click add

    #6289
    Profile photo of sinfulangle
    sinfulangle
    Participant

    load up wpa_gui from the start menu

    How would I do so?

    And is that the RetroPie Start Menu?

    Edit:I do not have any OS on the Pi, just RetroPie.

    #6291
    Profile photo of RazorX2014
    RazorX2014
    Participant

    i edited my comment but you need to get to the desktop by hitting f4 from retropie then typing in startx

    #6292
    Profile photo of sinfulangle
    sinfulangle
    Participant

    i edited my comment but you need to get to the desktop by hitting f4 from retropie then typing in startx

    Awesome, thank you for your help! Currently doing that now.. then WiFi should work with RetroPie?

    #6294
    Profile photo of RazorX2014
    RazorX2014
    Participant

    yup

    once its all working set this post to resolved ๐Ÿ™‚

    #6295
    Profile photo of sinfulangle
    sinfulangle
    Participant

    yup

    once its all working set this post to resolved :)

    Maybe I didn’t explain myself properly but the problem I’m having is I cannot get an IP from RetroPie. When I enter ‘ifconfig’ it gives an IP of ‘10.0.0.4’ instead of something like ‘192.168.x.x’.

    I did get the internet working instead Raspbian but I want to get the USB WiFi dongle working with RetroPie.

    Thanks. ๐Ÿ™‚

    #6296
    Profile photo of RazorX2014
    RazorX2014
    Participant

    if you enter startx and setup the wifi and get it working when you logout and go back to retropie it will still be connected to the wifi retropie is basically just a script running on raspbian

    #6297
    Profile photo of sinfulangle
    sinfulangle
    Participant

    if you enter startx and setup the wifi and get it working when you logout and go back to retropie it will still be connected to the wifi retropie is basically just a script running on raspbian

    Hmm, yes I did all that but when I’m back to RetroPie the IP address is giving me still an internal IP.

    What I am trying to do is connect to the Pi using Cyberduck to drag & drop ROMS into the Pi.

    Maybe I am doing something wrong :\

    #6298
    Profile photo of RazorX2014
    RazorX2014
    Participant

    i can do that on mine it should work on yours try loading up RetroPie_Setup.sh and setting up samba i think it is that might sort it for you all i can say is it works on mine

    #6299
    Profile photo of sinfulangle
    sinfulangle
    Participant

    i can do that on mine it should work on yours try loading up RetroPie_Setup.sh and setting up samba i think it is that might sort it for you all i can say is it works on mine

    Got it working, I just pressed network on my PC and my Pi was detected and I’m now dragging & dropping ROMS on, thank you for all your help! ๐Ÿ™‚

    #6302
    Profile photo of RazorX2014
    RazorX2014
    Participant

    np glad i could help remember to set the post to resolved ๐Ÿ˜‰

    #6436
    Profile photo of karloss
    karloss
    Participant

    the process is exactly the same as raspbian…

    Step 1.
    Boot the Raspberry Pi without the WiFi adapter plugged in.

    Step 2.
    Open a Terminal session by clicking on the LXTerminal icon, and enter the
    following command into it:

    sudo nano /etc/network/interfaces
    

    Then Edit the file to look like this –

    auto lo
     
    iface lo inet loopback
    iface eth0 inet dhcp
     
    allow-hotplug wlan0
    auto wlan0
     
     iface wlan0 inet dhcp
            wpa-ssid "ssid"
            wpa-psk "password"

    Step 4.
    When you have finished press [ctrl]x. This will ask if you want to save the modified files.
    Press ‘Y’ and then Return to save the file with the same name.

    Step 5.
    Shut down your Raspberry Pi, plug the WiFi adapter in and start it up again. You should find that the Raspberry Pi connects using the WiFi adapter as it boots up.

    job done ๐Ÿ™‚

    #6440
    Profile photo of sinfulangle
    sinfulangle
    Participant

    the process is exactly the same as raspbianโ€ฆ

    Step 1.<br>
    Boot the Raspberry Pi without the WiFi adapter plugged in.

    Step 2.<br>
    Open a Terminal session by clicking on the LXTerminal icon, and enter the<br>
    following command into it:

    sudo nano /etc/network/interfaces
    

    Then Edit the file to look like this โ€“

    auto lo
     
    iface lo inet loopback
    iface eth0 inet dhcp
     
    allow-hotplug wlan0
    auto wlan0
     
     iface wlan0 inet dhcp
            wpa-ssid "ssid"
            wpa-psk "password"

    Step 4.<br>
    When you have finished press [ctrl]x. This will ask if you want to save the modified files.<br>
    Press โ€˜Yโ€™ and then Return to save the file with the same name.

    Step 5.<br>
    Shut down your Raspberry Pi, plug the WiFi adapter in and start it up again. You should find that the Raspberry Pi connects using the WiFi adapter as it boots up.

    job done :)

    Thank you for your help, although I got it working last week with RazorX2014’s assistance! Thanks anyway ๐Ÿ™‚

Viewing 14 posts - 1 through 14 (of 14 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar