Getting RetroPie started

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! Getting RetroPie started

This topic contains 13 replies, has 4 voices, and was last updated by Profile photo of aton aton 1 year, 11 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #101291
    Profile photo of aton
    aton
    Participant

    Hi everybody,

    I made a little PDF walkthrough with some screenshots on how to get started:
    Get the image onto SD
    Get RetroPie to fire up
    How to mount your roms via USB HD (or stick)
    and how to scrape your roms.

    Hope the collected bits and pieces help you get it rolling.

    Edit 2015-07-13
    -Clarified how to get to the ‘roms’ share (in Windows)
    -Added the line to get sselph for the Pi1
    I just let WordPress number the files until I can delete them somehow

    Edit 2015-07-09
    -Modified the link of sselph to reflect v0.9.3-beta
    -Changed color of ‘mirror ROM folder structure to HDD’

    How do I remove the old file -.-

    #101542
    Profile photo of thatguyinfl
    thatguyinfl
    Participant

    Thank you for this!

    Luis

    #101547
    Profile photo of thatguyinfl
    thatguyinfl
    Participant

    Quick question. doesnt this “sudo rm * -rf” remove all directories? Would it be easier to copy them to the hdd first?

    #101737
    Profile photo of aton
    aton
    Participant

    It actually does. Just had a peek in case I forgot, but:
    Section 3 under ‘g’ I mention that you should mirror the ‘roms’ folder structure.

    I could change the color of it or make it bold maybe… if it is overlooked it can get a bit tricky, true.

    #101901
    Profile photo of pdlane43
    pdlane43
    Participant

    This is awesome, but can you tell me what I actually need to do in order to get connected via Putty?

    I’ve flashed my 16 gig SanDisk MicroSD card with RetroPie v3 beta 4. I’ve gotten it to boot and run, what appears to be, successfully on my TV. I have the Pi2 on my network and can identify the correct IP Address.

    I am not able to connect via Putty. Nothing shows up in the list, when I key in the IP address, I just get errors.

    #101935
    Profile photo of aton
    aton
    Participant

    Actually you should be able to connect via the name ‘retropie’.
    If you open a commandprompt and type ‘ping retropie’ it should show you the IP address so you are sure you have the right one.

    Also make sure you changed Putty’s connection type to ‘SSH’.

    I added a picture with pointers how it should look (and work).

    Attachments:
    #101946
    Profile photo of xxwerdxx
    xxwerdxx
    Participant

    Ok so 2 things:

    1. I think I might love you for this guide. I’ve been unreasonably stuck for too long!

    2. In section 3giii, am I doing that on the USB or the Pi itself?

    Edit: I pushed ahead on the Pi and I ran into another issue. When I typed in “scraper -scrape_al-thumb_only”, I got back “runtime: this CPU has no VFPv3 floating point hardware, so it cannot run this GOARM=7. REcompile using GOARM=6”. How do I get around this?

    #101966
    Profile photo of aton
    aton
    Participant

    1. Thank you very much. Thought it might help. Lost some hair too until it worked 😀

    2. I’ll clarify this in the next version:
    -> in Win use ‘Run’ (Windowskey+R) to type ‘\\retropie’
    -> go into the ‘roms’ share there and copy all
    -> then access your USB drive and paste the structure there
    This will make sure you have the right structure for the Pi to recognize

    Yes, I just checked -> My bad as I only showed the Pi2 version. You have the 1 I guess, so it would change to:
    wget https://github.com/sselph/scraper/releases/download/v0.9.3-beta/scraper_rpi.zip

    (Notice the missing ‘2’ at the end)
    Nothing changes with the handling.

    Let me know if it works or not. I’ll edit the guide as soon as I can.

    #102092
    Profile photo of pdlane43
    pdlane43
    Participant

    This is correct advice, but I had to enable SSH on my Pi before this would work.

    Thanks!

    #102116
    Profile photo of aton
    aton
    Participant

    Good point. Will add a note in the guide to enable it. Must have been an automatic thing for me to do -.-

    #102147
    Profile photo of thatguyinfl
    thatguyinfl
    Participant

    Is it necessary to update binaries if you have the latest image?

    For some reason if I update binaries after setting up controls in emulation i cant move left or right but buttons work.

    If I just use beta 3 update 4 and perform the entire tutorial, after setting up controls in emulation station, i can move left and right.

    Anyways, was curious if we had to update or not.

    Thanks

    Luis

    #102155
    Profile photo of aton
    aton
    Participant

    I have several ‘annoyances’ when using the new image and traced that to the newest update of Retroarch.
    Getting my XBox360 pad to work correctly is more than a pain in the behind
    Retroarch freezes when enumerating my roms directory (black screen)

    What I did was rolling back to my previous installation and then updating everything except Retroarch -> works nicely.

    Have not gotten around to look at the Amiga emulation though, the XBox joypad seems to be at war with the emulator -> moving left or right without any input from me, though it looks like a problem with the deadzone of the analog stick

    #102224
    Profile photo of thatguyinfl
    thatguyinfl
    Participant

    So you recommend us using the latest image and updating the binaries per your guide. Does retroarch not get updated this way?

    Sorry im new to this and more curious than anything.

    Thank for the great guide by the way.

    Luis

    #102262
    Profile photo of aton
    aton
    Participant

    Retroarch is already updated in the latest image as far as I know.
    Am also not sure if it is my setup or a general ‘problem’. I had quite a few difficulties getting my XBox joypad configured in Retroarch due to the analog triggers being detected too quickly.
    To configure mine I use the console based dialog in RetroPie.

    I have to add that I converted my whole PSX collection to ISO and that is a lot, that might cause it to hang while enumerating.

    So my advice: Try the newest image, update all and see if it works for you.

    You are welcome.

Viewing 14 posts - 1 through 14 (of 14 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar