Getting full screen in SNES emulator

Home Forums RetroPie Project Everything else related to the RetroPie Project Getting full screen in SNES emulator

This topic contains 7 replies, has 6 voices, and was last updated by Profile photo of gypohansel gypohansel 2 years, 3 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #4808
    Profile photo of marcy921
    marcy921
    Participant

    Hi guys,

    First post here but I’ve been reading through many posts which have been very helpful.

    Everything is setup and running well including the controller but I just can’t seem to get the games to run in full screen mode. I’m using a 32″ TV running through HDMI at 16:9 aspect ratio.

    Things I’ve tried:

    changing the runcommand from 1 to 2 in es_systems.cfg

    This actually made the game run in a smaller window for some reason.

    I also tried something I seen on another site

    I edited /RetroPie/configs/all/retroarch.cfg

    video_aspect_ratio_auto = True
    video_aspect_ratio = 1.25

    This made the SNES emulator fill the screen but it also cut a bit off the top which was playable but quite annoying.

    Any ideas where I’m going wrong?

    Many Thanks

    #4809
    Profile photo of brooksyx
    brooksyx
    Participant

    video_aspect_ratio = 1.25

    Maybe try a different number than 1.25, I had to play with different numbers until I found one that worked well with my screen. For some reason 1.25 did the trick. Which is odd because 1.25 is 4:3.

    #4824
    Profile photo of goremachine
    goremachine
    Participant

    Which is odd because 1.25 is 4:3.

    No. 4:3 is 1.33
    1.25 is 5:4.

    Anyways. Cutoff screen is usually an overscan problem.
    Go to the console (exit emulationstation via F4)
    Type “sudo nano /boot/config.txt
    add the line “overscan_scale=1
    press ctrl+o to save
    press ctrl+x to quit
    type “sudo reboot now
    Retry the emulator.

    And for the aspect ratio, edit your config
    nano /home/pi/RetroArch/configs/snes/retroarch.cfg

    Add the lines:
    video_force_aspect = true
    video_aspect_ratio_auto = true

    save+exit.

    This way the rom tells the aspect ratio, which is 8:7 snes-internally and then gets stretched to 4:3 automatically. And the forced aspect should keep it 4:3 no matter what the aspect of your display is.

    hth.

    #4857
    Profile photo of marcy921
    marcy921
    Participant

    Thanks for the replies guys.

    I’ve added overscan_scale 1 to the boot config and that does fix a few problems in the emulation station part where bits before would cut off so that was a bonus.

    I also added the below commands to “/home/pi/RetroPie/configs/snes/retroarch.cfg” – I noticed you put RetroArch/configs but I don’t seem to have that directory?

    video_force_aspect = true
    video_aspect_ratio_auto = true

    I still have a problem with black borders although now it is different.

    Fullscreen

    Is this supposed to be how it looks or am I doing something wrong?

    I appreciate all of the help you have provided me with guys.

    Cheers

    EDIT – I’ve attached my cfgs

    EDIT – Seems to of fixed it by commenting disable_overscan=1

    Cheers for the help again, I’m sure I’ll be back again lol

    #4898
    Profile photo of goremachine
    goremachine
    Participant

    Yes, RetroPie/ ofc. I am always mixing up Pie/Arch, also when writing my configs.
    The black borders are most likely from the overscan_scale=1.
    You can remove it again, reboot and see what happens.
    If there’s nothing cut off you’re good.
    If there are portions of the display cut off again, you can manually change them with:
    overscan_left=20
    overscan_right=12
    overscan_top=10
    overscan_bottom=10

    Just change the numbers until it fits.

    I run my Pie on various displays and multiple emulators so i set it to overscan_scale=1. Sometimes there are black borders, sometimes it fits nicely.

    I also have a runcommand.sh that allows 720p, not only VGA and 1080p, to have a compromise between speed/quality when using GLSL shaders for emulating old CRT/LCD/Phosphor displays.

    So it also depends on the resolution chosen.

    However your display looks like it is a 16:9.
    The image shown is 16:9 just cropped as well.
    If thats SNES it’s wrong. SNES should result in a 4:3 🙁

    I had a similar problem when running in VGA mode, the aspect ratio never was constrained, it always changed to 16:9.

    edit your /home/pi/.emulationstation/es_system.cfg
    Find the SNES section.
    there is a COMMAND= section.
    there you should see .…./…/runcommand.sh 1 part
    The 1 means to use VGA mode.
    Change it to a 2. Then it’ll keep the HDMIs native resolution, or the one you forced in boot/config.txt

    Once I changed from VGA to 1080/720, constraining the aspect ratio to 4:3 worked.
    However, I have changed my /RetroPie/supplementary/command/runcommand.sh to be able to switch to 720p.

    If setting graphicsmode to “2” fails, or performance is too slow now due to the high resolution, report back, then I give you my runcommand.sh to switch to 720p. 🙂

    So the summary of this wall of text:
    1) You’re running VGA mode, somehow it’s streched to 16:9 and never constrained to 4:3
    2) Your display is either 1080p or 720p. Change the es_system.cfg so it runs with the bootup-resolution of emulationsstation.
    3) If its 1080p your pie might be too slow -> get my runcommand and force 720p, else all should work now properly.
    4) If the black borders are still there but your display is now nice 4:3, try removing the overscan_scale=1 and reboot to see what you got now 😀

    hth.

    #5473
    Profile photo of anakinpendragon
    anakinpendragon
    Participant

    For me work with two options in /home/pi/RetroPie/conf/all/retroarch.cfg:

    video_fullscreen = true
    video_aspect_ratio = 1.77

    The full screen fit in all retroarch emulators.

    #5548
    Profile photo of n64pie
    n64pie
    Participant

    I keep Getting:
    [ Error writing /RetroPie/configs/all/retroarch.cfg: No such file or directory ]

    Any ideas?

    #92295
    Profile photo of gypohansel
    gypohansel
    Participant

    Did the trick anakinpendrag. Thanks.

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar