GBA Lagging with Crackling Sound

This topic contains 10 replies, has 3 voices, and was last updated by Profile photo of jplaj jplaj 3 years, 11 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1781
    Profile photo of jplaj
    jplaj
    Participant

    I’ve got a RetroPie configured card where everything works well except a few things. One of the problems is the GBA emulator lags terribly. None of the other emulators have this trouble. The games play very sluggishly and the sound is nothing more than bursts of crackling.

    Based on suggestions I’ve found elsewhere, I tried overclocking and increasing the memory split, but they didn’t affect play at all. I found some information about video refresh rates, but don’t quite know how to (or even if I can) set that; I tried running the system using the RCA video output instead of the HDMI cable, but the only thing that did was cut off the signal every time I selected a game.

    Any suggestions?

    Thank you.

    #1783
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Are you using the gpSP emulator, which comes with the recent version of the RetroPie Setup and SD-card download?

    I have “Zelda – Minish Cap” running with full speed and perfect sound.

    #1795
    Profile photo of jplaj
    jplaj
    Participant

    I’m not entirely sure. How do I check? The SD card I’m using came from an image I downloaded that had already run the retropie setup script. I’m not sure how old it is. Is there a way to update if it is old?

    #1865
    Profile photo of petrockblog
    petrockblog
    Keymaster
    #1893
    Profile photo of jplaj
    jplaj
    Participant

    Thank you very much for your help!

    I’ve been playing around with this for the last few days, and I think I’ve solved the problem for the most part.

    I ran the git pull and updated to gpsp, however I still had the same trouble. Each attempt at installing came up with a slightly different error message, and other forums offered bits and pieces of advice. Eventually, I started to suspect the executable file for gpsp was in the wrong place.

    In one installation, I found it under:
    /home/pi/gpsp
    And I copied it to:
    /home/pi/RetroPie/emulators/gpsp/raspberrypi

    Also, based on advice from another forum, I downloaded a gba_bios.bin file and placed it in the same directory as the executable.

    However, I’m not entirely happy with the control scheme. I noticed that the other emulators have options for overriding the universal retroarch.cfg file by altering the .cfg files in their respective folders under /home/pi/RetroPie/configs/

    But gpsp doesn’t seem to have a folder. Is there a way I can reconfigure the control scheme?

    Also, I’m having newfound problems with MAME, but I’m hoping to tinker with that a bit before opening a new thread.

    Thank you again!

    #1894
    Profile photo of jplaj
    jplaj
    Participant

    Sorry, some of my text was cut out. After “….same directory as the executable” I meant to say:

    “Now most the games will load, and don’t run sluggishly. However, a few still crash back to the emulationstation menu. For the most part, though, that problem is solved.”

    #1901
    Profile photo of jbaker1225
    jbaker1225
    Participant

    CD into the directory that your executable is in from the terminal and run ./gpsp
    It will run open a GUI wherein you can configure the controls. Also, anywhere in a game, you can hit Select+R (assuming you know what those are configured to) to bring up that GUI, where you can also quit the game from as well.

    #1915
    Profile photo of jplaj
    jplaj
    Participant

    Thanks. I’ve found the menu, but I’m still having some issues. There’s a menu option for “Configure gamepad input” and one for “Configure analog input,” but when I select them, they take me to a menu with only one option, “Back.”

    Is there a file missing that the menu is trying to read? When browsing through directories manually, I found files marked “input.c” and “input.h” that look like I could potentially edit to change the configuration. Could I do something with this?

    Thanks for the assistance.

    #1917
    Profile photo of jbaker1225
    jbaker1225
    Participant

    Sounds like you are running an older version of gpSP.
    Just download the precompiled binary here: https://www.dropbox.com/s/2x9tz60v06h15u9/gpsp.tar.gz

    Then go into your RetroPie/emulators/gpsp/raspberrypi folder and replace the old gpsp, gba_bios, and game_config.txt files with the new ones you just downloaded.

    That’ll let you do what I described above.

    #1919
    Profile photo of jplaj
    jplaj
    Participant

    That worked great! Thanks.

    #2514
    Profile photo of jplaj
    jplaj
    Participant

    jbaker1225,

    You helped me before on an issue like the one I’m having now and I want to know if you might be able to help again. I’m missing another menu option on the gpsp GUI, the option for setting the flash rom type to 128k. Are there any updated files I could find to add this option?

    Thanks.

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar