Gasia Co.,Ltd PS(R) Gamepad

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Gasia Co.,Ltd PS(R) Gamepad

This topic contains 37 replies, has 5 voices, and was last updated by  slayer 2 years, 1 month ago.

Viewing 35 posts - 1 through 35 (of 38 total)
  • Author
    Posts
  • #108543

    mrco123
    Participant

    Hi !

    Pi Model:2 B
    RetroPie Version Used: 3.2
    Built From: SD Image
    Guide used: wiki
    USB Devices connected:
    Bus 001 Device 005: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
    Controller used: Gasia Co.,Ltd PS(R) Gamepad
    Bus 001 Device 006: ID 054c:0268 Sony Corp. Batoh Device / PlayStation 3 Controller

    Error messages received: none
    pi@retropie ~ $ hcitool scan
    Scanning …
    pi@retropie ~ $ hcitool dev
    Devices:
    hci0 00:11:F6:0B:28:9E

    how to configure this gamepad ???

    thank you for your help !

    M@rco

    #108544

    gizmo98
    Participant

    Looks like a PS3 controller clone!? Try to install ps3controller module. And if it is working please post your controller config files (/opt/retropie/configs/all/retroarch-joypads).

    #108590

    mrco123
    Participant

    Looks like a PS3 controller clone!? Try to install ps3controller module. And if it is working please post your controller config files (/opt/retropie/configs/all/retroarch-joypads).

    hi !
    yes, it’s a PS3 controller clone
    But it not want working in bluetooth mode …

    it work fine in usb mode !!

    my GasiaCo.,LtdPS(R)Gamepad.cfg:

    input_device = “Gasia Co.,Ltd PS(R) Gamepad”
    input_driver = “udev”
    input_r_y_plus_axis = “+3”
    input_r_x_minus_axis = “-2”
    input_r_btn = “9”
    input_save_state_btn = “9”
    input_l2_btn = “10”
    input_start_btn = “3”
    input_exit_emulator_btn = “3”
    input_l_y_minus_axis = “-1”
    input_l_btn = “8”
    input_load_state_btn = “8”
    input_up_btn = “4”
    input_r_y_minus_axis = “-3”
    input_a_btn = “12”
    input_b_btn = “14”
    input_reset_btn = “14”
    input_down_btn = “6”
    input_r2_btn = “11”
    input_l_x_plus_axis = “+0”
    input_l_y_plus_axis = “+1”
    input_right_btn = “5”
    input_state_slot_increase_btn = “5”
    input_x_btn = “15”
    input_menu_toggle_btn = “15”
    input_select_btn = “0”
    input_enable_hotkey_btn = “0”
    input_l_x_minus_axis = “-0”
    input_y_btn = “13”
    input_left_btn = “7”
    input_state_slot_decrease_btn = “7”
    input_r_x_plus_axis = “+2”

    #109523

    slayer
    Participant

    Having the same issue, works fine wired. And if I press the ps button on any genuine Ps3 controller it pairs fine and works but the clone just flash’s until it stops with no sync and then have to restart the unit to use the controller wired again.

    #109528

    gizmo98
    Participant

    There is an qtsixad package with gasia support on github. Default qtsixad does not seem to work with gasia clones.
    https://github.com/falkTX/qtsixa

    #109530

    gizmo98
    Participant

    Just out of interest. Where can i buy this ps3 controller clone?

    #109531

    slayer
    Participant

    Can purchase them on ebay mate.

    How do we go about installing that package.sorry very new to this stuff.

    Thanks for quick response and help.

    #109535

    paperboy
    Participant

    Bump… Good question my local market is flooed witn these clones would be good to see how to fix?

    Sent from my LG-D855 using Tapatalk

    #109666

    gizmo98
    Participant

    I will post something if it is running.

    #109670

    slayer
    Participant

    I will post something if it is running.

    Please do, still can’t get it to work and not sure how to use the install the above method.

    #109883

    gizmo98
    Participant

    You can try this ps3controller module:
    https://github.com/gizmo98/RetroPie-Setup/blob/ps3-gasia-hack/scriptmodules/supplementary/ps3controller.sh

    Or type…

    mkdir test
    cd test
    git clone --depth=1 https://github.com/gizmo98/RetroPie-Setup.git
    cd RetroPie-Setup
    sudo ./retropie_setup.sh

    …and (re)install ps3controller

    #109950

    slayer
    Participant

    I just gave that a go but after typing git clone etc. It said cloning into ‘retropie-setup’ then asks for user name and password? Which I do not have 😔 so it started to work lol

    Ok sorted it out but still no go.thanks anyways.

    #110193

    mrco123
    Participant

    some news about this gasia ?

    #110194

    petrockblog
    Keymaster

    yes – two posts up.

    #110198

    gizmo98
    Participant

    @slayer
    My fault. You need to checkout another branch. Please try…

    mkdir test
    cd test
    git clone --depth=1 https://github.com/gizmo98/RetroPie-Setup.git
    cd RetroPie-Setup
    git pull
    git checkout ps3-gasia-hack
    sudo ./retropie_setup.sh
    #110231

    slayer
    Participant

    @slayer
    My fault. You need to checkout another branch. Please try…

    mkdir test
    cd test
    git clone --depth=1 https://github.com/gizmo98/RetroPie-Setup.git
    cd RetroPie-Setup
    git pull
    git checkout ps3-gasia-hack
    sudo ./retropie_setup.sh

    Champion,I did all that and didn’t think it worked, when I unplugged the control then pressed the p3 button it flashed all four lights fast and then went to a slower flash and just kept flashing then I tried the controls and they work perfectly,not sure how two controls will go but shouldn’t be too much of an issue hopefully, thanks heaps for the help mate.

    #110268

    gizmo98
    Participant

    Good to here it is running! Gasia hack + led support is broken at the moment and i don’t know if it can be fixed.

    #110285

    slayer
    Participant

    Good to here it is running! Gasia hack + led support is broken at the moment and i don’t know if it can be fixed.

    Even if it can’t that’d fine as long as it works I don’t need the LED lights to tell me what player I am ☺ thanks again for helping us out with this issue.

    #110319

    mrco123
    Participant

    hello thank you for the answer ..

    but :
    OK mkdir test
    OK cd test
    OK git clone –depth=1 https://github.com/gizmo98/RetroPie-Setup.git
    OK cd RetroPie-Setup
    OK git pull
    OK git checkout ps3-gasia-hack
    OK sudo ./retropie_setup.sh

    after :
    setup / configuration ?
    install / pair ps3 ?
    install / pair ps3 ?

    but nothing !

    #110321

    slayer
    Participant

    That’s what I did install/pair then it will do its thing and come up with a message saying to connect controller via usb etc etc hit ok, restart and load into ES then disconnect cable and press p3 button wait few seconds and it should be ok, if not go to menu and configure control and it should say 1 gameplay detected then press and hold p3 button ☺

    #110323

    gizmo98
    Participant

    Remove configs/driver (no.2) before you install.

    #110324

    mrco123
    Participant

    okay and thank you !

    OK mkdir test
    OK cd test
    OK git clone –depth=1 https://github.com/gizmo98/RetroPie-Setup.git
    OK cd RetroPie-Setup
    OK git pull
    OK git checkout ps3-gasia-hack
    OK sudo ./retropie_setup.sh

    after :
    setup / configuration
    ok
    install / pair ps3
    ok
    remove ps3 controller
    ok
    install / pair ps3

    a message say me to connect controller via usb
    ok
    restart ( ctrl C )
    emulationstation
    I disconnect cable and I press p3 button …

    but nothing !

    #110356

    slayer
    Participant

    When in ES and you disconnect the usb and press the p3 button what do the lights do on the controller?

    #110381

    mrco123
    Participant

    Hello !

    the 4 lights flash

    #110410

    slayer
    Participant

    I had that happen too,but it was a fast flash for a few seconds then it slowed down, once that happened I was able to configure input in ES menu as it detects a new controller.

    #110566

    mrco123
    Participant

    Hi !!!

    okayyyy !!
    it run !
    I have doing :
    F4
    i disconnect the usb cable
    sixad stop
    sixad start
    it say me ” push on ps3 button ” the 4 led flash
    ” connected to ps3 ……… ” the first led is on
    emulationstation
    ans it’is okay …
    But if i reboot my Pi, the bluetooth connection is down …

    #110607

    mrco123
    Participant

    ok it’s good !
    I modified etc/rc.local
    i added
    hciconfig hci0 piscan
    before
    exit0
    and it’is good !

    #110620

    gizmo98
    Participant

    @mrco123
    Could you test something for me? Remove your rc.local changes. Update RetroPie-Setup and reinstall PS3 controller driver with “clone support”.

    #110627

    mrco123
    Participant

    yes …

    with : sudo ./retropie_setup.sh in
    ~/test/RetroPie-Setup/

    ?

    #110637

    mrco123
    Participant

    i removed my rc.local changes
    i updated retropie-setup in /test/retropie_setup/
    i have run sudo ./retropie-setup in /test/retropie_setup/
    but i have not see “clone support” !!!

    but now, if i reboot , the controller is ok !

    #110660

    gizmo98
    Participant

    Thanks! The next sd card image will have a install option for clones.

    #110673

    mrco123
    Participant

    another probleme ! …

    when i reboot , the controller is ok , but, if i pause the game for 20mn ….
    the controller don’t run ! …. The 4 led flash but nothing …

    #110805

    gizmo98
    Participant

    Sorry i don’t know how to solve this problem at the moment. If you have only one controller enable safety.timeout: “/var/lib/sixad/profiles/default” “enable_safety_timeout 1”

    #110820

    mrco123
    Participant

    ah .. ok !
    thank you !

    I have re-tested yesterday and it’s ok !!! work fine !!!

    #110884

    mrco123
    Participant

    Sorry i don’t know how to solve this problem at the moment. If you have only one controller enable safety.timeout: “/var/lib/sixad/profiles/default” “enable_safety_timeout 1”

    no, don’t work ! …

Viewing 35 posts - 1 through 35 (of 38 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss