gamepad settings are not saved / no retroarch.cfg

Home Forums RetroPie Project Everything else related to the RetroPie Project gamepad settings are not saved / no retroarch.cfg

This topic contains 16 replies, has 4 voices, and was last updated by Profile photo of rhino224 rhino224 2 years, 2 months ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #49333

    Dennis

    Hey,

    I do have a weird problem – every time I set up my gamepad the buttons won’t be saved for some reason. In case I run a game, I can’t do anything because no button seems to be configured – the keyboard works fine.

    Reinstalling retropi didn’t fixed the problem. When retropi starts the first time I have to setup my gamepad which I do but the config is saved nowhere.

    Using a ftp client, I checked the “home/pi/RetroPie/” directory and couldn’t neither find an “emulators” folder nor the “retroarch.cfg”, which I found in “opt/retropie/configs/all/” instead.

    So what am I doing wrong? The whole folder structure is missing in “home/pi/RetroPie/” (except for rom & bios folder).

    Best regards
    Dennis

    #50418

    lewis

    I am experiencing the same issue. I have installed a fresh 2.3 system and on first set up configured the controller for the emulation staiton, which saves and works fine. I’ve also done the command line set up for the xbox controller to use it for the roms, however I have mixed outcomes. On the NES the buttons will work, but on the SNES and other systems the buttons will only work in certain parts of the game then i can’t go any further because the controller appears to have no effect. I have had a look and cannot find the retroarch.cfg file.

    have had a look around but theres a ton of guides all saying different things for different versions of the system

    #51032

    Dennis

    Ya exactly. I used the latest 2.3 sd-card image and it seems that, in my case, some part of the first configuration is missing. I have no idea whether this is because of my USB SNES gamepad or the release itself… this doesn’t work with me:

    “there is a Input Configuration Page. I used this to program my gamepad for the SNES emulator and everything worked great. You are given 3 choices during the configuration, I chose “retroarch”, and it worked”

    – there are no options on the config page

    #51063
    Profile photo of shywolf28
    shywolf28

    To find it go to /opt/retropie/con figs/all…that’s where u want to edit

    #51223

    lewis

    i found the folders I was looking for in the opt directory (thanks!) but the changes I make to the retroarch.cfg files seem to have random effects. sometimes the buttons will change after i’ve edited them for a specific emulator and other times they won’t. for example i have a few games that when i press the attack button, it’s also the pause button and i can’t seem to change this..any ideas?

    #52207

    Dennis

    Would it help to create an alias to these files in /opt/retropie/configs/all? I experienced a lot of alias files stored in etc/ pointing at files in the “opt” directory. Or what if I put the whole retropie/configs/all branch into home/pi/RetroPie/? I don’t want to crash the system, that’s why I am asking before trying out

    #52273
    Profile photo of shywolf28
    shywolf28

    lewis..if you change the input for a specific emulator make sure its put in the /opt/retropie/configs/(your emulator)..otherwise the default retroarch.cfg will take over your edited inputs..if that makes sense

    Dennis if you put an alias, wont crash your system

    #52331

    tony

    can these be edited in desktop mode im having trouble trying to get my configs all sorted using 2.3

    #52345
    Profile photo of shywolf28
    shywolf28

    Yes

    #52346

    tony

    thanks ill have to look into it its really confusing its a shame there isnt a image with all the configs already setup for controllers

    #52961

    Dennis

    I will also try to define them in the opt directory before but the problem is that I don’t know the keys of my SNES controller. Thus I can’t define them in retroarch.cfg and as they’re not temporarily saved I have no clue how to find out… any ideas?

    #53082

    Dennis

    Aight, got it finally working by editing the retroarch.cfg inside /opt/retropie/configs/snes/ adding these values found here

    input_player1_joypad_index = 0
    input_player1_b_btn = 2
    input_player1_a_btn = 1
    input_player1_y_btn = 3
    input_player1_x_btn = 0
    input_player1_l_btn = 4
    input_player1_r_btn = 5
    input_player1_start_btn = 9
    input_player1_select_btn = 8
    input_player1_l_y_plus = -1
    input_player1_up_axis = -1
    input_player1_l_y_minus = +1
    input_player1_down_axis = +1
    input_player1_l_x_minus = -0
    input_player1_left_axis = -0
    input_player1_l_x_plus = +0
    input_player1_right_axis = +0
    #83289
    Profile photo of kagiac
    kagiac
    Participant

    I’m using the newest version of Retro-Pie and can’t even find a retroarch.cfg file. There’s only one cfg – file called retronetplay.cfg in the Retro-Pie-Setup/configs folder.

    I’m trying to help several kids set this up and none of our game pads work with the games. Can someone direct me to the retrarch.cfg file?

    Thanks!
    Karen G

    #83305
    Profile photo of Floob
    Floob
    Member

    You can find the retroarch.cfg files in
    /opt/retropie/configs

    This may also help

    Please note the comment on that video about the directory – as the video is slightly out of date.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #84022
    Profile photo of gdice
    gdice
    Participant

    Great tutorial floob, however, I run into a similar issue that the video does not address. When I run my RetroArch auto configuration from the GUI, the USBxxxx config file never saves or populates. Any suggestions? I am using version 2.3 btw.

    #84033
    Profile photo of Floob
    Floob
    Member

    This thread may help.

    Error with RetroPie Setup scripts

    If not, please post the steps you take and the error you get.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #92925
    Profile photo of rhino224
    rhino224
    Participant

    Wanted to say thanks! did exactly what dennis said and now my game is working perfectly!

Viewing 17 posts - 1 through 17 (of 17 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar