Fresh install 3.2.1 – No input works during games

Home Forums RetroPie Project Controller Configuration in RetroPie Fresh install 3.2.1 – No input works during games

This topic contains 31 replies, has 5 voices, and was last updated by Profile photo of nschloe nschloe 1 year, 6 months ago.

Viewing 32 posts - 1 through 32 (of 32 total)
  • Author
    Posts
  • #110277
    Profile photo of ericahlers
    ericahlers
    Participant

    Hey all,
    I just did a fresh install of 3.2.1. Got Emulation station up and running…recognizing my gamepads (F310s) without issue. The second I run a game or attempt to get in the RetroArch setup…no input works at all. It doesnt recognize the gamepads or the keyboard. I’ve never had this happen and not sure how to fix it. I end up having to power down to even reset the Pi.

    Everything else went smooth without issue.

    Any ideas?

    #110280
    Profile photo of herbfargus
    herbfargus
    Member

    I have had similar issues but it seems to be a lag rather than no input with that same controller if you wait a while it should work. It may be a retroarch issue but I’m not entirely sure. It is specific to the Logitech f310 though as I haven’t had the same issue with my snes controller

    #110282
    Profile photo of ericahlers
    ericahlers
    Participant

    There’s no lag. Nothing works. Even if I load up the “Configure Retroarch” from the Retropie menu in ES…I’m immediately unable to do anything. If a run a game…the game continues to emulate without issue…I just can’t play it, or even try to escape, exit, or Ctrl+Alt+Delete

    I hadn’t messed with my RetroPie setup since 2.6…so I’m suprised I ran into the issue given how much more cleanly and user-friendly the initial setup was.

    #110284
    Profile photo of herbfargus
    herbfargus
    Member

    That’s super weird, but I can confirm the same issue. Perhaps you should open up a ticket on github for it.

    #110304
    Profile photo of ericahlers
    ericahlers
    Participant

    Thanks for the reply. I’ll spend more time trying to trouble shoot to figure out whats going on.

    #110487
    Profile photo of mikebrew
    mikebrew
    Participant

    Please share any discoveries you make. I’m experiencing the same problem with a pair of Logitech F710 controllers on 3.2.1.

    #110523
    Profile photo of ericahlers
    ericahlers
    Participant

    So…I discovered a few things, but still no solutions:
    1. Emulation station detects 3 gamepads – when I only have 1 F310 plugged in and 1 USB keyboard
    2. I once got the emulator to work by unplugging and replugging in the f310 after the emulator had started. When doing so, the yellow text at the bottom were read “F310 successfully connected” but would also say something about “Xbox controller 0/2 not configured”
    3. Switching the F310 controller to Dinput mode appears to render the controller completely useless, as least per my experience.

    All very strange, given how I bought the f310s originally because of how flawlessly they worked with Retropie.

    #110572
    Profile photo of mikebrew
    mikebrew
    Participant

    So for my setup, I’m using a rpi2 with 3.2.1 installed using a Wi-Pi, Logitech K400r wireless keyboard and two Logitech F710 wireless gamepads. ES on startup recognizes both gamepads and after the joypad setup all buttons/axis are known. ES can be manipulated with both pads no problem. Select a Nintendo game rom and the first message on screen says something to the effect of “Press a key (or joypad button 0) to configure launch options for emulator/port (lr-fceum). Errors will be logged to /tmp/runcommand.log”. Very quickly thereafter, the emulator starts and I see in yellow at the bottom of the screen “Logitech F710 Gamepad configured in port #0” and “Logitech F710 Gamepad configured in port #1”. After the rom is launched there is absolutely no response from the keyboard or the gamepads. I have to power down rpi2 to restart everything.

    It is clear that ES and the emulator are recognizing that the pads are installed but they don’t get configured to play. jstest gets responses from all buttons and axis controls. Interesting that when I select DosBox the keyboard is recognized and works. The DosBox emulator also reports the following “Two or more joysticks reported, initializing with 2axis. Using joystick Logitech Gamepad F710 with 7 axis, 11 buttons and 1 hat(s).” The second line is repeated for the other gamepad. I don’t see this when the game emulators are started.

    Poking around in /opt/retropie/configs/all/retroarch.cfg I see “input_autodetect_enabled = true” and “joypad_autoconfig_dir = /opt/retorpie/configs/all/retroarch-joypads”. The directory does contain a mapping for the F710 controller but I don’t know where it came from. Looking further at retroarch.cfg I see “# input_libretro_device_p1 = ” for up to 8 players. When I uncomment two of those lines and set the value to 1, save and restart, I can launch and the pad works but not as I expect it to. Maybe I need to use a value of 5 because these pads have analog capability as well. I’ll try that tonight. I also found that there is no way to escape out of the emulator once it is launched. Back to the power cord for a reboot.

    In the process of playing with this thing I also discovered that the “more” command is broke. It only displays one page then dumps you out to the commoand line. Good thing that “less” is also installed and works properly. I also found the at the game scraper has a serious problem when selecting “thearchive”. It takes several minutes between key/btn presses before it will accept another input. Default keyboard is set to “gb”, not “us” so piping Linux commands is impossible and some special keys are swapped on the keyboard. I’m sure there are more bugs yet to be discovered.

    #110576
    Profile photo of ericahlers
    ericahlers
    Participant

    The config file for the controller is auto-generated by ES now after you set it up.
    This issue seems to be a very prominent and reproducible issue. Anyway to make it an official ticket? I didn’t seem able to report it on the github site for some reason

    #110578
    Profile photo of ericahlers
    ericahlers
    Participant

    FOUND A SOLUTION!!! — Not quite…see below

    So, I modified the cfg file for the F310 and changed the following:

    input_driver = “udev” –> input_driver = “sdl”

    By doing that, the gamepads are currently working fine and appropriately, with the configuration set by ES. Able to exit the game using the Start+Select and everything as well.
    It appears by activating gamepads as udev, the emulator was tricked into thinking they were a keyboard, but also interfering with the default keyboard (by default, a “udev” device -> rendering all input methods useless).

    I will continue further testing to verify that this did indeed fix the issue. I have not tested all the retroarch emulators and multiple controllers yet. But I was excited enough that I decided the need to post my results immediately.

    #110581
    Profile photo of petrockblog
    petrockblog
    Keymaster

    There are some other issues solved by switching the driver too for other gamepads which seem to map differently when using udev – see https://github.com/RetroPie/RetroPie-Setup/issues/1077

    We may be switching to sdl2 for the input – but it requires some more testing.

    #110582
    Profile photo of petrockblog
    petrockblog
    Keymaster

    I would be interested in the results of config changes with changing just “input_joypad_driver = sdl2” in the main configs/all/retroarch.cfg also

    #110583
    Profile photo of petrockblog
    petrockblog
    Keymaster

    (and using sdl2 rather than sdl in the joypad configuration file).

    #110585
    Profile photo of ericahlers
    ericahlers
    Participant

    Well it looks like I need to keep exploring.
    By switching to “sdl” from “udev”, I got the following systems to work:
    Genesis/Masterdrive, NES, SNES, N64, FBA.
    However, PSX and Mame (both using libretro/retroarch cores) don’t recognize the gamepad at all. Very strange to me..given if retroarch recognizes the gamepad in any system, i would assume it to work for all.

    #110589
    Profile photo of ericahlers
    ericahlers
    Participant

    So SDL2 still to be working equivalently to SDL. Still no luck in MAME, although I did have intermittent luck with PSX.

    Side question – is there anyway to calibrate/zero in the triggers/axes for a given controller? I have 4 different F310s, and never had any issues with them. Since updating to 3.2.1, I notice the right back trigger appears to be touchy. First noticed in ES when setting it up (making it “skip” for alot of people – see this thread: http://blog.petrockblock.com/forums/topic/logitech-f310-controller-cant-assign-control-to-top-right-trigger/#post-104784).
    I also notice that in ES, it will want to constantly “page down”..a setting contributed to the back right trigger.
    I ask this because I noticed in PSX…the controls seem to work ONLY when I am holding down the back right button. It makes me wonder if that is jacking up the controls, which explains why it doesn’t work for systems that would potentially use that button (Mame, PSX).

    Like I said, never had any issues in 2.6. I doubt all 4 of my F310s suddnely all broke in the exact same way 4 times over. Very very strange. Hoping we can find a solution.

    #110590
    Profile photo of petrockblog
    petrockblog
    Keymaster

    the driver name should be sdl2 not sdl for our retroarch I think – not sure if it allows sdl too or just defaults to another setting. Need to check the sourcecode to find out.

    Please can you try my suggestions above as it would be useful for retropie development.

    #110591
    Profile photo of ericahlers
    ericahlers
    Participant

    Looks like we posted at the same time. But Buzz, I did make the changes you suggested (switching over to sdl2), and noticed no change from when it was configured to sdl.

    #110596
    Profile photo of petrockblog
    petrockblog
    Keymaster

    thanks.

    Can’t advise on calibration I’m afraid.

    I am after a little more detail if you can please with the settings:

    EG for each of these

    
    a) configs/all/retroarch.cfg - input_joypad_driver = sdl2
       configs/all/retroarch-joypads/yourjoypad.cfg - input_driver = udev
    
    b) configs/all/retroarch.cfg - input_joypad_driver = udev
       configs/all/retroarch-joypads/yourjoypad.cfg - input_driver = sdl2
    
    c) configs/all/retroarch.cfg - input_joypad_driver = sdl2
       configs/all/retroarch-joypads/yourjoypad.cfg - input_driver = sdl2
    

    also if you have any other controllers I would be interested if this affects them with hotplugging etc.

    #110600
    Profile photo of ericahlers
    ericahlers
    Participant

    I’ll gladly help out with what you asked. But what do you mean by “EG for each?” Thats not an acronym I’m familiar with.

    I do have wireless 360 controllers, but I’ve never set those up as I bought the F310s for dedicates retropie use. I’ll try to get around to testing those out as well.

    #110604
    Profile photo of ericahlers
    ericahlers
    Participant

    So I’m convinced it has to do with the the back right button. I tried a total of 6 F310s, including 2 brand new ones. Same result every time.

    So i wanted to go back to the original setup, so I restored my config files back to their original setup (so F310 .cfg file set to “udev”.

    In all the systems that are working…none of the controls work until the back right trigger is pressed. The easiest way I’ve been testing this is to load up the emulator and attempt to exit via the hotkey (button 8), as I know this isn’t a game specific key. It does absolutely nothing initially. However, after I press the back trigger key once. The controls and hotkeys all work fine.

    #110605
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Just those examples above – I would like to know how it affects your set up as described in a / b and c scenarios.

    so for a)
    edit configs/all/retroarch.cfg – change: input_joypad_driver = sdl2
    edit configs/all/retroarch-joypads/yourjoypad.cfg – change: input_driver = udev

    then test 1 / 2 joypads connected and hotplugging them.

    and then do the same for b etc. It will help me to decide what defaults to choose for the next release to work around some issues (including yours).

    #110606
    Profile photo of ericahlers
    ericahlers
    Participant

    So The wireless xbox 360 controls work fantastically out of the box (userspace driver). No issues with the setup (excpet MAME still doesnt recognize any inputs). I did notice that on ES, it recognizes the back triggers on the 360 controller as buttons and not axes, which I find interesting since the F310s are run on xinput and should appear identical to the 360 controller.

    #110609
    Profile photo of ericahlers
    ericahlers
    Participant

    Buzz,
    I ran through each of those scenarios. They all functioned identically. No discernible difference between the two.

    I realized my MAME emulator had switched off of a libretro core. Once I fixed that, the controls worked fine with the Xbox 360 controller.

    I continue to have the same reproducible issues with the F310s. The controls do not work at all UNTIL the back right trigger is pressed.

    My LogitechGamepadF310.cfg files reads as such:
    input_device = “Logitech Gamepad F310”
    input_driver = “udev”
    input_r_y_plus_axis = “+4”
    input_l3_btn = “9”
    input_r_x_minus_axis = “-3”
    input_r_axis = “-5”
    input_save_state_axis = “-5”
    input_l2_btn = “4”
    input_start_btn = “7”
    input_exit_emulator_btn = “8”
    input_l_y_minus_axis = “-1”
    input_l_axis = “+2”
    input_load_state_axis = “+2”
    input_up_btn = “h0up”
    input_r_y_minus_axis = “-4”
    input_a_btn = “0”
    input_b_btn = “1”
    input_reset_btn = “1”
    input_down_btn = “h0down”
    input_r2_btn = “5”
    input_l_x_plus_axis = “+0”
    input_l_y_plus_axis = “+1”
    input_r3_btn = “10”
    input_right_btn = “h0right”
    input_state_slot_increase_btn = “h0right”
    input_x_btn = “2”
    input_menu_toggle_btn = “2”
    input_select_btn = “6”
    input_enable_hotkey_btn = “8”
    input_l_x_minus_axis = “-0”
    input_y_btn = “3”
    input_left_btn = “h0left”
    input_state_slot_decrease_btn = “h0left”
    input_r_x_plus_axis = “+3”

    For reference, on jstest, that back right trigger is axis 5 and default value is “-32767”. When fully pressed, it is “32767.”
    To me, this seems like a driver error with the F310. And it didnt happen with 2.6 and prior, so something changed.

    #110610
    Profile photo of herbfargus
    herbfargus
    Member

    That would be consistent with the weird workaround where the back right trigger (or top right) bugs out the first time on emulationstation input. It’s likely due to that same issue.

    #110615
    Profile photo of petrockblog
    petrockblog
    Keymaster

    please can you clarify – there were 3 scenarios, one being the original set up which didn’t work before, so not sure which ones you are referring to 🙂

    #110616
    Profile photo of petrockblog
    petrockblog
    Keymaster

    aha. so it’s all related to the trigger ? changing the driver had no effect at all (so it does work left as udev in both configs ?)

    Could be how the kernel is treating the values – but often it’s also related to buggy firmware in controllers etc. you could try downgrading the kernel with rpi-update to see if that makes a difference.

    #110617
    Profile photo of ericahlers
    ericahlers
    Participant

    Buzz, All 3 scenarios are the same. With the initial setup that didn’t work, I didn’t thoroughly examine the possibility of the back right trigger affecting the usability of the gamepads. When I reverted back to my original setup (or tried any of the other scenarios you proposed), they all had the identical result – after pressing the back right button, the gamepads would work without issue.

    Herbfargus – do we have a fix/work around for that yet?

    #110629
    Profile photo of ericahlers
    ericahlers
    Participant

    I have no issue trying to downgrade to prior firmware. The issue is I have no point of reference of where to start when choosing a firmware to revert to. How far back or to which firmware do you recommend? I’m not that much of a superuser to confidently start using older/custom firmwares without knowing what to expect and what may be affected by reverting back.

    #110651
    Profile photo of herbfargus
    herbfargus
    Member

    If it is a firmware issue then reverting to older firmware is currently the only solution. I’ll test it some when I’ve got some time to verify your results and see which firmware it breaks at.

    #111950
    Profile photo of ericahlers
    ericahlers
    Participant

    Just curious if any progress has been made for this? I was hoping to have a functional build to give a Christmas. Looks like I may have to revert back to 2.6 since that worked, but obviously isn’t a clean at Retropie 3.

    #111951
    Profile photo of herbfargus
    herbfargus
    Member

    I couldn’t get consistent results enough to test properly. as soon as I tried to test it worked fine, so I don’t know what the deal was with it. but needing to tap a button before it starts or skipping the button altogether is hardly an issue for me, but if it’s firmware or retroarch related I’m not sure how much retropie can really do about it.

    #112451
    Profile photo of nschloe
    nschloe
    Participant

    I have the exact same issue with my F310 on Jessie 3.3 (beta), although the “top right button” fix doesn’t work for me.

Viewing 32 posts - 1 through 32 (of 32 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar