Failed to save state (roms on USB)

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Failed to save state (roms on USB)

This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of captainw captainw 2 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #28724
    Profile photo of reaver63
    reaver63
    Participant

    Hello! i’m using a 16gb USB drive to load roms without copying them on the sd card.
    But when i’m playing on EmulationStation, i can’t save state.
    It says “Failed to save state to “/media/usb/Snes” or something like that.

    So i searched everywhere, and found a solution: use gparted to format the USB drive in EXT4.
    I did it, and it didn’t worked.

    Does somebody can help me?

    #28761

    Quantico

    This happened to me, and the problem was insufficient space on SD.

    See if the USB or SD card has sufficient space.

    #28779
    Profile photo of reaver63
    reaver63
    Participant

    Okay, i fixed it with the sudo chmod 777 * to set the permissions ! Solved! ^^

    #91287
    Profile photo of captainw
    captainw
    Participant

    Hi,

    I’m facing the same problem, I run my roms from my usb dongle (which has plenty of free space (~31Go free)).

    I tried to use the chmod command : sudo chmod 777 /media/usb0 but it still doesn’t work… Any idea?

    Thanks

    #91288
    Profile photo of petrockblog
    petrockblog
    Keymaster

    probably because the folder below it are not writeable.

    if using fat32 – you should make sure it is writeable to the user you will be using. this can be done with mount options.

    if mounting via fstab
    http://serverfault.com/questions/43634/how-to-mount-external-vfat-drive-as-user

    if using usbmount
    http://unix.stackexchange.com/a/39941

    #92208
    Profile photo of captainw
    captainw
    Participant

    Hi thanks a lot for your answer (sorry to answer so late I thought I’de receive a mail as notification of answer…guess I forgot to tick the notification box…)

    I’m must admit I’m quite a noob with programmation.

    I found somewhere that I’d have to allow writing on the Usb drive using :

    sudo chown -R pi:pi /media/usb/

    Then I’d be able to do the chmod trick :

    sudo chmod 777 /media/usb0

    Does this seems correct to you?

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar