Experimental mGba

This topic contains 10 replies, has 4 voices, and was last updated by Profile photo of momaw27 momaw27 2 years ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #99898
    Profile photo of Omnija
    Omnija
    Participant

    I’ve been using mGba since i found it had better performance and compatibility with my games. Yesterday i noticed it had been updated so i recompiled it and now the games won’t launch.

    RunCommand Log

    RetroArch [ERROR] :: dylib_load :: dylib_load() failed: "/opt/retropie/libretrocores/lr-mgba/mgba_libretro.so: undefined symbol: binaryName".
    RetroArch [ERROR] :: load_symbols :: Failed to open dynamic library: "/opt/retropie/libretrocores/lr-mgba/mgba_libretro.so"
    RetroArch [ERROR] :: rarch_main_init :: Fatal error received in: "load_dynamic()"

    #99901
    Profile photo of petrockblog
    petrockblog
    Keymaster

    and if you install it from binary rather than source does it work ? if a change in it has broken you will need to report it back to the libretro project page on github.

    #99902
    Profile photo of Omnija
    Omnija
    Participant

    I don’t think there’s an option to install it from binary, due to it being an experimental install.

    edit: can’t seem to figure out how to report bugs/issues

    #99936
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Ahh yeh sorry – there wont be – and of course some things are in experimental for a reason. I forgot it was. I will have a look at this when I next get a moment – feel free to open a ticket on retropie github, but basically if it did work, and now it doesn’t its likely an upstream bug :/

    #99938
    Profile photo of Omnija
    Omnija
    Participant

    Will do thanks.

    #99990
    Profile photo of Omnija
    Omnija
    Participant

    Here’s a copy of the old binary incase anyone wanted it. Retrieved it from a backup image i had.

    Attachments:
    1. lr-mgba.zip
    #100020
    Profile photo of momaw27
    momaw27
    Participant

    Hey Omnija!

    Ran into the same issue. How would I go about installing the older binary in my 3.0B3 image?

    momaw27

    #100023
    Profile photo of Omnija
    Omnija
    Participant

    I uploaded it above, all you have to do is download/unzip and replace it in the opt/retropie/libretrocores/lr-mgba.

    #100024
    Profile photo of momaw27
    momaw27
    Participant

    Brilliant! Thank you!

    #100219
    Profile photo of blockaboots
    blockaboots
    Participant

    Yeah having the same issue with the latest version not working, also vgba-next also doesn’t appear to work when you download the binary

    #100271
    Profile photo of momaw27
    momaw27
    Participant

    Darn. Replacing the .so didn’t fix it.

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar