Exiting Sega Master System Emulator (Osmose) from controller

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Exiting Sega Master System Emulator (Osmose) from controller

This topic contains 12 replies, has 4 voices, and was last updated by  Quantico 3 years, 5 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #5904


    I don’t believe Osmose uses the retroarch configuration file. Anyone know of a way to bind a joystick (xbox 360 controller) input to the “exit emulator” command (similar to how retroarch is able to exit an emulator from a controller input).

    Also, if it’s not possible, is it possible to use a different different emulator for the Master System that does use retroarch configurations?

    Thanks. 🙂



    Use pico drive

    Sent from my iPhone using Tapatalk



    There isn’t a commented-out command to use picodrive for Master System games.

    Anyone happen to know the emulationstation command?




    if you edit your es_systems.cfg (nano /home/pi/.emulationstation/es_systems.cfg) and scroll down to the Megadrive section you will see the supported rom filetypes. Try adding .sms and .SMS to that line (roms need to be in the Megadrive folder) and Emulation Station should pick them up on reboot.

    I’m assuming Picodrive is installed on your setup by the way, it should be the default emulator in es_systems, if not you can install it via the setup script.

    If you have found the solution to your problem please mark the topic as resolved.



    What’s the Retroarch command to use PicoDrive as the Genesis/MegaDrive emulator? Unfortunately, the only opetion available os Osmose.

    Example: COMMAND=/home/pi/RetroPie/emulators/osmose-0.8.1+rpi20121122/osmose %ROM% -joy -tv -fs



    Have you installed Picodrive AND updated the RetroPie config (one of the last options in the sources installation menu) using the script? Once you do that, you should be able to switch to the alternative command.
    I do not know if once you installed a new emulator you can still perform the configuration alone to fix it. If you just installed Picodrive but did not update the config, you can add the alternative command by yourself (look for the line somewhere around the forum) or reinstall it along with the update option.
    Hope this helps!

    BTW, I am using Picodrive only for SMS, I did not find it much better than DGen for Megadrive. I would prefer to use Osmose for SMS (some ROMs are not working with Picodrive), but I am staying with PicoDrive because of the exit button…
    Can someone give his/her opinion on this? Is really Picodrive better than Osmose and DGen? Why won’t some ROMs run in Picodrive?

    To defeat them is a must and bringing peace to the land is my duty



    can you post the contents of your es_systems.cfg

    If you have found the solution to your problem please mark the topic as resolved.



    I for one Do Not believe Picodrive Is really better Osmose especially when it comes to master system emulation.!
    It is slow block like graphics and colors are completely wrong let alone the sound.
    As For Sega CD / 32x Emulation It seems that’s its Place to be.

    I did manage to hot Osmose in the past so I will Burn IMG to SDcard and see what I did to achieve this.
    And Replicate it on the latest Dash will report back ASAP on success/Failure
    and how to guide.



    Hi got Sega Master System working and to exit with correct colors & sound
    What I did was copy Genesis Plus GX core to my RPI.
    and edited es_systems.cfg
    Sega Master System to point to Genesis Plus GX.so (core)
    now everything works the way it is supposed to.
    To edit es_systems.cfg
    (in Linux Wheezy Raspian)
    start Other Xterminal as root
    cd /etc/emulationstation
    sudo nano es_systems.cfg
    Press Ctrl + W
    type sms
    replace original.so with genesis_plus_gx_liberetto.so
    (make sure it points to correct location
    Hope it works for You
    HAVE FUN !!!!
    You may need to do same for your controller config at end of file
    (*)Just copy configs to where they can become Read and Write Not just Read.

    Problem Sorted.



    Edit /opt/retropie/configs/all/retropie.cfg

    I can exit from Osmose with SELECT+START, after adding these lines in retropie.cfg

    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”



    Quantico Wrote

    “Edit /opt/retropie/configs/all/retropie.cfg

    I can exit from Osmose with SELECT+START, after adding these lines in retropie.cfg

    input_enable_hotkey_btn = “8″
    input_exit_emulator_btn = “9″

    this works fine for RetroPie V2.1 But seems to have issues in RetroPie V2.2 +
    Which is why I use
    genesis_plus_gx_liberetto.so Core.
    And after doing this I have to admit Superior Graphics,Sound,Speed and Responsiveness over Osmoses.



    PS you forgot the sudo nano command



    Is true, now i see, my es_systems is setting to run Picodrive and not Osmose.

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss