Exit Emulator with 2 Players

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Exit Emulator with 2 Players

This topic contains 1 reply, has 2 voices, and was last updated by  herbfargus 2 years, 4 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #101777

    mheyman
    Participant

    Hello!

    So here’s my setup, I’m using a keyboard for player one and a joypad for player 2. I forced the joypad as player to in the retroarch.cfg file in the /configs/all folder.

    So here’s my issue. When there is no second player plugged in, the escape key exits the emulator. When I do plug in a joypad (which always seems to default to index 0) the first player keyboard can no longer use escape to exit the emulator.

    Any ideas how to fix this?

    #101805

    herbfargus
    Member

    Its by design with retroarch- anytime a joypad is plugged in it overrides the nulbinding of the keyboard, basically you don’t need a hotkey to exit with a keyboard so it doesn’t expect one but with a joypad often you use the hotkey to exit for gameplay (it would be kind of annoying to press start and have it exit instead of starting the game) if you have a joypad plugged in along with your keyboard you can press select on the joypad and ESC on the keyboard to exit. Or you can change the hotkey settings in the setup script to choose alt- then you’ll press alt+ESC to exit.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/