Exit emulator from joystick

This topic contains 6 replies, has 2 voices, and was last updated by  Francesco 2 years, 11 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #11817

    Francesco

    i’m trying to set exit emulators from joystick instead press esc on keyboard but i can’t do that.
    i add on /opt/retropie/configs/all/retroarch.cfg this two lines:

     input_enable_hotkey_btn = "11"
    input_exit_emulator_btn = "8"
    

    but it doesnt work.. (11 and 8 are select and start on my joystick, i also try with another combo but it doesnt work)

    i also try these:

    input_player1_enable_hotkey_btn = "11"
    input_player1_exit_emulator_btn = "8"
    

    but nothing…how can i do that?

    #11818
    Profile photo of Mutex
    Mutex
    Participant

    What emulator (for which system) are you trying to quit?

    #11820

    Francesco

    snes and pifba

    #11829

    Francesco

    sorry for mame4all and snes not pifba (select+start works for pifba)

    #11831
    Profile photo of kitchuk
    kitchuk
    Participant

    Mame4all: Press the TAB button on your keyboard and then go to overall input options. You should see a entry for UI Cancel. Press enter on your keyboard, then press the two buttons together at the same time.

    Snes should be:

    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “11”

    #11834

    Francesco

    ok now it works fine thanks a lot!

    #11836

    Francesco

    only problem now it’s that every time i exited from an emulator, i’ve to plug oout and plug in joystick because keymap of joystick is changed so for example dpad down is A button…how can i fix that?

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar