Exit-able emulators

This topic contains 12 replies, has 4 voices, and was last updated by  dudleydes 3 years ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #84785

    proxycell
    Participant

    Other than FBA, GBA and the libretro set, are there any other exit-able emulators?

    thanks

    #84841

    dudleydes
    Participant

    By exit-able, I assume you mean that the emulator exits successfully back to emulationstation. If so, then you can include mame4all-pi.

    #84842

    petrockblog
    Keymaster

    They should all be exitable?

    #84843

    petrockblog
    Keymaster

    if not – let me know which and what happens and I’ll try and help.

    #84848

    downup
    Participant

    On my Xbox360 controller can i exit the emulator with Select + Start and the (xbox-button) brings up the menu to save/load and other stuff.

    Really good, got an xbox controller?

    #84849

    dudleydes
    Participant

    Thanks, Buzz. I compiled a new version of the Intellivision, jzintv, which fixed a bug that was breaking keyboard hacks. The SVN source is available at the following link: http://spatula-city.org/~im14u2c/intv/dl/jzintv-svn-20141028.zip.

    On exit from jzintv, I get a black screen and the pi is completely unresponsive. I can SSH into the pi but sudo reboot doesn’t work. The only way to reset the pi is through a power cycle. There is a long-running issue at the ES github (../EmulationStation/issues/206) that suggests that it’s affecting other non-Retroarch emulators such as VICE.

    There is a fix at this post – ../emulationstation-not-restarting-on-emulator-exit/#post-81307. I tried to write a script that would replicate this but I can’t seem to get the exit command in step 2 working as it’s an inbuilt command. Also, I’m not entirely sure why typing exit should relaunch ES.

    I also followed this thread ../atari-2600-stella-locks-up-after-exit/ which described a similar situation to mine. I have tried to enable dispmanx for jzintv. I installed dispmanx from the (updated) Retropie setup script and then enabled it for jzintv, also from the setup script. I am still getting a black screen on exit. Now I’m not sure whether dispmanx doesn’t solve the issue for jzintv or whether dispmanx wasn’t enabled as I had compiled jzintv from an alternative source to the Retropie script.

    Any advice would be appreciated.

    #84850

    petrockblog
    Keymaster

    did you do

    
    sudo ./retropie_packages.sh jzintv configure
    

    (or run the main install binaries script again which will run configure for everything). the dispmanx configuration requires that the es_system.cfg is updated with latest configuration from the jzintv retropie module.

    #84851

    petrockblog
    Keymaster

    thanks for the updated source.

    #84853

    dudleydes
    Participant

    I have found out why dispmanx wasn’t enabled. It was because I hadn’t updated the runcommand script since June 2014. In any case, I ran
    sudo ./retropie_packages.sh jzintv configure
    as it provided the command to make sure dispmanx was enabled for jzintv.

    Now a rom will not launch. I get the following output in the console:

    ERROR: MAC Dispmanx - the program is calling SDL_ListModes. That shouldn't happen.
    gfx/SDL Error:
    Powering on HDMI with preferred setting

    before returning to ES.

    Incidentally, I could only get audio for the new build of jzintv by adding a -a22050 flag.

    #84854

    petrockblog
    Keymaster

    oh yeh. that needs updating too – I thought I had mentioned that in the other thread.

    that sdl error isn’t fatal afaik, i think stuff usually runs anyway, but i’d have to check.

    I don’t have any time right now to look into this, but when i update jzintv I will check it’s working etc and fix up any issues I find.

    #84856

    dudleydes
    Participant

    Ok, thanks. If there’s any testing on jzintv you’d like to be done, then please let me know and I’d be happy to do so.

    #84857

    proxycell
    Participant

    ahhh, i meant via a controller by default (excluding the libretro stuff). if mame4all-pi can do it i will include it. which key combo does it?

    #84860

    dudleydes
    Participant

    You can assign a key to exit mame4all-pi by pressing TAB in-game. I don’t think there’s a default.

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss