ESC key not working to exit game back to emulationstation

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project ESC key not working to exit game back to emulationstation

This topic contains 8 replies, has 5 voices, and was last updated by Profile photo of rubberfish613 rubberfish613 2 years, 3 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #91474
    Profile photo of hazza4569
    hazza4569
    Participant

    Apologies in advance, as this is probably a very basic issue and I am very new to all of this and not very capable at all.

    When I’m in a game, playing with a wired xbox 360 controller, I am unable to exit the game using the ESC key on the keyboard. The keyboard still works – I can use it to play the game instead of the controller, just I have no way of exiting the game short of pulling out the power cord.

    Why isn’t this working? And how do I fix it?

    Also I know there are lots of forums on it already from searching to answers to my first question, but could somebody maybe explain to me in very simple steps how to map the escape key to a controller key to exit the game?

    Thanks for any and all help.

    #91510
    Profile photo of herbfargus
    herbfargus
    Member

    I am having the same issue, I’ve tested it a bit and it seems to be a problem with all of the libretro cores. The non libretro emulators seem to work fine to use escape to exit. Is it the same thing for you?

    #91517
    Profile photo of gizmo98
    gizmo98
    Participant

    Try:

    cd RetroPie-Setup
    sudo ./retropie_packages.sh hotkeys

    Option 3 should do the trick. RGUI opens if you press ESC. Select “Quit Retroarch” to close Retroarch.

    Be aware if you plug in a controller with configured hotkeys it is necessary to press the input_enable_hotkey_btn (select) to enable keyboard hotkeys like exit (ESC) or RGUI (F1). Retroarch makes no difference between keyboard keys and joypad buttons.

    #91528
    Profile photo of herbfargus
    herbfargus
    Member

    Thanks for the quick response, it worked fine for me.

    What about the nul bind though? as far as I understood it the nul value means you don’t have to press a key to enable the hotkey rather you can just press one key to process your function- does that no longer work?

    for example

    input_enable_hotkey = nul
    input_exit_emulator = escape
    #91743
    Profile photo of hazza4569
    hazza4569
    Participant

    Try:

    cd RetroPie-Setup
    sudo ./retropie_packages.sh hotkeys

    Option 3 should do the trick. RGUI opens if you press ESC. Select “Quit Retroarch” to close Retroarch.

    Be aware if you plug in a controller with configured hotkeys it is necessary to press the input_enable_hotkey_btn (select) to enable keyboard hotkeys like exit (ESC) or RGUI (F1). Retroarch makes no difference between keyboard keys and joypad buttons.

    Thank you for the reply. When I enter that second command, it errors and says “No module ‘hotkeys’ found for platform rpi1”

    Any idea on what to do? Sorry I’m so useless.

    #91748
    Profile photo of davejaca
    davejaca
    Participant

    This is not a solution, but if you do get stuck in an emulator also try pressing Control+c. When escape didn’t work for me this usually did.

    #91971
    Profile photo of rubberfish613
    rubberfish613
    Participant

    I am getting the EXACT same issue. It originally WAS working, until I updated the retropi-config script. Since doing so NO keyboard input works in game (e.g. Space for fast forward, f2/f4 for save states, etc.) and thus, I need to use CTRL+C to exit.. since this is not a clean exit, it won’t automatically save.. and since I can’t use save states, I essentially can’t save any progress.. Please, someone help D:
    Bump!

    Edit: hazza4569: I tried your solution, and i found that everything except the exit function were set, which would be fine, as I could exit thru that menu, unfourtunately NONE of the keys work in game :/

    #91978
    Profile photo of herbfargus
    herbfargus
    Member

    I followed Gizmo’s solution but I selected to use ALT- so I just hold down alt and press escape and it exits fine. I’m still stumped as to why the nul bind no longer works though like it used to.

    #92036
    Profile photo of rubberfish613
    rubberfish613
    Participant

    My hotkeys won’t work with any of the options.. only the RGUI if option 3 is selected.. where fastforward isn’t even an option..

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar