Error wiith OpenMSX in RetroPie (image) 2.3: machines/C-BIOS_MSX2.xml not found

Home Forums RetroPie Project Everything else related to the RetroPie Project Error wiith OpenMSX in RetroPie (image) 2.3: machines/C-BIOS_MSX2.xml not found

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of arcadoff arcadoff 2 years, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #51439
    Profile photo of msxer
    msxer
    Participant

    I just started using the RetroPie image v2.3 and managed to get some emulators running by uploading some game ROMs to the Samba share ROMS.

    However, when trying to start the included OpenMSX emulator from Emulation Station, I get the following error:

    Failed to initialize default machine: Error in “C-BIOS_MSX2+” machine: machines/C-BIOS_MSX2+.xml not found in this context.

    How can I solve this problem? I did download the cbios-0.25 bios files but it’s not exactly clear where to put these files.

    Did anyone get OpenMSX to work?

    #56680
    Profile photo of msxer
    msxer
    Participant

    Fixed the issue myself by installing the OpenMSX 0.10.0 build from http://misapuntesde.com/post.php?id=382

    Now OpenMSX is installed in /opt/openMSX (including the /machines subfolder) and works without any problems. After that I only had to update the /etc/emulationstation/es_systems.cfg to point to the new location of the OpenMSX binary:

    <system>
       <fullname>MSX</fullname>
       <name>msx</name>
       <path>~/RetroPie/roms/msx</path>
       <extension>.rom .ROM</extension>
       <command>/opt/retropie/supplementary/runcommand/runcommand.sh 3 "/opt/openMSX/bin/openmsx %ROM%"</command>
       <platform>msx</platform>
       <theme>msx</theme>
    </system>
    #83546
    Profile photo of arcadoff
    arcadoff
    Participant

    Did by your How-to. Works like a charm on HDMI monitor.

    Does it work on CRT TV?
    If yes, how did you config video settings for runcommand.sh 3 ?
    Getting black screen with every tried setting..
    Thank you!

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar