Error scraping FBA games

This topic contains 6 replies, has 3 voices, and was last updated by  peanut 2 years, 11 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #88523


    Hi for some reason my pi fba games are not scraping.

    I crash to commandline with my keyboard being ‘disconnected’

    Everytime I scrape a fba image it crashes
    but it does save the image it is scrapes followed with a crash to the commandline.

    This is the following error I get to see

    terminate called after throwing an instance of 'boost::filesystem3::filesystem_error’
    what():  boost::filesystem::canonical: No such file or directory: “/home/pi/.emulationstation/downloaded_images/fba/1944-image.jpg”
    /usr/bin/emulationstation: line 11:  2353 Aborted    $es_bin “$@”

    does anyone know the solution?



    Have you tried scraping with sselphs script – it is quicker and more reliable.

    RetroPie help guides -->
    Please read this before asking for help -->



    that is not for mame/neogeo games

    oh it is my bad! thnx hopefully it won’t give any errors

    but seriously though… how is it even possible for the problem that I have to occur… it frustrates me to no end



    The error seems to be because it can’t open
    /home/pi/.emulationstation/downloaded_images/fba/1944-image.jpg for writing.
    There could be a few causes. You can check to see if the folders exist. It should create them for you but if the folder didn’t exist you’d get an error like that. You could also check the permissions of the folders to ensure that everything is writable by pi.

    I didn’t specifically add FBA support but if it is in the it might work with the -mame flag.




    I tried the video using your latest scraper file from the latest releases page.

    followed the video but I get error processing No valid roms found in zip

    it happens to each rom



    You have to add the -mame flag, if you are scraping mame to tell it to use that logic vs the original hashing logic. The original script attempts to locate the rom data and hash the contents even inside zip files but with mame I just look at the name of the zip.




    Thanks I worked somehow 🙂

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss