Error installing RetroPie on Raspbmc

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Error installing RetroPie on Raspbmc

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of fenwick fenwick 2 years, 8 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #71784


    Hi all,

    I’m trying to install RetroPie from the git repo on my Raspbmc installation, but when I run the I encounter the following error:

    Did not find needed package(s): libxkbcommon-dev. I am trying to install them now.
    Hit wheezy Release.gpg
    Hit wheezy Release
    Hit wheezy/main armhf Packages
    Hit wheezy/contrib armhf Packages
    Hit wheezy/non-free armhf Packages
    Ign wheezy/contrib Translation-en
    Ign wheezy/main Translation-en
    Ign wheezy/non-free Translation-en
    Reading package lists...
    Reading package lists...
    Building dependency tree...
    Reading state information...
    E: Unable to locate package libxkbcommon-dev
    Could not install package(s): libxkbcommon-dev. Aborting now.

    It happens when it is installing dependencies for RetroArch.

    I try to do the installation with the binary version.

    I also tried to download the deb package for this lib, but I need to update libc6 tot >= 2.17 but that is not possible, because it’s aborted and not in the apt-get repo.

    Could any one help me?



    Profile photo of fenwick

    This happened to me too. It looks like it’s not in the default apt repositories.

    add the following line to /etc/apt/sources.list file:

    deb wheezy rpi

    then just apt-get install libxkbcommon-dev

    I found the solution here:

    On December 4th, 2013, libxkbcommon-dev is not yet found in Raspbian itself, but it is available from the repository, see above.

    Hope this helps!

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar