Emulators in full screen

This topic contains 3 replies, has 1 voice, and was last updated by Profile photo of borlandoflorida borlandoflorida 2 years, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #42884

    totolnad75

    Hello

    i use an adaptator Hdmi to vga and i want my rom in full screen and not in 4/3 mode or a small size (ex : snes)

    how to do that ?

    #44893
    Profile photo of borlandoflorida
    borlandoflorida
    Participant

    I would imagine you need to edit the config.txt file so that you have the HDMI mode set to VGA.

    So…

    sudo nano /boot/config.txt

    Scroll down to the bit that says

    hdmi_group=1

    If I were changing it, I would put mine something like this:

    hdmi_group=2
    hdmi_mode=35

    This would set the HDMI group to DMT and the resolution to 1280×1024 @ 60Hz.

    Then finally:

    sudo reboot

    You might need to play around with the hdmi_mode to one that works for your monitor / TV. And if you are using a TV, then it might be easier to set the HDMI group to 1 and then pick a HDMI mode that your TV is capable of displaying (I would hazard a guess as hdmi_group=1 then hdmi_mode=4 (which is 720p) or mode=16 (which is 1080p).

    You’ll find a lot of information here if this helps: http://elinux.org/RPiconfig#Video

    #45899

    totolnad75

    thanks for your answer borlandoflorida it very cool your information

    but this features is just for the emulation station, the emulateur is not affect with that, snes, master system, megadrive is in 4/3 mode not in full sreen on my monitor HD 23″

    an other solution

    thanks

    #46501
    Profile photo of borlandoflorida
    borlandoflorida
    Participant

    Ok, I am with you now.

    You need to adjust the settings from within the emulator menu (usually in NES/SNES/Genesis etc it is accessed by pressing F1 on your keyboard).

    Then go into settings -> Video settings, then choose a custom resolution and then adjust to fit your screen.

    You need to save the settings (there is a save function on the main options screen), but this will save the settings as a new .cfg file (usually libretro.cfg or something similar).

    This means when you re-load the emulator, it will load the file retroarch.cfg and not the new one you just created with your new resolutions.

    To fix this, you will need to SSH into your Pi (I use WinSCP so you can browse the file structure) and locate the new libretro.cfg file within the relevant folder (I think it might be in the all folder, but I cannot remember exactly as I’m at work at the moment I have just seen on another topic that the file is saved here: /opt/retropie/emulators/RetroArch/configs), then rename this retroarch.cfg (may be worth backing up the existing retroarch.cfg first by downloading it to your PC desktop) and then reboot the pi.

    If all has gone well, the emulator should boot using the new settings and should now be displaying in full screen!

    PS – This is also very useful when setting up controllers, shaders etc. I would recommend doing it all in one go, then saving the new .cfg file before renaming it to retroarch.cfg otherwise you’ll be constantly to-ing and fro-ing.

    PPS – If you cannot access the emulator menu when you launch the game, it may be because the hotkey option is not working. This requires some SSH-ing and editing of the retroarch.cfg file to set the relevant hotkey (I set my hotkey to F2, so I hold F2 then press F1 to bring up the menu). There is a separate post on this topic here (http://blog.petrockblock.com/forums/topic/how-to-setup-a-controller-in-2-2/#post-13105) which is worth reading too (plus it saves repeating information that is already on this forum).

    Hope this helps!

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar