Emulation Station Keyboard Set-up problems

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! Emulation Station Keyboard Set-up problems

This topic contains 5 replies, has 3 voices, and was last updated by  cliphead 1 year, 11 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #114955


    Hi all, I’m a Retropie n00b so apologies if this is a silly question, help gratefully received. I’ve searched the forums but I can’t find a similar problem described so here goes…

    I have blown a vanilla v3.4 image for RPi v1 onto my SD card and inserted into my Pi B+’s full-size SD slot. At start-up it asks to configure device because I don’t have a controller connected (correct). So I hold a key on my keyboard and it tells me I have a keyboard (great).
    Then I run through the key mappings, key by key. Until the Okay step – no obvious key mapped to do that – pressed the obvious ones, but I somehow fumble my way through it by pressing everything until it goes away.

    Then I’m into the sidescrolling ES home screen. I can navigate left and right no problem, but none of the keys I have mapped activates the “_ Menu” or “A Select” items.

    (There’s nothing special about the keyboard – it’s a cheapo Dell USB keyboard – works fine at the command line.)

    What am I doing wrong?

    Pointer to another article descibing my problem most welcome. Or whatever help you can provide. Thanks in advance.



    Whatever you mapped for the buttons on your keyboard will be the controls you use:




    Thanks Herbfargus – yes, that’s the guide I used.

    “Whatever you mapped for the buttons on your keyboard will be the controls you use”
    I wish that were the case, then I’d have no need to post here. But sadly it’s not.

    I wonder if it’s the muddling through the final “Okay” confirmation (after mapping all the keys) which is causing the problem. What key should I be pressing on my keyboard there?



    It’s in bold on the page youve looked at twice.



    A little cryptic, but I think you’re referring to this:
    “When you get to OK press the button you have configured as “A”.”

    I tried new mappings using the numeric keypad – avoiding the qwerty keyboard and I think I’m getting there now. Note, I had tried mapping A to A, B to B, X to X and Y to errr, Y, and it simply didn’t work …pressing A didn’t do the “A – Select” or “A – Launch” actions. Imagine my confusion. As I get more proficient I’ll go back and try to debug it.



    Hey Spicemuseum,
    I’m also a noob, but I try to help:

    Be sure to setup your keyboard in the raspi-config (Emulationstation->RetroPie->Raspi-Config), if it’s not an international one. I use a Quertz-keyboard, so it had to be changed.
    Since I only use my keyboard for setup or ScummVM games, I mapped it like this:


    Just skip the buttons you don’t need by pressing any button for a long time. If your assigned “A”-Button doesn’t work try the “B”-Button instead. Perhaps they got switched during the process.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss