Emulationstation Looping Back to Menu After Selecting Game

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Emulationstation Looping Back to Menu After Selecting Game

This topic contains 8 replies, has 4 voices, and was last updated by Profile photo of mrsteven2 Steve 2 years, 11 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1782
    Profile photo of jplaj
    jplaj
    Participant

    I ran the setup script on the Raspbian Wheezy distribution, and I have everything working except for one thing. For about 90% of the games I have, hitting the select button to start them takes me to the loading screen (which flashes by too fast to read much text), and then immediately back to the menu.

    The problem is not particular to any specific emulator. There are a handful of games that always work, but most of them don’t.

    Any idea what might be wrong and/or how to fix it?

    Thank you.

    #1784
    Profile photo of petrockblog
    petrockblog
    Keymaster

    If you are using the composite video out, you need to disable the variable HDMI resolution from within the RetroPie Setup Script.

    #1796
    Profile photo of jplaj
    jplaj
    Participant

    Thanks for the help.

    I’ve been running it through HDMI. I disabled the variable HDMI resolution and tried it again, first using the HDMI cable, then switching to composite. Neither one seemed to work–selecting roms still flashes to black briefly, then takes me back to the menu.

    #1830
    Profile photo of petrockblog
    petrockblog
    Keymaster

    For troubleshooting, you could exit Emulation Station by pressing F4 and look at the console output. Maybe that gives some other clues.

    #1846
    Profile photo of jplaj
    jplaj
    Participant

    For most emulators, the result is something like this:

    /home/pi/RetroPie/supplementary/runcommand/runcommand.sh: line 15: /home/pi/RetroPie/emulators/gsps/raspberrypi/gpsp: No such file or directory

    For MAME it’s different:
    Gauntlt1.6p NOT FOUND
    ERROR: required files are missing, the game cannot be run.
    RetroArch [WARN] :: [GL]: Stock GLSL shaders will be used.
    RetroArch [ERROR] :: Implementation does not support save states. Cannot use rewind.

    All roms and MAME files (romset 0.145, but the version doesn’t seem to make much difference)work on other computers. Even when installing an additional .chd file for MAME games, I get the same result.

    I ran the setup script from the beginning to see if an updated version would change anything. Now the problem seems to affect only Sega (Megadrive) and Game Boy Advance.

    #2799
    Profile photo of marcuspatrickwomack
    marcuspatrickwomack
    Participant

    Anyone else found solution to all mame files saying NOT FOUND? I’ve updated but still getting same problem.

    #2801
    Profile photo of jplaj
    jplaj
    Participant

    I’ve found it’s a pretty complex problem. You have to have MAME files from the Mame4all romset, but you also need to have files for the same game from different romsets as well, and you can’t rename any of the files or use ES Scraper for MAME. I don’t understand why it works that way, but I’ve found if I change any one of those things, I can’t play the roms anymore.

    #9298
    Profile photo of clemley6415
    clemley6415
    Participant

    I am having the same issue with a different message. When I attempt to load a NES game, it will make a sound and act as if it is going to load, then flash back to the emulator screen. I have attached a screenshot of the error it is giving me.

    Can anyone tell me what I am doing wrong?

    Thank you!

    Attachments:
    #18417
    Profile photo of mrsteven2
    Steve

    I have the same issue with the exact same error messages you also have pictures of. Im running the b+ model with an N64 controller.

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar