Emulationstation does not run via VNC

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Emulationstation does not run via VNC

This topic contains 0 replies, has 1 voice, and was last updated by  venkatrl 2 years, 10 months ago.

Viewing 1 post (of 1 total)
  • Author
  • #92402


    Hi all,

    I’m running the newest build of Retropie 2.6.0, and I’m experiencing problems running a VNC server (and remotely viewing emulationstation). I’ve installed (and started) tightvnc server using the procedure described here (which worked perfectly with my last build of Retropie).

    This time around, though, I’m not able to start emulationstation from my VNC client. I’m able to use VNC to open a terminal, but launching emulationstation gives the following error:

    “X is running. Please shut down X in order to mitigate problems with loosing (sic) keyboard input. For example, logout from LXDE.”

    Unfortunately, I am unable to stop X from the VNC terminal (without also halting VNC).

    If I run the binary so that it bypasses the X-server check, I still get the following error:

    Xlib: extension “RANDR” missing on display “:1”.
    Keyboard layout unknown, please send the following to the SDL mailing list (sdl@libsdl.org):
    lvl0: Error creating SDL window!
    Could not get EGL display
    lvl0: Renderer failed to initialize!
    lvl0: Window failed to initialize!

    I’d appreciate any thoughts! Thanks, all, in advance.

Viewing 1 post (of 1 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss